Bug 781201

Summary: Provide native systemd service
Product: [Fedora] Fedora Reporter: Jóhann B. Guðmundsson <johannbg>
Component: lcgdmAssignee: Mattias Ellert <mattias.ellert>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: mattias.ellert, steve.traylen
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: lcgdm-1.8.2-3.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-09 04:55:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 751869    
Attachments:
Description Flags
native systemd services along with new path structure and files for daemons none

Description Jóhann B. Guðmundsson 2012-01-12 23:07:03 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2012-01-12 23:08:30 UTC
Created attachment 554949 [details]
native systemd services along with new path structure and files for daemons

Comment 2 Jóhann B. Guðmundsson 2012-01-12 23:14:59 UTC
This set of unit files tshould be acceptable by upstream and usable across distributions using systemd. 

Any reference to /etc/sysconfig has been dropped since it's obsolete and to make it cross distributable. 

If users want to add variables to unit or otherwise edit them they should copy
them to /etc/systemd/system directory and edit them there.

Any /etc/dpm-* and /etc/lfc-* directory can be dropped as far as I can tell

Comment 3 Fedora Update System 2012-03-02 20:20:13 UTC
lcgdm-1.8.2-3.fc16,CGSI-gSOAP-1.3.4.2-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lcgdm-1.8.2-3.fc16,CGSI-gSOAP-1.3.4.2-6.fc16

Comment 4 Fedora Update System 2012-03-02 20:20:30 UTC
lcgdm-1.8.2-3.fc17,CGSI-gSOAP-1.3.4.2-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lcgdm-1.8.2-3.fc17,CGSI-gSOAP-1.3.4.2-6.fc17

Comment 5 Fedora Update System 2012-03-02 20:20:58 UTC
lcgdm-1.8.2-3.fc15,CGSI-gSOAP-1.3.4.2-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lcgdm-1.8.2-3.fc15,CGSI-gSOAP-1.3.4.2-6.fc15

Comment 6 Fedora Update System 2012-03-02 20:21:12 UTC
lcgdm-1.8.2-3.el5,CGSI-gSOAP-1.3.4.2-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/lcgdm-1.8.2-3.el5,CGSI-gSOAP-1.3.4.2-6.el5

Comment 7 Fedora Update System 2012-03-02 20:21:26 UTC
lcgdm-1.8.2-3.el6,CGSI-gSOAP-1.3.4.2-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/lcgdm-1.8.2-3.el6,CGSI-gSOAP-1.3.4.2-6.el6

Comment 8 Fedora Update System 2012-03-05 20:57:21 UTC
Package lcgdm-1.8.2-3.fc17, CGSI-gSOAP-1.3.4.2-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lcgdm-1.8.2-3.fc17 CGSI-gSOAP-1.3.4.2-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2890/lcgdm-1.8.2-3.fc17,CGSI-gSOAP-1.3.4.2-6.fc17
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2012-03-09 04:55:08 UTC
lcgdm-1.8.2-3.fc17, CGSI-gSOAP-1.3.4.2-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2012-03-17 23:49:04 UTC
lcgdm-1.8.2-3.fc15, CGSI-gSOAP-1.3.4.2-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2012-03-17 23:54:29 UTC
lcgdm-1.8.2-3.fc16, CGSI-gSOAP-1.3.4.2-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2012-03-20 20:48:26 UTC
lcgdm-1.8.2-3.el5, CGSI-gSOAP-1.3.4.2-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2012-03-20 20:48:44 UTC
lcgdm-1.8.2-3.el6, CGSI-gSOAP-1.3.4.2-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.