Bug 781837

Summary: RFE: Generate .mobi files
Product: [Community] Publican Reporter: eric <eric>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED WONTFIX QA Contact: Ruediger Landmann <r.landmann>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 2.9CC: herrold, r.landmann, rlandman
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-09 05:25:09 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description eric@christensenplace.us 2012-01-15 10:58:26 EST
Description of problem: Publican should create .mobi files so that users of Kindle devices can utilize Publican-generated goodness.

Calibre can convert from epub to mobi so perhaps we can use this functionality?
Comment 1 Ruediger Landmann 2012-01-15 18:39:54 EST
I like this idea, but this is something that would need to get added upstream, so I'm moving it there.

MobiPerl would probably be a better solution for us than Calibre: https://dev.mobileread.com/trac/mobiperl

Cheers, 
Rudi
Comment 2 R P Herrold 2013-12-05 17:01:35 EST
Mobipler link wend dead -- now outlink seems to be:
   http://www.mobileread.com/forums/showthread.php?t=17718

which in turn has an archive:
   http://www.ida.liu.se/~tompe/mobiperl/downloads/

and an optimistic statement up a level that a dead URL was at one point live
   http://www.ida.liu.se/~tompe/mobiperl/

which seems to have moved into a wiki at:
   http://wiki.mobileread.com/wiki/Mobiperl

The supported formats seem to be:

     html2mobi - Convert HTML file to a MobiPocket file.
    opf2mobi - Convert an opf file structure to a MobiPocket file.
    lit2mobi - Convert a lit file to a MobiPocket file.
    mobi2html - Explode a DRM free MobiPocket file.
    mobi2mobi - Manipulate meta data for a MobiPocket file.
Comment 3 Jeff Fearn 2017-01-09 05:25:09 EST
There are plenty of tools to convert epubs to mobi, so I don;t think there is any need for publican to have this feature. Anyone using such a tool that has problems consuming publican generated epubs can open a bug and we'll try and make them play happily together.