Bug 782284

Summary: CPU flags are truncated to 10 characters
Product: [Community] Beaker Reporter: Steven Lawrance <stl>
Component: inventoryAssignee: Dan Callaghan <dcallagh>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: unspecified    
Version: 0.8CC: bpeck, kzhang, mcsontos, rmancy, stl
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-20 00:39:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Steven Lawrance 2012-01-17 04:39:35 UTC
The CPU flag table has the flag name defined as a String(10), which results in truncation of several flags including 'constant_tsc' and 'flexpriority'.

This affects systems search results when searching on those flags.

Comment 1 Dan Callaghan 2012-05-21 05:17:43 UTC
Bumping to 0.9.1 as this doesn't seem to be too serious.

Comment 2 Dan Callaghan 2012-05-21 05:20:17 UTC
On Gerrit: http://gerrit.beaker-project.org/1077

Comment 4 Steven Lawrance 2012-07-12 05:51:44 UTC
Would it be worth fixing up the truncated cpu flags?

Comment 5 Dan Callaghan 2012-07-12 05:59:54 UTC
How do we know what the original was supposed to be?

They will be fixed the next time inventory is re-run on each system anyway.

Comment 8 Raymond Mancy 2012-07-19 04:01:59 UTC
This cannot be verified properly due to 841398

Comment 9 Raymond Mancy 2012-07-19 06:05:56 UTC
Actually I was able to verify this by making the rpc directly

>>> s.push('mymainframe.funtimes.invalid', {'Cpu': {'CpuFlags': ['thisislongerthan11characters'], 'vendor': 'vendorname', 'model': 'model', 'modelName': 'modeltest', 'family': 'familyname', 'stepping': '1', 'speed': '100', 'processors': '1', 'cores': '1', 'sockets': '1'}})
0
>>>

Comment 10 Dan Callaghan 2012-07-20 00:39:06 UTC
Beaker 0.9.1 has been released.