Bug 782898

Summary: Changing the server port in the UI at Administration/Server doesn't seem to do anything
Product: [Other] RHQ Project Reporter: Mike Foley <mfoley>
Component: Core UIAssignee: RHQ Project Maintainer <rhq-maint>
Status: NEW --- QA Contact: Mike Foley <mfoley>
Severity: unspecified Docs Contact:
Priority: medium    
Version: 4.3CC: dlackey, hrupp
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
notice the URL in the browser = 7080, but the server port on the view = 7090 none

Description Mike Foley 2012-01-18 15:04:50 EST
Created attachment 556108 [details]
notice the URL in the browser = 7080, but the server port on the view = 7090

Description of problem:  Changing the server port in the UI at Administration/Server doesn't seem to do anything.  If you need to edit the server port in rhq-server.properties ... and changing it in the UI does nothing ... then it should probably not be allowed.  It just sets an expectation that something should be changing ... when it doesn't.


Version-Release number of selected component (if applicable):  JON 2.4.2


How reproducible:
100%

Steps to Reproduce:
1.  in the UI, change the server port at Administration/Server from 7080 to 7090
2.  restart the server  ./rhqserver.sh -stop  ... then ./rhqserver.sh -start 
3.  try to access the server at the new port of 7090, ie  http://localhost:7090/coregui   ... 404
4.  try to access the server at the old port of 7080, ie http://localhost:7080/coregui   ... still works. 
  
Actual results:  server port dd not change


Expected results:   server port changes


Additional info:  see attached image