Bug 78458

Summary: ppp can't see internet when there is a local network with gateway
Product: [Retired] Red Hat Linux Reporter: Need Real Name <frud>
Component: pppAssignee: Thomas Woerner <twoerner>
Status: CLOSED NOTABUG QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-08-16 16:13:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2002-11-23 10:45:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
Hello

I am new to Linux. Using RedHat 7.2.

I have the same setup as described in this post and am having the same problem.
I have a small home network with Samba, and a modem to dial into the Internet. 
I
can connect fine with kppp but can't see anything on the Internet (except for
the remote gateway).

I have tried your resolution but that doesn't seem to work either. I have
updated to the latest initscripts, ppp and pam packages using red hat network.

I have also tried adding GATEWAY= and GATEWAYDEV= to the /etc/sysconfig/network
file, with no success.

I have a gateway set up to another machine that also dials to the Internet, so
am able to browse the Internet via the network through that machine. However, I
would also like to be able to use the dial-up as well.

Here is the result of route -n before connecting using kppp:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0

and here is the result of route -n after connnecting using kppp:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
203.167.253.60  0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0

Hope you can help me.

thanks in advance
Faizal


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set up a LAN with ethernet card (assign ip numbers, etc.)
2. Set up a gateway to another computer that accesses internet (as is in my 
case - I use that to access the Internet at the moment)
3. Use kppp to dial to internet (I want to be able to access the Internet via 
the modem on my machine as well)
	

Actual Results:  After kppp connects, can't ping anything on the Internet 
except the remote ppp gateway (that can be found using ifconfig after the 
connection has been established)

Expected Results:  Should be able to see other ip addresses on Internet, to 
enable browsing, etc.

Additional info:

Comment 1 Thomas Woerner 2004-08-16 16:13:43 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.