Bug 785229

Summary: Attempts to open PPTX causes LibreOffice to instantly crash
Product: [Fedora] Fedora Reporter: Máirín Duffy <duffy>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: caolanm, dtardon, erack, ItSANgo, ltinkl, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libreoffice-3.4.5.2-1.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-31 00:12:29 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Máirín Duffy 2012-01-27 12:38:05 EST
Description of problem:
If I open the (private attachment) PPTX attached here, LibreOffice instantly crashes. 

Oddly, ABRT doesn't seem to pick up the crash at all, and I can't seem to get the application to output any kind of error log. Is there any kind of debug mode I could run LibreOffice in to get you more information?

I tried to open it using 

/usr/bin/python /usr/bin/unoconv --format=odp -o output -v 'filename.pptx'

And did get a traceback of sorts:

uno.py:318:_uno_struct__getattr__:AttributeError: ErrCode

Traceback (most recent call last):
  File "/usr/bin/unoconv", line 801, in <module>
    main()
  File "/usr/bin/unoconv", line 780, in main
    convertor.convert(inputfn)
  File "/usr/bin/unoconv", line 690, in convert
    error("ERROR: The provided document cannot be converted to the desired format. (code: %s)" % e.ErrCode)
  File "/usr/lib64/python2.7/site-packages/uno.py", line 318, in _uno_struct__getattr__
    return __builtin__.getattr(self.__dict__["value"],name)
AttributeError: ErrCode

Local variables in innermost frame:
self: Binary URP bridge disposed during call
name: 'ErrCode'

Version-Release number of selected component (if applicable):
libreoffice-impress-3.4.4.2-7.fc16.x86_64
Comment 2 David Tardon 2012-01-28 03:19:27 EST
(In reply to comment #0)
> Oddly, ABRT doesn't seem to pick up the crash at all, and I can't seem to get
> the application to output any kind of error log. Is there any kind of debug
> mode I could run LibreOffice in to get you more information?

No, there is not. Not in the 3.4 series, anyway.
Comment 3 David Tardon 2012-01-28 03:20:39 EST
I cannot reproduce the crash in 3.4.5 or anything newer. It might have been fixed by http://cgit.freedesktop.org/libreoffice/filters/commit/?h=libreoffice-3-4-5&id=5c613fa40a60cbd2c2664783a0aaebee6dfc4309 , but https://bugzilla.novell.com/show_bug.cgi?id=706792 mentioned in the commit message is not publicly accessible (grr, I could scream when I see such a useless reference...)

Could you re-test this with libreoffice-3.4.5.2-1.fc16 from updates testing?
Comment 4 Máirín Duffy 2012-01-28 21:23:18 EST
Oh my goodness, that's amazing, the updates-testing version works perfectly. I'll look for it in Bodhi to give it good karma. thannk you *so much* for the quick reply and fix!!!
Comment 5 Caolan McNamara 2012-01-30 07:00:01 EST
lets call it "modified"
Comment 6 David Tardon 2012-01-31 00:12:29 EST
libreoffice-3.4.5.2-1.fc16 has been pushed into stable -> closing