Bug 785951

Summary: Wireless connection fails requiring reboot
Product: [Fedora] Fedora Reporter: Steven Stern <subscribed-lists>
Component: kernelAssignee: John W. Linville <linville>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: andy, gansalmon, goeran, itamar, jonathan, kernel-maint, madhu.chinakonda, me, mickflemm
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-11 13:57:26 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Steven Stern 2012-01-30 20:05:57 EST
Since installing the latest kernel,  3.2.2-1.fc16.i686.PAE, my wireless connection dies after several hours.  The access point is functioning normally -- all other devices continue to work.  

Once this happens, NetworkManager shows that wireless is enabled, but shows no available networks. Stopping and restarting the service doesn't help. It's necessary to reboot to restore the network connection.

Here's /var/log/messages at the time it went away.

Jan 30 18:15:04 sds-desk kernel: [107165.004357] ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
Jan 30 18:17:04 sds-desk kernel: [107285.004581] ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
Jan 30 18:20:01 sds-desk systemd-logind[1047]: New session 229 of user root.
Jan 30 18:20:01 sds-desk systemd-logind[1047]: Removed session 229.
Jan 30 18:23:04 sds-desk kernel: [107645.004350] ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
Jan 30 18:27:01 sds-desk systemd-logind[1047]: New session 230 of user root.
Jan 30 18:27:02 sds-desk systemd-logind[1047]: Removed session 230.
Jan 30 18:30:01 sds-desk systemd-logind[1047]: New session 231 of user root.
Jan 30 18:30:01 sds-desk systemd-logind[1047]: Removed session 231.
Jan 30 18:30:01 sds-desk systemd-logind[1047]: User root logged out.
Jan 30 18:30:08 sds-desk kernel: [108068.152401] ath5k phy0: gain calibration timeout (2422MHz)
Jan 30 18:30:08 sds-desk kernel: [108068.486736] ath5k phy0: calibration of channel 3 failed
Jan 30 18:30:10 sds-desk kernel: [108070.521094] cfg80211: Calling CRDA to update world regulatory domain
Jan 30 18:30:10 sds-desk kernel: [108070.806151] cfg80211: World regulatory domain updated:
Jan 30 18:30:10 sds-desk kernel: [108070.806157] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Jan 30 18:30:10 sds-desk kernel: [108070.806162] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jan 30 18:30:10 sds-desk kernel: [108070.806168] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Jan 30 18:30:10 sds-desk kernel: [108070.806172] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Jan 30 18:30:10 sds-desk kernel: [108070.806177] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jan 30 18:30:10 sds-desk kernel: [108070.806182] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jan 30 18:30:10 sds-desk NetworkManager[1021]: <info> (wlan0): supplicant interface state: completed -> disconnected
Jan 30 18:30:10 sds-desk NetworkManager[1021]: <info> (wlan0): supplicant interface state: disconnected -> scanning

and it repeats like this until I reboot.
Comment 1 Mohammed Shafi 2012-02-01 06:05:51 EST
looks like an ath5k bug
Comment 2 John W. Linville 2012-02-01 10:52:00 EST
Ooops, you're right! :-)
Comment 3 Steven Stern 2012-02-11 13:57:08 EST
Seems to be better with 3.2.503
Comment 4 Andrew Haveland-Robinson 2012-03-06 05:10:25 EST
I'm using 3.2.8-3.fc16.i686 on ASUS EEE running as my wifi/eth router,
and it is still broken.
Not a happy bunny.
After lots of research this bug has been surfacing on and off over the last two or three years.
Can't anyone fix it make sure that it stays fixed?
Comment 5 Andrew Haveland-Robinson 2012-03-06 05:12:02 EST
Mar  6 11:07:24 mars kernel: [476396.901345] ath5k phy0: gain calibration timeout (2422MHz)
Mar  6 11:07:26 mars kernel: [476398.576499] ath5k phy0: gain calibration timeout (2422MHz)
Mar  6 11:07:28 mars kernel: [476400.251684] ath5k phy0: gain calibration timeout (2422MHz)
Mar  6 11:07:29 mars kernel: [476401.926785] ath5k phy0: gain calibration timeout (2422MHz)
Mar  6 11:07:31 mars kernel: [476403.605110] ath5k phy0: gain calibration timeout (2422MHz)
Mar  6 11:07:33 mars kernel: [476405.280666] ath5k phy0: gain calibration timeout (2422MHz)
Mar  6 11:07:34 mars kernel: [476406.956514] ath5k phy0: gain calibration timeout (2422MHz)
Mar  6 11:07:36 mars kernel: [476408.632004] ath5k phy0: gain calibration timeout (2422MHz)