Bug 78672

Summary: Nautilus ignores "Ask before emptying Trash or deleting files" preference
Product: [Retired] Red Hat Linux Reporter: Michael Lee Yohe <michael>
Component: nautilusAssignee: Alexander Larsson <alexl>
Status: CLOSED CANTFIX QA Contact: Jay Turner <jturner>
Severity: low Docs Contact:
Priority: medium    
Version: 8.0CC: srevivo
Target Milestone: ---Keywords: MoveUpstream
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-10-18 14:31:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79600    

Description Michael Lee Yohe 2002-11-27 10:35:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Nautilus includes the ability to remove its dialog box asking you if you wish to
move a file to the Trash or delete the file.

The current behavior is as such in Nautilus:
1) If file is located on the same partition as ~/.Trash - move the file to the
~/.Trash and catalog.
2) If file is not located on the same partition as ~/.Trash - delete the file
(asking the user).

Understanding this behavior - if I uncheck "Ask before emptying Trash or
DELETING FILES", I should have the ability to simply click and "Del" to my
heart's content.  If so desired, a dialog box could pop up warning the user
_THEN_ that removing this preference could cause a user to inadvertently
permanently delete files.

However, if I go to /tmp on my system (which resides in a different partition),
Nautilus still pops up a dialog box informing me that it is unable to move the
file to the Trash and asks if I wish to permanently delete the file.

This is related to another bug I filed - Bug 78671.  "Fixing" bug 78671 is
definitely the preferable option (but would take longer than simply correcting
this bug).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open a Nautilus window
2. Go to Edit -> Preferences -> Desktop & Trash
3. Uncheck "Ask before emptying Trash or deleting files"
4. Close configuration window
5. Go to another partition
6. Click on a file to delete and press "Del".
	

Actual Results:  A dialog box pops up (ASKing before deleting a file).

Expected Results:  File should be removed.  Done and done.

Additional info:

$ rpm -q nautilus
nautilus-2.0.6-6
Comment 1 Havoc Pennington 2002-12-16 13:20:55 EST
Changing to MoveUpstream keyword instead of GnomeUpstream tracking bug.
sorry about the spam.
Comment 2 Alexander Larsson 2004-10-04 08:57:23 EDT
I can't reproduce this with 2.8.0. Do you still see this in fc3test3?
Comment 3 Bill Nottingham 2006-10-18 14:31:56 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.