Bug 787776

Summary: RHEL6.1 - Netfs fails to unmount unreachable NFS filesystems
Product: Red Hat Enterprise Linux 6 Reporter: Nathan Galvin <ngalvin>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED NOTABUG QA Contact: Filesystem QE <fs-qe>
Severity: high Docs Contact:
Priority: urgent    
Version: 6.1CC: david.halliwell, hannsj_uhl, harald, initscripts-maint-list, jcapik, kchin, ksquizza, mishu, mpoole, nkuriako, pchavan, pm-rhel, rvokal, tlavigne
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-04-01 05:58:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 782183, 836160, 994246, 1056252, 840699, 843526    

Description Nathan Galvin 2012-02-06 12:23:58 EST
Other similar bugs.
- https://bugzilla.redhat.com/show_bug.cgi?id=750926
- https://bugzilla.redhat.com/show_bug.cgi?id=735458

Description of the problem:

The netfs service fails to unmount NFS filesystems when the NFS server is unreachable.  
The system hangs on shutdown.

How reproducible:

Reproducible for RHEL 6.1 systems using NFS filesystems.
initscripts version: initscripts-9.03.23-1.el6.x86_64


Steps to Reproduce:

1.  mkdir /mnt/mountpoint
2.  mount nfsserver:/path /mnt/mountpoint
3.  initiate traffic to mount (large file copy)
4.  /etc/init.d/network stop
5.  /etc/init.d/netfs stop
6.  wait indefinately, the netfs stop never completes.

7.  in another terminal shutdown the system, 'shutdown -ry now'

Actual results:

netfs will hang while attempting to unmount the NFS filesystem.

Then, if a shutdown is issued, it also hangs during;

Unmounting NFS filesystems:  umount.nfs: /NFS: device is busy
umount.nfs: /NFS: device is busy     [FAILED]


Expected results:

netfs should unmount the NFS filesystem.

shutdown should shutdown the system.
Comment 2 Bill Nottingham 2012-02-06 15:01:50 EST
Moving to psmisc; ideally, fuser would not hang in this case.

We can't check the umount return without screenscraping, and that's not very
reliable.
Comment 4 Suzanne Yeghiayan 2012-02-14 18:31:12 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 30 Lukáš Nykrýn 2014-03-19 10:54:44 EDT
I am really clueless what we could do here. lazy umount leads to hangs in the kernel, normal umount leads to hangs in netfs. I am reassigning to nfs-utils, since that is owner of umount.nfs. Maybe they can figure some solution there
Comment 31 Lukáš Nykrýn 2014-03-19 10:56:51 EDT
*** Bug 843526 has been marked as a duplicate of this bug. ***
Comment 32 Steve Dickson 2014-04-01 05:58:44 EDT
NFS unmounts will hang when the server is not reachable. The is by 
design to ensure all data is flushed back to the server, when it comes
back up. There is nothing umount.nfs can do in this situation.