Bug 787830

Summary: [abrt] kernel: WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]()
Product: [Fedora] Fedora Reporter: amylaar
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:544430bc6ee06fa9102b59a169eb0da78ed5f155
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-06 17:08:29 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description amylaar 2012-02-06 15:57:29 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.3-2.fc16.i686.PAE root=/dev/mapper/vg_helium-LogVol00 ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_helium/LogVol00 rd.lvm.lv=vg_helium/LogVol01 quiet SYSFONT=latarcyrheb-sun16 rhgb KEYTABLE=uk rd.luks=0 LANG=en_US.UTF-8
comment:        I've been testing the newly available wireless connectivity under Fedora by installing a few software packages.
kernel:         3.2.3-2.fc16.i686.PAE
reason:         WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]()
time:           Mon 06 Feb 2012 08:46:14 PM GMT

backtrace:
:WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]()
:Hardware name: 1015PX
:Modules linked in: fuse lockd rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state ip6table_filter nf_conntrack ip6_tables arc4 snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer btusb brcmsmac snd mac80211 bluetooth brcmutil eeepc_wmi asus_wmi cfg80211 uvcvideo sparse_keymap atl1c soundcore crc8 cordic bcma videodev media microcode snd_page_alloc iTCO_wdt rfkill iTCO_vendor_support joydev sunrpc uinput wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 54, comm: kworker/u:4 Not tainted 3.2.3-2.fc16.i686.PAE #1
:Call Trace:
: [<c0933042>] ? printk+0x2d/0x2f
: [<c045e352>] warn_slowpath_common+0x72/0xa0
: [<f8588b1a>] ? brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]
: [<f8588b1a>] ? brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]
: [<c045e3a2>] warn_slowpath_null+0x22/0x30
: [<f8588b1a>] brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]
: [<f857b150>] brcms_ops_flush+0x30/0x50 [brcmsmac]
: [<f8714048>] ieee80211_scan_work+0x328/0x570 [mac80211]
: [<c0939f91>] ? __schedule+0x391/0x8b0
: [<c04774da>] process_one_work+0xfa/0x390
: [<c093cea9>] ? apic_timer_interrupt+0x31/0x38
: [<f8713d20>] ? ieee80211_scan_rx+0x1b0/0x1b0 [mac80211]
: [<c04781d1>] worker_thread+0x121/0x2d0
: [<c04780b0>] ? manage_workers+0x1f0/0x1f0
: [<c047c36d>] kthread+0x6d/0x80
: [<c047c300>] ? kthread_worker_fn+0x140/0x140
: [<c0943a3e>] kernel_thread_helper+0x6/0x10

smolt_data:
:
:
:General
:=================================
:UUID: fcef771f-ab3a-40fc-8f19-ad7fb56d2a99
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 3333.23
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Atom(TM) CPU N570   @ 1.66GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 28
:Number of CPUs: 4
:CPU Speed: 1667
:System Memory: 992
:System Swap: 4095
:Vendor: ASUSTeK Computer INC.
:System: 1015PX x.x
:Form factor: Notebook
:Kernel: 3.2.3-2.fc16.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10172:4163:33709) pci, None, PCI/ISA, NM10 Family LPC Controller
:(5348:18215:6715:8263) pci, bcma-pci-bridge, NETWORK, BCM4313 802.11b/g/n Wireless LAN Controller
:(32902:40977:4163:33708) pci, i915, VIDEO, N10 Family Integrated Graphics Controller
:(32902:40978:4163:33708) pci, None, VIDEO, N10 Family Integrated Graphics Controller
:(32902:10192:4163:33709) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:4163:33709) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(6505:8290:4163:33896) pci, atl1c, ETHERNET, AR8152 v2.0 Fast Ethernet
:(32902:10200:4163:33847) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10177:4163:33709) pci, ahci, STORAGE, N10/ICH7 Family SATA AHCI Controller
:(32902:9288:4163:33709) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10198:4163:33709) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 4
:(32902:10185:4163:33709) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4163:33709) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:40976:4163:33708) pci, agpgart-intel, HOST/PCI, N10 Family DMI Bridge
:(32902:10186:4163:33709) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10187:4163:33709) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:4163:33709) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_helium-LogVol00 / ext4 4096 4096 5103904 3786859 3530859 1281120 1074077 1074077
:/dev/mapper/vg_helium-LogVol01 /boot ext4 4096 4096 130557 106622 100069 32768 32541 32541
:/dev/mapper/vg_helium-LogVol02 /home ext4 4096 4096 21076682 20711851 19656312 5283840 5283355 5283355
:
Comment 1 Dave Jones 2012-02-06 17:08:29 EST

*** This bug has been marked as a duplicate of bug 787649 ***