Bug 788335

Summary: [abrt] kernel: WARNING: at drivers/gpu/drm/i915/i915_irq.c:652 ironlake_irq_handler+0x4ea/0x500 [i915]()
Product: [Fedora] Fedora Reporter: Peter Portante <pportant>
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: ajax, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:0777503c0abb82342641a0f4452844d7470c1ba0
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-13 12:38:14 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Peter Portante 2012-02-07 23:22:11 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.3-2.fc16.x86_64 root=/dev/mapper/vg_frodo-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_frodo/lv_root KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks.uuid=luks-477b3b96-9330-4763-8f78-d689fb00bfba rd.lvm.lv=vg_frodo/lv_swap LANG=en_US.UTF-8
comment:        Not sure what happened, but running a test program that uses cgroups.
kernel:         3.2.3-2.fc16.x86_64
reason:         WARNING: at drivers/gpu/drm/i915/i915_irq.c:652 ironlake_irq_handler+0x4ea/0x500 [i915]()
time:           Tue 07 Feb 2012 10:39:20 PM EST

backtrace:
:WARNING: at drivers/gpu/drm/i915/i915_irq.c:652 ironlake_irq_handler+0x4ea/0x500 [i915]()
:Hardware name: 4243B37
:Missed a PM interrupt
:Modules linked in: tun tcp_lp ppdev parport_pc lp parport fuse 8021q garp stp llc fcoe lockd libfcoe libfc scsi_transport_fc scsi_tgt rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack binfmt_misc snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm iTCO_wdt btusb bluetooth uvcvideo videodev media v4l2_compat_ioctl32 arc4 iwlwifi mac80211 cfg80211 thinkpad_acpi iTCO_vendor_support i2c_i801 snd_timer rfkill snd_page_alloc tpm_tis tpm e1000e snd soundcore tpm_bios joydev uinput microcode sunrpc xts gf128mul dm_crypt firewire_ohci sdhci_pci sdhci firewire_core mmc_core crc_itu_t wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 2383, comm: gnome-terminal Not tainted 3.2.3-2.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff8106dd4f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8106de46>] warn_slowpath_fmt+0x46/0x50
: [<ffffffffa007981a>] ironlake_irq_handler+0x4ea/0x500 [i915]
: [<ffffffff810de335>] handle_irq_event_percpu+0x55/0x220
: [<ffffffff81056395>] ? check_preempt_curr+0x75/0xa0
: [<ffffffff810de544>] handle_irq_event+0x44/0x70
: [<ffffffff810e16ca>] handle_edge_irq+0x7a/0x120
: [<ffffffff810161a6>] handle_irq+0x46/0xb0
: [<ffffffff815ec29a>] do_IRQ+0x5a/0xe0
: [<ffffffff815e1c2e>] common_interrupt+0x6e/0x6e
: <EOI>  [<ffffffff810592aa>] ? finish_task_switch+0x4a/0xe0
: [<ffffffff815df114>] __schedule+0x3d4/0x8c0
: [<ffffffff815df91f>] schedule+0x3f/0x60
: [<ffffffff815e09fc>] schedule_hrtimeout_range_clock+0x12c/0x170
: [<ffffffff81093900>] ? update_rmtp+0x70/0x70
: [<ffffffff81094614>] ? hrtimer_start_range_ns+0x14/0x20
: [<ffffffff815e0a53>] schedule_hrtimeout_range+0x13/0x20
: [<ffffffff8118b4f9>] poll_schedule_timeout+0x49/0x70
: [<ffffffff8118c9ab>] do_sys_poll+0x37b/0x500
: [<ffffffff8118b600>] ? poll_freewait+0xe0/0xe0
: [<ffffffff8118b6f0>] ? __pollwait+0xf0/0xf0
: [<ffffffff8118b6f0>] ? __pollwait+0xf0/0xf0
: [<ffffffff8118b6f0>] ? __pollwait+0xf0/0xf0
: [<ffffffff8118b6f0>] ? __pollwait+0xf0/0xf0
: [<ffffffff8118b6f0>] ? __pollwait+0xf0/0xf0
: [<ffffffff8118b6f0>] ? __pollwait+0xf0/0xf0
: [<ffffffff8118b6f0>] ? __pollwait+0xf0/0xf0
: [<ffffffff8118b6f0>] ? __pollwait+0xf0/0xf0
: [<ffffffff8118b6f0>] ? __pollwait+0xf0/0xf0
: [<ffffffff8101b3b9>] ? read_tsc+0x9/0x20
: [<ffffffff810997ed>] ? ktime_get_ts+0xad/0xe0
: [<ffffffff8118b8ea>] ? poll_select_set_timeout+0x7a/0x90
: [<ffffffff8118cc16>] sys_poll+0x76/0x110
: [<ffffffff815e9782>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: 1f04c76f-c1ca-4fb0-9d5e-33733f8d191f
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5382.56
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2701
:System Memory: 7870
:System Swap: 10015
:Vendor: LENOVO
:System: 4243B37 ThinkPad T520
:Form factor: Notebook
:Kernel: 3.2.3-2.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7247:6058:8655) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(4480:59427:6058:8655) pci, sdhci-pci, BASE, N/A
:(32902:294:6058:8655) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7192:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8655) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7213:6058:8655) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7202:6058:8655) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(4480:59442:6058:8655) pci, firewire_ohci, FIREWIRE, FireWire Host Controller
:(32902:16952:32902:4369) pci, iwlwifi, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:(32902:7171:6058:8655) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7229:6058:8655) pci, serial, 16550_SERIAL, 6 Series/C200 Series Chipset Family KT Controller
:(32902:7206:6058:8655) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8655) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8655) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_frodo-lv_root / ext4 4096 4096 13092026 10800461 10669439 3276800 3009909 3009909
:/dev/sda1 /boot ext4 1024 1024 508745 409551 383951 128016 127739 127739
:/dev/mapper/vg_frodo-lv_home /home ext4 4096 4096 106175076 104108052 98793492 26574848 26554298 26554298
:
Comment 1 Adam Jackson 2012-02-13 12:38:14 EST

*** This bug has been marked as a duplicate of bug 755144 ***