Bug 788775

Summary: trac: please update to version 0.12.3
Product: [Fedora] Fedora Reporter: Jose Pedro Oliveira <jose.p.oliveira.oss>
Component: tracAssignee: Gwyn Ciesla <gwync>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dcantrell, fschwarz, gwync
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: trac-0.12.3-2.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-13 01:57:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jose Pedro Oliveira 2012-02-09 00:00:59 UTC
Description of problem:
Please update trac to version 0.12.3. 

Expected results:
Trac 0.12.3 RPMS for rawhide, F-17, F-16 and EPEL-6.

Additional info:
 * Trac 0.12.3 changelog (highlights)
   http://trac.edgewall.org/wiki/ChangeLog#a0.12.3

 * Trac 0.12.3 closed tickets (81 tickets)
   http://trac.edgewall.org/milestone/0.12.3

Comment 1 Fedora Update System 2012-02-09 16:27:21 UTC
trac-0.12.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/trac-0.12.3-1.fc15

Comment 2 Fedora Update System 2012-02-09 16:27:30 UTC
trac-0.12.3-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/trac-0.12.3-1.el6

Comment 3 Fedora Update System 2012-02-09 16:27:39 UTC
trac-0.12.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/trac-0.12.3-1.fc16

Comment 4 Fedora Update System 2012-02-10 00:47:15 UTC
Package trac-0.12.3-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing trac-0.12.3-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1472/trac-0.12.3-1.fc16
then log in and leave karma (feedback).

Comment 5 Jose Pedro Oliveira 2012-02-11 01:59:54 UTC
Hi,

The EPEL6 upgrade has problems as the trac site disappears as the apache trac configuration file gets renamed. This affects EPEL users who are still depending on mod_python/trac.conf.


yum log:
----------
# yum update --enablerepo=epel-testing trac
...
Running Transaction
  Updating   : trac-0.12.3-1.el6.noarch                                 1/2 
  Cleanup    : trac-0.12.2-1.el6.noarch                                 2/2 
warning: /etc/httpd/conf.d/trac.conf saved as /etc/httpd/conf.d/trac.conf.rpmsave
...
----------


rpmdiff between the EPEL6 releases:
----------
rpmdiff trac-0.12.2-1.el6.src.rpm trac-0.12.3-1.el6.src.rpm
..........T 0001-Make-sure-we-use-the-right-python-genshi.patch
removed     Trac-0.12.2.tar.gz
added       Trac-0.12.3.tar.gz
S.5.......T trac-README.fedora
removed     trac.conf
..........T trac.ini
..........T trac.ini-environment_sample
S.5.......T trac.spec
added       trac.wsgi
----------


Note the removal of trac.conf.

/jpo

Comment 6 Gwyn Ciesla 2012-02-13 15:30:18 UTC
This looks like the result of 720760.

Comment 7 Jose Pedro Oliveira 2012-02-14 01:35:10 UTC
(In reply to comment #6)
> This looks like the result of 720760.

More likely this change:

---------
* Tue Jun 14 2011 Jon Ciesla <limb@jcomserv.net> - 0.12.2-5
- Added .wsgi file, BZ 701762.
- No longer ship mod_python trac.conf, deprecated.
----------

that was only pushed for Fedora builds (Fedora 15 and above).

jpo

Comment 8 Fedora Update System 2012-04-27 20:48:05 UTC
trac-0.12.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2012-04-27 20:50:36 UTC
trac-0.12.3-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2012-05-04 14:25:33 UTC
trac-0.12.3-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/trac-0.12.3-2.fc15

Comment 11 Fedora Update System 2012-05-04 14:25:48 UTC
trac-0.12.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/trac-0.12.3-2.fc16

Comment 12 Fedora Update System 2012-05-04 14:26:05 UTC
trac-0.12.3-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/trac-0.12.3-2.el6

Comment 13 Fedora Update System 2012-05-04 14:26:21 UTC
trac-0.12.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/trac-0.12.3-2.fc17

Comment 14 Jose Pedro Oliveira 2012-05-05 11:13:41 UTC
Re-opening as the EPEL upgrade is still problematic (see comment #5).

Comment 15 Gwyn Ciesla 2012-05-07 14:53:49 UTC
Sorry, fix on the way.

Comment 16 Fedora Update System 2012-05-07 15:01:27 UTC
trac-0.12.3-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/trac-0.12.3-3.el6

Comment 17 Fedora Update System 2012-05-07 22:10:57 UTC
Package trac-0.12.3-3.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing trac-0.12.3-3.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-5806/trac-0.12.3-3.el6
then log in and leave karma (feedback).

Comment 18 Jose Pedro Oliveira 2012-05-08 14:11:29 UTC
Jon,

Thanks for the EPEL update. I'll try it ASAP.

/jpo

Comment 19 Fedora Update System 2012-05-13 01:57:50 UTC
trac-0.12.3-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2012-05-13 01:58:32 UTC
trac-0.12.3-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2012-05-22 15:38:58 UTC
trac-0.12.3-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2012-05-26 07:38:14 UTC
trac-0.12.3-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.