This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 790546

Summary: [abrt] kernel: kernel BUG at mm/mmap.c:2378!
Product: [Fedora] Fedora Reporter: Tony Browning <ttonybrowning>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:dab3455761d2f02d89f2082157a51c577af96ad3
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-17 00:30:26 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tony Browning 2012-02-14 14:52:34 EST
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.0-7.fc16.i686 root=/dev/mapper/vg_toshiba-lv_root ro nomodeset rd.lvm.lv=vg_toshiba/lv_swap rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.md=0 rd.luks=0 rd.lvm.lv=vg_toshiba/lv_root LANG=en_US.UTF-8
comment:        New Fedora 16 Verne install. Now have kernel 3.1.0-0.rc6.git0.3.fc16.i686 32bit and have one that is the same kernel version but a (Recovery) kernel. Now have another kernel that I'm trying out also, version kernel3.1.0-7fc16.i686.rpm. Done the 368 updates that one always views after a new Fedora install. But, I do not know why it crashed. Supposedly, a new bug report has been filed with Bugzilla and Logger, #790510.
kernel:         undefined
reason:         kernel BUG at mm/mmap.c:2378!
time:           Tue Feb 14 03:45:34 2012

backtrace:
:kernel BUG at mm/mmap.c:2378!
:invalid opcode: 0000 [#1] SMP 
:Modules linked in: tcp_lp ppdev parport_pc lp parport fuse 8021q garp stp llc fcoe libfcoe libfc scsi_transport_fc scsi_tgt ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_si3054 snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device arc4 snd_pcm tifm_7xx1 tifm_core e100 mii iwl3945 iwl_legacy mac80211 cfg80211 iTCO_wdt iTCO_vendor_support snd_timer snd soundcore rfkill snd_page_alloc joydev microcode i2c_i801 serio_raw uinput yenta_socket sdhci_pci sdhci mmc_core firewire_ohci firewire_core crc_itu_t i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 15146, comm: ld-linux.so.2 Not tainted 3.1.0-7.fc16.i686 #1 TOSHIBA Satellite A100/MPAD-MSAE Customer Reference Boards
:EIP: 0060:[<c04cd9a1>] EFLAGS: 00010202 CPU: 0
:EIP is at exit_mmap+0xd0/0xda
:EAX: 00000000 EBX: 00000000 ECX: f5d8d934 EDX: f5408a30
:ESI: f66d8200 EDI: bfb0d000 EBP: e1389f04 ESP: e1389eac
: DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
:Process ld-linux.so.2 (pid: 15146, ti=e1388000 task=f6ad25b0 task.ti=e1388000)
:Stack:
: 00000000 e1389ef4 00000000 f66d8200 e4153528 00000001 e1389ec8 00000000
: 00000000 00000008 f6000580 f5babd80 f60d5fa0 f60effc0 f60e6080 f60abce0
: f60ee5c0 f60c7e20 000005d2 f66d8200 f66d8200 00000000 e1389f14 c043ab22
:Call Trace:
: [<c043ab22>] mmput+0x57/0xb7
: [<c043f74f>] exit_mm+0x10a/0x112
: [<c043f978>] do_exit+0x221/0x65a
: [<c043ffc5>] do_group_exit+0x6a/0x93
: [<c0440006>] sys_exit_group+0x18/0x18
: [<c0810b0c>] syscall_call+0x7/0xb
:Code: e8 80 ad ff ff 8d 45 b4 89 f9 31 d2 e8 a5 aa ff ff 89 f0 e8 08 4b f3 ff 89 d8 e8 c4 ec ff ff 85 c0 89 c3 75 f3 83 7e 78 00 74 02 <0f> 0b 83 c4 4c 5b 5e 5f 5d c3 55 89 e5 56 53 83 ec 14 3e 8d 74 
:EIP: [<c04cd9a1>] exit_mmap+0xd0/0xda SS:ESP 0068:e1389eac

event_log:
:2012-02-14-14:47:55> Smolt profile successfully saved
:2012-02-14-14:55:43> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2012-02-14-14:56:47  Kernel oops has not been sent due to Couldn't connect to server
:2012-02-14-14:56:47* (exited with 1)

smolt_data:
:
:
:General
:=================================
:UUID: 219ed543-db70-45fe-898b-43908bcb897e
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 3457.60
:CPU Vendor: GenuineIntel
:CPU Model: Genuine Intel(R) CPU           T2250  @ 1.73GHz
:CPU Stepping: 8
:CPU Family: 6
:CPU Model Num: 14
:Number of CPUs: 2
:CPU Speed: 1733
:System Memory: 993
:System Swap: 2015
:Vendor: TOSHIBA
:System: Satellite A100 PSB10U-SA10ES1
:Form factor: Other
:Kernel: 3.1.0-7.fc16.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4172:32827:4473:65296) pci, tifm_7xx1, STORAGE, 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
:(32902:4242:4473:65296) pci, e100, ETHERNET, PRO/100 VE Network Connection
:(32902:10144:4473:65296) pci, agpgart-intel, HOST/PCI, Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub
:(4172:32826:4473:65296) pci, firewire_ohci, FIREWIRE, PCIxx12 OHCI Compliant IEEE 1394 Host Controller
:(4172:32825:4473:65296) pci, yenta_cardbus, PCI/CARDBUS, PCIxx12 Cardbus Controller
:(4172:32828:4473:65296) pci, sdhci-pci, BASE, PCIxx12 SDA Standard Compliant SD Host Controller
:(32902:10169:4473:65296) pci, None, PCI/ISA, 82801GBM (ICH7-M) LPC Interface Bridge
:(32902:10196:4473:65296) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 3
:(32902:9288:4473:65296) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10185:4473:65296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4473:65296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10187:4473:65296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10186:4473:65296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10188:4473:65296) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:(32902:10146:4473:65296) pci, None, VIDEO, Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
:(32902:10150:4473:65296) pci, None, VIDEO, Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
:(32902:10192:4473:65296) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:4473:65296) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(32902:10200:4473:65296) pci, snd_hda_intel, MULTIMEDIA, Toshiba Satellite A100-796 audio (Realtek ALC861)
:(32902:10202:4473:65296) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:16930:32902:4160) pci, iwl3945, NETWORK, PRO/Wireless 3945ABG [Golan] Network Connection
:(32902:10180:4473:65296) pci, ata_piix, STORAGE, 82801GBM/GHM (ICH7 Family) SATA IDE Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_toshiba-lv_root / ext4 4096 4096 12901535 11988050 11857028 3276800 3164599 3164599
:/dev/sda1 /boot ext4 1024 1024 495844 438481 412881 128016 127792 127792
:/dev/mapper/vg_toshiba-lv_home /home ext4 4096 4096 10498372 10416685 9883386 2670592 2670073 2670073
:
Comment 1 Josh Boyer 2012-02-14 20:17:14 EST
Can you recreate this on the 3.2.x series of kernels now found in the stable update repositories?
Comment 2 Dave Jones 2012-02-17 00:30:26 EST

*** This bug has been marked as a duplicate of bug 786632 ***