Bug 79066

Summary: Severe keybord input corruption for many locales
Product: [Retired] Red Hat Linux Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: high    
Version: 7.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-05 09:44:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79062    

Description Nicolas Mailhot 2002-12-05 09:41:05 UTC
The speakup patch included in recent Red Hat kernels messes up <ALT-GR> key
processing.

This is a major key on many european keybords. For example on a french keyboard
you need it to access <~>, <#>, <{>, <[>, <|>, <`>, <\>, <^>, <@>, <]>, <}>.

The bug occurs both on the console and in X. While not systematic (i.e not for
each key strike), it *will* occur during any meaningful user activity.

It was first reported in NULL, went into 8.0, and was propagated to Red Hat 7.0,
7.1, 7.2 and 7.3 via Red Hat errata.

There has been no public Red Hat activity on this bug since august 2002.

This is the 7.0 specific bug report.

Comment 1 Arjan van de Ven 2002-12-05 09:53:18 UTC

*** This bug has been marked as a duplicate of 79062 ***