Bug 794559

Summary: [abrt] kernel: kernel BUG at mm/mmap.c:2378!
Product: [Fedora] Fedora Reporter: Tony Browning <ttonybrowning>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:7e80f0e3bebff5d3206fe4029f8973f1430b6b5a
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-17 00:30:31 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tony Browning 2012-02-17 00:25:18 EST
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.0-7.fc16.i686 root=/dev/mapper/vg_toshiba-lv_root ro nomodeset rd.lvm.lv=vg_toshiba/lv_swap rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.md=0 rd.luks=0 rd.lvm.lv=vg_toshiba/lv_root LANG=en_US.UTF-8
comment:        firefox keep freeze or crash, then on logout and start up this crash.
kernel:         undefined
reason:         kernel BUG at mm/mmap.c:2378!
time:           Fri Feb 17 00:25:51 2012

backtrace:
:kernel BUG at mm/mmap.c:2378!
:invalid opcode: 0000 [#1] SMP 
:Modules linked in: tcp_lp ppdev parport_pc lp parport fuse 8021q garp stp llc fcoe libfcoe libfc scsi_transport_fc scsi_tgt ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_conntrack_ipv4 nf_defrag_ipv4 ip6_tables xt_state nf_conntrack snd_hda_codec_si3054 snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device arc4 snd_pcm iwl3945 iwl_legacy tifm_7xx1 tifm_core mac80211 e100 mii cfg80211 snd_timer snd i2c_i801 iTCO_wdt iTCO_vendor_support microcode rfkill joydev soundcore snd_page_alloc serio_raw uinput yenta_socket sdhci_pci sdhci firewire_ohci firewire_core mmc_core crc_itu_t i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 3377, comm: gdm-simple-slav Not tainted 3.1.0-7.fc16.i686 #1 TOSHIBA Satellite A100/MPAD-MSAE Customer Reference Boards
:EIP: 0060:[<c04cd9a1>] EFLAGS: 00010206 CPU: 0
:EIP is at exit_mmap+0xd0/0xda
:EAX: 00000000 EBX: 00000000 ECX: 00021ff5 EDX: 00021ff4
:ESI: f05d0200 EDI: bfcb1000 EBP: ea891e68 ESP: ea891e10
: DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
:Process gdm-simple-slav (pid: 3377, ti=ea890000 task=f671cb60 task.ti=ea890000)
:Stack:
: 00000000 ea891e58 00000000 f05d0200 2542c468 00000001 ea891e2c 00000000
: 00000000 00000008 f6000580 f5e2bd00 f5a443e0 f60b08a0 f606a1c0 f5f006a0
: f5f006c0 f6094dc0 000008bc f05d0200 f05d0000 f05d0200 ea891e78 c043ab22
:Call Trace:
: [<c043ab22>] mmput+0x57/0xb7
: [<c04f0054>] flush_old_exec+0x458/0x527
: [<c051ec08>] load_elf_binary+0x2b3/0xfef
: [<c059d6eb>] ? process_measurement+0x43/0xaa
: [<c04efa4e>] search_binary_handler+0xad/0x241
: [<c051e955>] ? load_elf_library+0x20d/0x20d
: [<c04f06be>] do_execve+0x19d/0x25e
: [<c0408f38>] sys_execve+0x36/0x5d
: [<c081666e>] ptregs_execve+0x12/0x18
: [<c0810b0c>] ? syscall_call+0x7/0xb
: [<c0810000>] ? schedule_hrtimeout_range_clock+0xa4/0xda
:Code: e8 80 ad ff ff 8d 45 b4 89 f9 31 d2 e8 a5 aa ff ff 89 f0 e8 08 4b f3 ff 89 d8 e8 c4 ec ff ff 85 c0 89 c3 75 f3 83 7e 78 00 74 02 <0f> 0b 83 c4 4c 5b 5e 5f 5d c3 55 89 e5 56 53 83 ec 14 3e 8d 74 
:EIP: [<c04cd9a1>] exit_mmap+0xd0/0xda SS:ESP 0068:ea891e10

event_log:
:2012-02-17-00:27:54> Smolt profile successfully saved
:2012-02-17-00:28:30> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2012-02-17-00:29:34  Kernel oops has not been sent due to Couldn't connect to server
:2012-02-17-00:29:34* (exited with 1)

smolt_data:
:
:
:General
:=================================
:UUID: 219ed543-db70-45fe-898b-43908bcb897e
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 3457.99
:CPU Vendor: GenuineIntel
:CPU Model: Genuine Intel(R) CPU           T2250  @ 1.73GHz
:CPU Stepping: 8
:CPU Family: 6
:CPU Model Num: 14
:Number of CPUs: 2
:CPU Speed: 1733
:System Memory: 993
:System Swap: 2015
:Vendor: TOSHIBA
:System: Satellite A100 PSB10U-SA10ES1
:Form factor: Other
:Kernel: 3.1.0-7.fc16.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4172:32827:4473:65296) pci, tifm_7xx1, STORAGE, 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
:(32902:4242:4473:65296) pci, e100, ETHERNET, PRO/100 VE Network Connection
:(32902:10144:4473:65296) pci, agpgart-intel, HOST/PCI, Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub
:(4172:32826:4473:65296) pci, firewire_ohci, FIREWIRE, PCIxx12 OHCI Compliant IEEE 1394 Host Controller
:(4172:32825:4473:65296) pci, yenta_cardbus, PCI/CARDBUS, PCIxx12 Cardbus Controller
:(4172:32828:4473:65296) pci, sdhci-pci, BASE, PCIxx12 SDA Standard Compliant SD Host Controller
:(32902:10169:4473:65296) pci, None, PCI/ISA, 82801GBM (ICH7-M) LPC Interface Bridge
:(32902:10196:4473:65296) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 3
:(32902:9288:4473:65296) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10185:4473:65296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4473:65296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10187:4473:65296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10186:4473:65296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10188:4473:65296) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:(32902:10146:4473:65296) pci, None, VIDEO, Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
:(32902:10150:4473:65296) pci, None, VIDEO, Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
:(32902:10192:4473:65296) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:4473:65296) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(32902:10200:4473:65296) pci, snd_hda_intel, MULTIMEDIA, Toshiba Satellite A100-796 audio (Realtek ALC861)
:(32902:10202:4473:65296) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:16930:32902:4160) pci, iwl3945, NETWORK, PRO/Wireless 3945ABG [Golan] Network Connection
:(32902:10180:4473:65296) pci, ata_piix, STORAGE, 82801GBM/GHM (ICH7 Family) SATA IDE Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_toshiba-lv_root / ext4 4096 4096 12901535 11580890 11449868 3276800 3153519 3153519
:/dev/sda1 /boot ext4 1024 1024 495844 438481 412881 128016 127792 127792
:/dev/mapper/vg_toshiba-lv_home /home ext4 4096 4096 10498372 10388353 9855054 2670592 2669766 2669766
:
Comment 1 Dave Jones 2012-02-17 00:30:31 EST

*** This bug has been marked as a duplicate of bug 786632 ***