Bug 795020 (CVE-2012-1190)

Summary: CVE-2012-1190 phpMyAdmin: XSS in replication setup (PMASA-2012-1)
Product: [Other] Security Response Reporter: Vincent Danen <vdanen>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: gary.p.anderson, redhat-bugzilla
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=moderate,public=20120218,reported=20120218,source=internet,cvss2=4.3/AV:N/AC:M/Au:N/C:N/I:P/A:N,fedora-all/phpMyAdmin=affected,epel-6/phpMyAdmin=affected,epel-5/phpMyAdmin3=affected,cwe=CWE-79[auto]
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-02 21:51:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 795021, 795022, 795023    
Bug Blocks:    

Description Vincent Danen 2012-02-18 17:35:43 UTC
It was reported [1] that phpMyAdmin 3.4.x suffered from an XSS in replication setup, that could allow a malicious user to conduct an XSS attack using a crafted database name.  All 3.4.x versions are affected, and this is fixed in upstream 3.4.10.1 [2].

[1] http://www.phpmyadmin.net/home_page/security/PMASA-2012-1.php
[2] https://github.com/phpmyadmin/phpmyadmin/commit/86073d532aed656550cb731aa5b4288b126ae7a6

Comment 1 Vincent Danen 2012-02-18 17:36:36 UTC
Created phpMyAdmin tracking bugs for this issue

Affects: fedora-all [bug 795021]
Affects: epel-6 [bug 795022]

Comment 2 Vincent Danen 2012-02-18 17:36:39 UTC
Created phpMyAdmin3 tracking bugs for this issue

Affects: epel-5 [bug 795023]

Comment 3 Fedora Update System 2012-04-30 18:33:24 UTC
phpMyAdmin-3.5.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2012-04-30 18:34:34 UTC
phpMyAdmin3-3.5.0-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2012-05-01 00:49:03 UTC
phpMyAdmin-3.5.0-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2012-05-01 00:55:35 UTC
phpMyAdmin-3.5.0-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2012-05-02 04:49:01 UTC
phpMyAdmin-3.5.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.