Bug 795553

Summary: postgresql fails to build on multi-core due to blocking error
Product: [Fedora] Fedora Reporter: Mark Langsdorf <mark.langsdorf>
Component: postgresqlAssignee: Tom Lane <tgl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 17CC: blc, devrim, hhorak, tgl
Target Milestone: ---   
Target Release: ---   
Hardware: arm   
OS: Unspecified   
Whiteboard:
Fixed In Version: postgresql-9.1.3-1.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 795460 Environment:
Last Closed: 2012-04-03 11:24:36 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Mark Langsdorf 2012-02-20 16:07:30 EST
+++ This bug was initially created as a clone of Bug #795460 +++

Description of problem:
postgresql builds on armhfp but fails to complete the regression tests if the builder has multiple cores. 

Version-Release number of selected component (if applicable):
postgresql-9.1.2 on armhfp

How reproducible:
run mock on an SMP capable ARM system and rebuild the postgresql-9.1.2 srpm.

Actual results:
Failure

Expected results:
Successfully built RPM

Additional info:
the issue is resolved by http://git.postgresql.org/gitweb/?p=postgresql.git&a=commitdiff&h=bb65cb8cdf864e61bc939d3c4b28bbd43d926700

Please add to the rawhide postgresql. Thanks.

--- Additional comment from blc@redhat.com on 2012-02-20 15:54:50 EST ---

Please also put the patch in the F17 branch as we'll need it in both places.
Comment 1 Tom Lane 2012-02-27 17:36:22 EST
I believe this is fixed by upstream in postgresql-9.1.3-1.fc17, please test.
Comment 2 Tom Lane 2012-04-03 11:22:36 EDT
*** Bug 795460 has been marked as a duplicate of this bug. ***
Comment 3 Tom Lane 2012-04-03 11:24:36 EDT
Closing for lack of feedback.  I believe this is fixed as of current version, though.