Bug 796431

Summary: [Cobbler] Does not delete the pxe record when installing with UEFI
Product: [Fedora] Fedora Reporter: Jeff Burke <jburke>
Component: cobblerAssignee: James C. <jimi>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 16CC: awood, bpeck, bstein, dgoodwin, jsherril, shenson, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-06 10:03:27 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Patch to not generate grub system entry if netboot is disabled
none
New patch, that also removes existing grub file if it exists. none

Description Jeff Burke 2012-02-22 16:22:20 EST
Description of problem:
System reinstalls if installed using cobbler and you netboot.

Version-Release number of selected component (if applicable):
Cobbler 2.0.12

How reproducible:
Always
  
Actual results:
Install the system via UEFI network interface. The system will
install. The nextboot is set to Red Hat Enterprise Linux 6. If
use efimgr and set the nextboot to use the UEFI network interface 
the system reinstalls.

Expected results:
The PXE record should have been deleted

Additional info:
Comment 1 Jeff Burke 2012-03-01 14:07:28 EST
This issue is blocking UEFI testing on RHEL5.
Comment 2 Jeff Burke 2012-03-08 08:43:54 EST
Brian,
 Can you have someone look into this issue. This is currently blocking us from adding new UEFI systems to Beaker.

Thanks,
Jeff
Comment 3 Justin Sherrill 2012-03-20 11:24:15 EDT
Created attachment 571439 [details]
Patch to not generate grub system entry if netboot is disabled
Comment 4 Justin Sherrill 2012-03-20 11:26:25 EDT
I'm not able to fully test with an UEFI system, but the following patch does not generate a grub entry for a system if "Netboot Enabled" is set to false for that system.  From everything i can test without a UEFI system the above patch fixes the issue.  If it is possible to test this patch, it would be greatly appreciated.

-Justin
Comment 5 Justin Sherrill 2012-03-20 11:36:37 EDT
Created attachment 571451 [details]
New patch, that also removes existing grub file if it exists.
Comment 6 Justin Sherrill 2012-03-20 11:37:22 EDT
1st patch actually only solved the issue for cobbler sync.  This new patch should now also remove the grub file for the post kickstart hook.

-Justin
Comment 7 Fedora Admin XMLRPC Client 2012-04-11 18:00:11 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 James C. 2012-04-16 21:05:32 EDT
Has this issue been corrected as of the 2.2.x release? Also, is bug #696802 the same issue you're reporting above? It appears to be, so I may close this as a dupe to work it under a single bug id.
Comment 9 James C. 2012-06-06 10:03:27 EDT
Closing this bug, as there have been no updates in a while and the issue may be corrected in the current version. If not and the issue resurfaces, please submit the patches via github and I'll get them merged in.