This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 797069

Summary: [glusterfs-3.3.0qa24]: ping_pong failing on nfs client
Product: [Community] GlusterFS Reporter: Raghavendra Bhat <rabhat>
Component: nfsAssignee: Rajesh <rajesh>
Status: CLOSED WORKSFORME QA Contact:
Severity: unspecified Docs Contact:
Priority: high    
Version: mainlineCC: gluster-bugs, vagarwal, vbellur
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-05 02:16:31 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Raghavendra Bhat 2012-02-24 02:41:59 EST
Description of problem:
ping_pong tool is failing with the below errors on the nfs client even though the nlm changes have gone in.

lock at 5 failed! - Permission denied
lock at 7 failed! - Permission denied
lock at 6 failed! - Permission denied
lock at 6 failed! - Permission denied
lock at 6 failed! - Permission denied
write failed at 5
write failed at 5c
lock at 7 failed! - Permission denied
lock at 7 failed! - Permission denied
lock at 8 failed! - Permission denied
lock at 7 failed! - Permission denied
lock at 8 failed! - Permission denied
lock at 8 failed! - Permission denied
lock at 8 failed! - Permission denied
lock at 9 failed! - Permission denied
write failed at 7
lock at 9 failed! - Permission denied
lock at 9 failed! - Permission denied
lock at 9 failed! - Permission denied
lock at 10 failed! - Permission denied
lock at 10 failed! - Permission denied
lock at 11 failed! - Permission denied
lock at 10 failed! - Permission denied
lock at 10 failed! - Permission denied
lock at 11 failed! - Permission denied
lock at 12 failed! - Permission denied
lock at 11 failed! - Permission denied
lock at 11 failed! - Permission denied
lock at 12 failed! - Permission denied
lock at 13 failed! - Permission denied
lock at 12 failed! - Permission denied
lock at 12 failed! - Permission denied
lock at 13 failed! - Permission denied
lock at 14 failed! - Permission denied
lock at 13 failed! - Permission denied
lock at 13 failed! - Permission denied

Version-Release number of selected component (if applicable):


How reproducible:

always
Steps to Reproduce:
1. create a glusterfs volume, start it
2. mount the volume via nfs (do not use -o nolock option while mounting since nlm changes have gone in and should take care of locking)
3. run ping_pong test
  
Actual results:

ping_pong is getting errors sayinh permission denied or write failed/

Expected results:

ping_pong should not fail and should be able to acquire locks on the file mentioned



Additional info:

nfs server logs are not saying much.

2012-02-24 02:42:27.393349] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:54a77bc5-02f6-42ac-943a-2a152b36747b)
[2012-02-24 02:42:27.398494] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:54a77bc5-02f6-42ac-943a-2a152b36747b)
[2012-02-24 02:42:27.407756] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:ffb83d33-b41a-407e-adc1-b9c52f07ad64)
[2012-02-24 02:42:27.411141] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:ffb83d33-b41a-407e-adc1-b9c52f07ad64)
[2012-02-24 02:42:27.418569] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:76562a4e-e7bf-4e91-a276-648f715fa8b0)
[2012-02-24 02:42:27.420707] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:76562a4e-e7bf-4e91-a276-648f715fa8b0)
[2012-02-24 02:42:27.428376] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:1b56638c-4472-4122-874e-d39f5d38b647)
[2012-02-24 02:42:27.432093] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:1b56638c-4472-4122-874e-d39f5d38b647)
[2012-02-24 02:42:27.439308] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:62377c5d-2acb-45cd-98d1-32c6abaab054)
[2012-02-24 02:42:27.441831] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:62377c5d-2acb-45cd-98d1-32c6abaab054)
[2012-02-24 02:42:27.449540] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:61e958e9-3bc9-438f-8ded-54b7df165234)
[2012-02-24 02:42:27.452148] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:61e958e9-3bc9-438f-8ded-54b7df165234)
[2012-02-24 02:42:27.459396] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:add476d0-f6f9-41e3-a4e4-6e5726fa9780)
[2012-02-24 02:42:27.461698] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:add476d0-f6f9-41e3-a4e4-6e5726fa9780)
[2012-02-24 02:42:27.468793] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:bbe742f8-fb18-4e4d-83f9-4e58c27cbac3)
[2012-02-24 02:42:27.471623] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:bbe742f8-fb18-4e4d-83f9-4e58c27cbac3)
[2012-02-24 02:42:27.478923] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:d6b3bbf6-fb84-4373-b4b6-d4ef633d334f)
[2012-02-24 02:42:27.482804] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:d6b3bbf6-fb84-4373-b4b6-d4ef633d334f)
[2012-02-24 02:42:27.489880] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:984be157-84d9-44db-92be-a0f0cf147918)
[2012-02-24 02:42:27.492442] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:984be157-84d9-44db-92be-a0f0cf147918)
[2012-02-24 02:42:27.501649] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:2b9a6c02-40fd-4391-8748-6f6446deb7ee)
[2012-02-24 02:42:27.505165] W [quota.c:2146:quota_fstat_cbk] 0-mirror-quota: quota context not set in inode (gfid:2b9a6c02-40fd-4391-8748-6f6