Bug 797094

Summary: glibc: unbound alloca use in nscd_getserv_r and glob_in_dir
Product: Red Hat Enterprise Linux 6 Reporter: Tomas Hoger <thoger>
Component: glibcAssignee: Jeff Law <law>
Status: CLOSED ERRATA QA Contact: qe-baseos-tools
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.2CC: fweimer, mfranc, pmuller
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-20 12:09:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tomas Hoger 2012-02-24 09:19:20 UTC
Description of problem:
Upstream has fixed couple of unbound alloca uses which can lead to program crashes if excessively long inputs are passed to certain functions.

http://sourceware.org/bugzilla/show_bug.cgi?id=12671
http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=f2962a71959fd254a7a223437ca4b63b9e81130c

covers cases that can be triggered via getaddrinfo, getservbyname* and glob.

http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=34a9094f49241ebb72084c536cf468fd51ebe3ec

covers other alloca uses inside getaddrinfo.

Version-Release number of selected component (if applicable):
glibc-2.12-1.47.el6_2.5

Comment 5 errata-xmlrpc 2012-06-20 12:09:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0763.html