Bug 798746

Summary: Can't start virtual machine
Product: [Fedora] Fedora Reporter: Arnold Wang <arnold.x.wang>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: berrange, clalancette, crobinso, dougsland, itamar, jforbes, laine, libvirt-maint, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-06 19:17:50 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Arnold Wang 2012-02-29 13:24:07 EST
Description of problem:
When I tried to start the virtual machine using Virtual Machine Manager 0.9.1, I received the following error message:
Error starting domain: internal error Process exited while reading console log output: char device redirected to /dev/pts/1
Could not allocate dynamic translator buffer


Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 66, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1114, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 510, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/1
Could not allocate dynamic translator buffer

As far as I can remember, nothing change in the the guest machine configuration. 

Version-Release number of selected component (if applicable):

[awang@mars ~]$ rpm -qa | grep virt
python-virtinst-0.600.1-1.fc16.noarch
libvirt-python-0.9.6-4.fc16.x86_64
virt-manager-common-0.9.1-2.fc16.noarch
python-virtkey-0.50-9.fc15.x86_64
virt-manager-0.9.1-2.fc16.noarch
libvirt-0.9.6-4.fc16.x86_64
libvirt-client-0.9.6-4.fc16.x86_64


How reproducible:
start virtual machine manager, select the guest machine and click "run". 

Steps to Reproduce:
1. Start the virtual machine manager
2. Select the guest machine need be started
3. Right click and select "run"
  
Actual results:
Received the above error messages.

Expected results:
The guest machine starts.

Additional info:
The guest machines worked before, I don't use it frequently. I assume one of the patch I updated between last time and now broke this.
Comment 1 Arnold Wang 2012-02-29 13:44:29 EST
It appears I filed the bug report too quickly this time. The problem seems related to SELinux. Once I set the enforce mode to permissive, I can start the guest machine now. I will file another bug report in SELinux as well.
BTW, the following is what "audit2allow" generates, in case you're interested. As you can see, relabel the file system didn't help.
 
-bash-4.2# restorecon -R /
-bash-4.2# setenforce 1
-bash-4.2# audit2allow -alr

require {
	type iscsid_t;
	type var_log_t;
	type svirt_t;
	class process execmem;
	class file open;
}

#============= iscsid_t ==============
allow iscsid_t var_log_t:file open;

#============= svirt_t ==============
allow svirt_t self:process execmem;
-bash-4.2#
Comment 2 Arnold Wang 2012-03-06 19:17:50 EST

*** This bug has been marked as a duplicate of bug 798758 ***