Bug 799028

Summary: [RFE] Add command line option to enable bmi1 feature on AMD processors
Product: Red Hat Enterprise Linux 6 Reporter: Peter Krempa <pkrempa>
Component: qemu-kvmAssignee: Eduardo Habkost <ehabkost>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.3CC: acathrow, areis, bsarathy, dallan, ehabkost, emcnabb, juzhang, michen, minovotn, mkenneth, tburke, virt-maint, xfu
Target Milestone: rcKeywords: FutureFeature, TestOnly
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-21 02:32:37 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 843084    
Bug Blocks: 797283, 833128    

Description Peter Krempa 2012-03-01 10:48:19 EST
Description of problem:
The bmi1 support flag is forwarded to the guest OS only if "-cpu host" is used. There is no option to enable exposing this functionality with other (compatible) cpu models. 

When using qemu-kvm managed by libvirt, there's no possibility to use this feature with reasonable configurations. (Host processor passthrough cannot be used easily with migration)

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.235.el6

Steps to Check:
# qemu-kvm -cpu Opteron_G3,+bmi1
CPU feature bmi1 not found

Actual results:
Feature BMI1 cannot be exposed to guest OS without using "-cpu host".

Expected results:
Feature bmi1 can be enabled and exposed to guests using eg "-cpu OpteronG3,+bmi1...".

Additional info:
A option should be added that enables passing through CPUID fn. 0x00000007 reg EBX bit. 3 to the guest OS on compatible processors.
Comment 2 juzhang 2012-03-04 21:27:34 EST
Hi,Peter

   About bmi1 flag,would you please tell qe which amd platforms(host) includes this flag? thanks
Comment 3 Peter Krempa 2012-03-05 04:56:59 EST
Hi Junyi,
the bmi1 flag is exposed on hosts that support the new bit manipulation instructions. This feature is included in the new Piledriver architecture from AMD.
Comment 5 juzhang 2012-03-05 20:39:15 EST
Thanks peter,according to comment3 and comment4,set qa_ack+
Comment 13 FuXiangChun 2012-11-26 04:36:56 EST
verify this bug with qemu-kvm-0.12.1.2-2.334.el6.x86_64 and kernel 2.6.32-339.el6.x86_64

steps to verify:
1.boot rhel6.4 guest with -cpu Opteron_G3,+bmi1 on Seoul host
2.check flag bmil inside guest. 

result:
'bmil' flag is exposed to guest

so according to expected results in description, this bug is fixed.
Comment 15 errata-xmlrpc 2013-02-21 02:32:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html