Bug 799326

Summary: remove old kernels after new ones have started succesfully
Product: [Fedora] Fedora Reporter: Alexander van Loon <a.vanloon>
Component: yumAssignee: Seth Vidal <skvidal>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: rawhideCC: ffesti, gansalmon, itamar, james.antill, jonathan, kernel-maint, madhu.chinakonda, maxamillion, pmatilai, reklov, tla, zpavlas
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-02 13:49:41 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alexander van Loon 2012-03-02 08:56:06 EST
Description of problem:

Currently on my Fedora 16 systems, when kernel updates are installed – which has been happening quite often because Fedora updates it so frequently – the old kernels remain on the system and are not removed. As a consequence disk space is wasted and the grub menu gets quite crowded. So I propose that once a new kernel has been started successfully the old kernel will be removed automatically.
Comment 1 Volker Sobek 2012-03-02 09:36:30 EST
Just to clarify: The default is to keep three kernels, older ones are removed automatically. Do you have more than 3 kernels installed at a time?
Comment 2 Josh Boyer 2012-03-02 11:54:44 EST
As Frank said, this should already be happening unless you've modified something locally.

Either way, this isn't a kernel bug.  It should be reported against yum most likely.
Comment 3 Alexander van Loon 2012-03-02 13:49:41 EST
No, I never had more than three kernels installed at the same time and never modified anything. I wasn't aware it worked like that, thank you for explaining. Closing my bug.