Bug 800235

Summary: FTBFS: parted's t9050-partition-table-types.sh test that worked last month now fails
Product: [Fedora] Fedora Reporter: Brendan Conoboy <blc>
Component: partedAssignee: Brian Lane <bcl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 17CC: bcl
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: parted-3.0-9.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-11 23:37:10 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 245418    

Description Brendan Conoboy 2012-03-05 23:47:45 EST
Description of problem:

Something has happened in the last month that prevents parted-3.0-7.fc17.src.rpm from building successfully any longer.  It was initially noticed on ARM, but also FTBFS on x86_64.

From mock's build.log:

+ parted -s f mklabel pc98
Backtrace has 8 calls on stack:
  8: /builddir/build/BUILD/parted-3.0/libparted/.libs/libparted.so.1(ped_assert+0x2e) [0x7f949e8ea1de]
  7: /builddir/build/BUILD/parted-3.0/libparted/.libs/libparted.so.1(+0x28d1a) [0x7f949e905d1a]
  6: /builddir/build/BUILD/parted-3.0/libparted/.libs/libparted.so.1(ped_disk_new+0x58) [0x7f949e8ef748]
  5: /builddir/build/BUILD/parted-3.0/parted/.libs/lt-parted() [0x40811f]
  4: /builddir/build/BUILD/parted-3.0/parted/.libs/lt-parted(non_interactive_mode+0x8a) [0x40c25a]
  3: /builddir/build/BUILD/parted-3.0/parted/.libs/lt-parted(main+0xf25) [0x405cc5]
  2: /lib64/libc.so.6(__libc_start_main+0xf5) [0x7f949e0db745]
  1: /builddir/build/BUILD/parted-3.0/parted/.libs/lt-parted() [0x405d89]
./t9050-partition-table-types.sh: line 42: 10617 Aborted                 (core dumped) parted -s f mklabel $j
+ fail=1

Version-Release number of selected component (if applicable):

Happens on Fedora 17 buildroots on x86_64, armv5tel, and armv7hl.  Since the exact same test worked a month ago it is presumably some other component to blame.  Perhaps /usr move?  Reason is unclear.

Steps to Reproduce:
1. /usr/bin/mock -r fedora-17-x86_64 parted-3.0-7.fc17.src.rpm 
2. Observe the failure in build.log.
Comment 1 Brian Lane 2012-03-14 14:38:09 EDT
This is due to a change in mkswap, it no longer removes the bootloader part of the disk. This helps reveal another assert problem in the partition reading code, this time in mac.c -- we really shouldn't traceback on a bad partition table, especially when doing a mklabel.

reproduce it with:

PARTED_SECTOR_SIZE=1024 parted -s f mklabel mac
mkswap f
PARTED_SECTOR_SIZE=1024 parted -s f p
Comment 2 Fedora Update System 2012-03-14 15:16:44 EDT
parted-3.0-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/parted-3.0-8.fc17
Comment 3 Fedora Update System 2012-03-15 22:42:19 EDT
Package parted-3.0-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parted-3.0-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3829/parted-3.0-8.fc17
then log in and leave karma (feedback).
Comment 4 Brendan Conoboy 2012-03-15 22:49:28 EDT
I can confirm that parted-3.0.8.fc17 built successfully.  Assuming this is also in rawhide, we're all done.  Thanks!
Comment 5 Fedora Update System 2012-03-21 14:15:55 EDT
parted-3.0-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/parted-3.0-9.fc17
Comment 6 Fedora Update System 2012-04-11 23:37:10 EDT
parted-3.0-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.