Bug 80060

Summary: sendmail doesn't like all-digits usernames
Product: [Retired] Red Hat Linux Reporter: Bastien Nocera <bnocera>
Component: sendmailAssignee: Florian La Roche <laroche>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: psklenar, weiss
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-13 10:22:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bastien Nocera 2002-12-19 13:01:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
sendmail -bv 10342 responds with "10342... user unknown". ldapsearch -x
'(uid=10242)'  gives the right entry.
su - 10342 also works. Using "sendmail -bv testuser" I got "testuser...
deliverable: mailer local, user testuser"
Both accounts are only in the same ldap-subtree - not local. It seems that every
account containing only digits doesn't
work. Under RH 7.3 (sendmail.8.11.6-15) - same configuration - I get the the
correct result for 10342

How reproducible:
Always

Steps to Reproduce:
1. sendmail -bv 10342

Actual Results:  10342... user unknown". ldapsearch -x '(uid=10242)

Expected Results:  10342... deliverable: mailer local, user 10342

Additional info:

Under RH 8.0 with default sendmail.mc

Comment 1 Juergen Weiss 2002-12-19 13:39:07 UTC
I downloaded sendmail.8.12.5 and sendmail.8.12.6 from sendmail.org and built the
binary. Both work with sendmail -bv 4711

Comment 2 Juergen Weiss 2002-12-19 20:35:30 UTC
The behaviour not resolving local logins containing all-digits seems specific to
RH 8.0 sendmail.

Comment 3 Juergen Weiss 2003-01-02 16:31:46 UTC
Is there any progress towards a solution ?

Comment 4 Florian La Roche 2003-01-06 14:39:35 UTC
Seems disabling hesiod is fixing this as a shortterm fix, it should have nothing
todo with RHL7.x versus RHL8 sendmail rpms.

greetings,

Florian La Roche

Comment 5 Juergen Weiss 2003-01-08 10:19:23 UTC
Thanks for respondig:

1) Hesiod is not enabled ( I assume thats the default )
2) When installing from sendmail.org ( same tar file as in semdmails SRPM 
   (md5sum)). An all digit-usename is accepted ( sendmail -b 4711 )


Comment 6 Florian La Roche 2003-01-13 10:22:06 UTC
Should be fixed in 8.12.7-3 or newer.

greetings,

Florian La Roche