Bug 800692

Summary: [abrt] kernel: WARNING: at drivers/net/wireless/iwlwifi/iwl-trans-pcie-rx.c:461 iwl_irq_tasklet+0x79a/0x1c90 [iwlwifi]()
Product: [Fedora] Fedora Reporter: battleman2004
Component: kernelAssignee: John W. Linville <linville>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, sgruszka, wey-yi.w.guy
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:9304353a838984a32d0cd85971b3dbf83ef6a4e0
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-10 20:21:10 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description battleman2004 2012-03-06 18:48:04 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-0.rc5.git3.1.fc17.x86_64 root=/dev/mapper/vg_t400s-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_t400s/lv_swap SYSFONT=True rd.luks.uuid=luks-f385f9a8-8db1-423a-a9e9-c339091dc197 rd.lvm.lv=vg_t400s/lv_root LANG=de_DE.UTF-8 KEYTABLE=de-latin1-nodeadkeys rhgb quiet
event_log:      2012-03-07-00:47:53> Smolt profile successfully saved
kernel:         3.3.0-0.rc5.git3.1.fc17.x86_64
reason:         WARNING: at drivers/net/wireless/iwlwifi/iwl-trans-pcie-rx.c:461 iwl_irq_tasklet+0x79a/0x1c90 [iwlwifi]()
time:           Di 06 Mär 2012 21:48:43 CET

backtrace:
:WARNING: at drivers/net/wireless/iwlwifi/iwl-trans-pcie-rx.c:461 iwl_irq_tasklet+0x79a/0x1c90 [iwlwifi]()
:Hardware name: 2808D9G
:reclaim is false, SEQ_RX_FRAME unset: REPLY_RX_PHY_CMD
:Modules linked in: binfmt_misc fuse ip6table_filter ip6_tables ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack lockd sunrpc xt_CHECKSUM iptable_mangle be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 bridge stp llc cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi arc4 microcode uvcvideo cdc_ether videobuf2_vmalloc videobuf2_memops videobuf2_core usbnet mii videodev v4l2_compat_ioctl32 media cdc_acm cdc_wdm i2c_i801 iwlwifi iTCO_wdt snd_hda_codec_conexant iTCO_vendor_support mac80211 snd_hda_intel cfg80211 snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_timer e1000e thinkpad_acpi snd soundcore rfkill vhost_net tun macvtap macvlan kvm_intel kvm uinput xts gf128mul dm_crypt mmc_block sdhci_pci sdhci mmc_core wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 3343, comm: qemu-kvm Tainted: G        W    3.3.0-0.rc5.git3.1.fc17.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff81060d6f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81060e66>] warn_slowpath_fmt+0x46/0x50
: [<ffffffffa03fc12a>] iwl_irq_tasklet+0x79a/0x1c90 [iwlwifi]
: [<ffffffff810c71cd>] ? trace_hardirqs_off+0xd/0x10
: [<ffffffff8169dc67>] ? _raw_spin_unlock_irqrestore+0x77/0x80
: [<ffffffff81069317>] tasklet_action+0x97/0x200
: [<ffffffff81069ac0>] __do_softirq+0xe0/0x380
: [<ffffffff816a7e2c>] call_softirq+0x1c/0x30
: [<ffffffff8101b5e5>] do_softirq+0xa5/0xe0
: [<ffffffff8106a0d5>] irq_exit+0xd5/0xe0
: [<ffffffff816a86c3>] do_IRQ+0x63/0xe0
: [<ffffffff8169e033>] common_interrupt+0x73/0x73
: <EOI>  [<ffffffffa014b521>] ? x86_emulate_instruction+0x141/0x630 [kvm]
: [<ffffffffa014b51b>] ? x86_emulate_instruction+0x13b/0x630 [kvm]
: [<ffffffffa01b9585>] handle_apic_access+0x45/0x80 [kvm_intel]
: [<ffffffffa01bf099>] vmx_handle_exit+0xb9/0x950 [kvm_intel]
: [<ffffffffa014e8bd>] ? kvm_arch_vcpu_ioctl_run+0x55d/0x17a0 [kvm]
: [<ffffffffa014e908>] kvm_arch_vcpu_ioctl_run+0x5a8/0x17a0 [kvm]
: [<ffffffffa014e8bd>] ? kvm_arch_vcpu_ioctl_run+0x55d/0x17a0 [kvm]
: [<ffffffff81699ee3>] ? mutex_lock_nested+0x2d3/0x3a0
: [<ffffffffa01355d7>] ? vcpu_load+0x27/0xb0 [kvm]
: [<ffffffffa01355d7>] ? vcpu_load+0x27/0xb0 [kvm]
: [<ffffffffa0135a6e>] kvm_vcpu_ioctl+0x3ae/0x6a0 [kvm]
: [<ffffffff812c20b1>] ? file_has_perm+0xe1/0xf0
: [<ffffffff811d0339>] do_vfs_ioctl+0x99/0x5a0
: [<ffffffff811d08d9>] sys_ioctl+0x99/0xa0
: [<ffffffff816a68e9>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:Allgemein
:=================================
:UUID: 78bf6da9-c722-48ca-b5a0-c1e943afa13f
:OS: Fedora release 17 (Beefy Miracle)
:Standard-Runlevel: Unknown
:Sprache: de_DE.utf8
:Plattform: x86_64
:BogoMIPS: 4788.08
:CPU-Anbieter: GenuineIntel
:CPU-Modell: Intel(R) Core(TM)2 Duo CPU     P9400  @ 2.40GHz
:CPU-Stepping: 10
:CPU Familie: 6
:CPU-Modellnummer: 23
:Anzahl der CPUs: 2
:CPU-Geschwindigkeit: 2401
:Systemspeicher: 7861
:System-Swap: 9919
:Anbieter: LENOVO
:System: 2808D9G ThinkPad T400s
:Form-Faktor: Notebook
:Kernel: 3.3.0-0.rc5.git3.1.fc17.x86_64
:SELinux aktiviert: 1
:SELinux-Richtlinie: targeted
:SELinux erzwingen: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Geräte
:=================================
:(32902:10816:6058:8416) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10544:6058:8441) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10537:6058:8440) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10519:6058:8437) pci, None, PCI/ISA, ICH9M-E LPC Interface Controller
:(32902:4341:6058:8430) pci, e1000e, ETHERNET, 82567LM Gigabit Network Connection
:(32902:9288:6058:8436) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10566:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10549:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:6058:8433) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:6058:8433) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:16950:32902:4369) pci, iwlwifi, NETWORK, Ultimate N WiFi Link 5300
:(32902:10818:6058:8420) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:6058:8420) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10820:6058:8422) pci, None, SIMPLE, Mobile 4 Series Chipset MEI Controller
:(32902:10558:6058:8434) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4480:57904:6058:8500) pci, None, BASE, Memory Stick Host Controller
:(4480:59426:6058:8499) pci, sdhci-pci, BASE, MMC/SD Host Controller
:
:
:Dateisysteminformationen
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_t400s-lv_root / ext4 4096 4096 13081819 8629747 7974387 3276800 2988431 2988431
:/dev/sda2 /boot ext4 1024 1024 508745 407426 381826 128016 127789 127789
:/dev/mapper/vg_t400s-lv_home /home ext4 4096 4096 15446902 7625256 6851522 3874816 3600528 3600528
:
Comment 1 John W. Linville 2012-03-07 10:01:26 EST
This is where the WARN is:

                /* warn if this is cmd response / notification and the uCode
                 * didn't set the SEQ_RX_FRAME for a frame that is
                 * uCode-originated
                 * If you saw this code after the second half of 2012, then
                 * please remove it
                 */
                WARN(pkt->hdr.cmd != REPLY_TX && reclaim == false &&
                     (!(pkt->hdr.sequence & SEQ_RX_FRAME)),
                     "reclaim is false, SEQ_RX_FRAME unset: %s\n",
                     get_cmd_string(pkt->hdr.cmd));
Comment 2 Dave Jones 2012-03-07 10:26:46 EST
*** Bug 800827 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2012-03-07 10:26:53 EST
*** Bug 800824 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2012-03-07 10:27:00 EST
*** Bug 800826 has been marked as a duplicate of this bug. ***
Comment 5 Josh Boyer 2012-03-09 07:44:39 EST
*** Bug 801595 has been marked as a duplicate of this bug. ***
Comment 6 Josh Boyer 2012-03-09 07:44:59 EST
*** Bug 801591 has been marked as a duplicate of this bug. ***
Comment 7 Josh Boyer 2012-03-09 07:45:05 EST
*** Bug 801597 has been marked as a duplicate of this bug. ***
Comment 8 Josh Boyer 2012-03-09 07:45:13 EST
*** Bug 801596 has been marked as a duplicate of this bug. ***
Comment 9 Josh Boyer 2012-03-09 07:45:21 EST
*** Bug 801593 has been marked as a duplicate of this bug. ***
Comment 10 Josh Boyer 2012-04-10 20:21:10 EDT

*** This bug has been marked as a duplicate of bug 770595 ***