Bug 802514 (CVE-2012-1164)

Summary: CVE-2012-1164 openldap (slapd): Assertion failure by processing search queries requesting only attributes for particular entry
Product: [Other] Security Response Reporter: Jan Lieskovsky <jlieskov>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: dspurek, jsynacek, jvcelak, omoris, rmeggins, yanagiya
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=low,public=20120129,reported=20120229,source=gentoo,cvss2=5.0/AV:N/AC:L/Au:N/C:N/I:N/A:P,rhel-5/openldap=notaffected,rhel-6/openldap=affected,fedora-all/openldap=affected
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-17 06:25:01 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 813162, 829481    
Bug Blocks: 784298, 802520    

Description Jan Lieskovsky 2012-03-12 13:33:27 EDT
A denial of service flaw was found in the way the slapd server of the OpenLDAP, the Lightweight Directory Access Protocol applications and development suite, processed certain search queries requesting only attributes (no values) for a particular entry. A remote attacker could issue a specially-crafted LDAP search query, which once processed by a vulnerable slapd server would lead to assertion failure (slapd abort).

Upstream bug report:
[1] http://www.openldap.org/its/index.cgi/Software%20Bugs?id=7143

Original upstream patch:
[2] http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commit;h=ef2f5263de8802794e528cc2648ecfca369302ae

Further patches:
[3] http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commit;h=430256fafb85028443d7964a5ab1f4bbf8b2db38
[4] http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commit;h=463c1fa25d45e393dc1f1ea235286f79e872fad0

References:
[5] http://www.openldap.org/software/release/changes.html
[6] https://bugs.gentoo.org/show_bug.cgi?id=407941
[7] https://secunia.com/advisories/48372/
Comment 1 Jan Lieskovsky 2012-03-12 13:39:15 EDT
CVE Request:
[8] http://www.openwall.com/lists/oss-security/2012/03/12/2
Comment 4 Vincent Danen 2012-03-12 16:48:11 EDT
This was assigned the name CVE-2012-1164.
Comment 6 errata-xmlrpc 2012-06-20 03:29:30 EDT
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2012:0899 https://rhn.redhat.com/errata/RHSA-2012-0899.html
Comment 8 Vincent Danen 2012-06-20 16:00:36 EDT
Created openldap tracking bugs for this issue

Affects: fedora-all [bug 829481]
Comment 9 Jan Vcelak 2012-06-27 08:04:08 EDT
Fedora 16 affected.
Fedora 17, 18 not affected.
Comment 10 Taichi Yanagiya 2012-07-05 23:51:31 EDT
RHEL 5 affected ?
Comment 13 Stefan Cornelius 2012-07-17 06:25:01 EDT
Statement:

This issue did not affect openldap as shipped with Red Hat Enterprise Linux 5 as it did not contain the relevant assertion. This has been addressed in Red Hat Enterprise Linux 6 via https://rhn.redhat.com/errata/RHSA-2012-0899.html
Comment 14 Fedora Update System 2012-07-17 13:26:14 EDT
openldap-2.4.26-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.