Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 802552

Summary: wlan0: WPA: Failed to get master session key from EAPOL state machines - key handshake aborted
Product: [Fedora] Fedora Reporter: Joel Kirchmeyer <kirchmeyer>
Component: wpa_supplicantAssignee: Dan Williams <dcbw>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 17CC: atigro, awilliam, dcbw, jonas, jvpgomes, kevin, lionghostshop, lovenemesis, pbrobinson, pedrogfrancisco, rdieter, rebus, robatino, samuel-rhbugs
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=806128
Whiteboard: AcceptedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-04 18:30:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 752650    

Description Joel Kirchmeyer 2012-03-12 15:57:20 EDT
Description of problem:
Error in /var/log/wpa_supplicant.log


Version-Release number of selected component (if applicable):
0.3.fc17

How reproducible:
Every time

Steps to Reproduce:
1. Try to join WPA PEAP MSCHAPV2 Wifi
  
Actual results:
wlan0: WPA: Failed to get master session key from EAPOL state machines - key handshake aborted 

Expected results:
Connected

Additional info:
I downgraded to the 0.2.fc17 and things work again.
Comment 1 Jirka Klimes 2012-04-17 11:12:29 EDT
*** Bug 811447 has been marked as a duplicate of this bug. ***
Comment 2 Jirka Klimes 2012-04-17 11:14:46 EDT
*** Bug 806128 has been marked as a duplicate of this bug. ***
Comment 3 Peter Robinson 2012-04-17 11:30:13 EDT
*** Bug 809741 has been marked as a duplicate of this bug. ***
Comment 4 Peter Robinson 2012-04-17 12:31:59 EDT
Adding as F17Blocker as not being able to connect to a common type of Wireless AP used by universities and businesses is a bit of a problem
Comment 5 Adam Williamson 2012-04-20 17:36:36 EDT
Discussed at 2012-04-20 blocker review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-04-20/fedora-bugzappers.2012-04-20-17.01.log.txt . Agreed that this affects enough wireless configurations to constitute a violation of Alpha criterion "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops", and so is accepted as a release blocker.
Comment 6 Kevin Kofler 2012-04-26 06:07:03 EDT
For reference, the complete affected EVR is wpa_supplicant-1.0-0.3.fc17.
This only affects Fedora 17 and Rawhide, Fedora 15 and 16 not affected.
Comment 7 Pedro Francisco 2012-04-26 06:34:15 EDT
Yes, reverting to wpa_supplicant-1.0-0.2.fc17 works fixes the problem.

I have been checking the repos/SRPM, wpa_supplicant-1.0-0.3.fc17 uses a snapshot from wpa-supplicant git repo.

I've been following wpa-supplicant's ML and noone else complained about MSCHAP/EAPOL state machine; I'm guessing it's gone by unnoticed on the git tree.

The only Fedora specific changes were a migration from libnl2 to libnl3 and dropping 0001-Fall-back-to-other-drivers-if-global-init-for-one-dr.patch .
Comment 8 Pedro Francisco 2012-05-02 08:31:12 EDT
It seems the problem was fixed by upstream.

(I've modified Fedora's SRPM to compile upstream's 1.0-rc3 instead of 1.0-rc2.git20120302 and it seems to work)

I can't however find the commit that fixed it -- the closest one is for TTLS/MSCHAP . So if anyone else can confirm I'd appreciate.
Comment 9 lionghostshop 2012-05-02 21:00:33 EDT
Is the  1.0-rc3 in yum repository now?
Comment 10 Pedro Francisco 2012-05-03 03:57:38 EDT
Nop. Just upstream.
Comment 11 lionghostshop 2012-05-03 04:05:24 EDT
So we, ordinary users, cannot test it.
Comment 12 Pedro Francisco 2012-05-03 05:01:41 EDT
It is now on Fedora repos, courtesy of dcbw ( http://koji.fedoraproject.org/koji/buildinfo?buildID=316646 )

P.S.: I'm an ordinary user too, I just manually updated my the RPM :p
Comment 13 lionghostshop 2012-05-03 22:54:55 EDT
Fixed in wpa_supplicant-1.0-0.4.fc17.x86_64 from yum
Comment 14 Pedro Francisco 2012-05-04 17:13:50 EDT
http://meetbot.fedoraproject.org/fedora-bugzappers/2012-05-04/f17-final-blocker-review-4.2012-05-04-17.00.html says:
«there are reports that this has been fixed - not clear whether the update is in stable yet or not»


Does this help?

$ sudo yum list installed |grep wpa_supplicant
wpa_supplicant.i686                    1:1.0-0.4.fc17           @fedora
Comment 15 Adam Williamson 2012-05-04 18:30:26 EDT
The latest wpa_supplicant in stable is this one:

https://admin.fedoraproject.org/updates/FEDORA-2012-7053/wpa_supplicant-1.0-0.4.fc17

the update information does not mention this bug, but the package changelog does say:

* Tue May 01 2012 Dan Williams <dcbw@redhat.com> - 1:1.0-0.4 
- Update to wpa_supplicant 1.0-rc3

and Pedro and lionghostshop both suggest that is the build that fixes this bug. Given this info, I think we should close the bug.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers