Bug 80290

Summary: gedit does not have default printer font
Product: [Retired] Red Hat Linux Beta Reporter: Leon Ho <llch>
Component: geditAssignee: Havoc Pennington <hp>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: beta3CC: eng-i18n-bugs, otaylor
Target Milestone: ---Keywords: MoveUpstream, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-12 21:27:15 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79579    

Description Leon Ho 2002-12-23 23:08:14 EST
Description of problem: 
gedit does not have default printer font anymore - especially to CJK, as it require a 
specific font for printing 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
everytime 
 
Steps to Reproduce: 
1. gedit 
2. edit -> preference -> printer -> fonts 
 
     
Actual results: 
first font on the font list 
 
Expected results: 
default font, or specific default font for CJK 
 
Additional info: 
It pops with warning messages. ie: 
... 
(gedit:3594): GnomePrint-WARNING **: Can't create GPFontEntry for 
LucidaTypewriter-Regular because the extension could not be recognized (.pcf) 
 
 
(gedit:3594): GnomePrint-WARNING **: Can't create GPFontEntry for 
LucidaTypewriter-Regular because the extension could not be recognized (.pcf) 
 
 
(gedit:3594): GnomePrint-WARNING **: Can't create GPFontEntry for 
LucidaTypewriter-Regular because the extension could not be recognized (.pcf) 
 
 
(gedit:3594): GnomePrint-WARNING **: Can't create GPFontEntry for 
LucidaTypewriter-Regular because the extension could not be recognized (.pcf) 
 
 
(gedit:3594): GnomePrint-WARNING **: Can't create GPFontEntry for 
LucidaTypewriter-Regular because the extension could not be recognized (.pcf) 
 
 
(gedit:3594): GnomePrint-WARNING **: Can't create GPFontEntry for 
LucidaTypewriter-Regular because the extension could not be recognized (.pcf) 
 
 
(gedit:3594): GnomePrint-WARNING **: Can't create GPFontEntry for AR PL 
Mingti2L Big5-Reguler because the extension could not be recognized (font) 
...
Comment 1 Havoc Pennington 2002-12-24 00:06:01 EST
The defaults are bad in the .schemas file:

  <default>Mononospace 9</default>
 <default>Sans Normal 11</default>
 <default>Sans Normal 8</default>

Mononospace is definitely nonexistent, and not sure "Sans normal 11" is the 
right syntax. It may be.

This should be fixed upstream. Also, if we want to localize the default 
printer fonts we need the <default> line in gedit.schemas.in moved 
inside the <locale name="C"> element.

However it may be wrong to localize, as "monospace" and "sans-serif" aliases
should always map to something that works in all languages. If we need a
different default for printing, maybe we need to address that on the fontconfig 
layer. fontconfig is supposed to fix the annoying need to localize default 
fonts all over the place, let's not go back to the bad old days.
If a program specifies "sans-serif" it needs to always work, on screen and in print.

Filed as http://bugzilla.gnome.org/show_bug.cgi?id=101892

(Marking bug public)

Keeping bug open so we can be sure we fix it by release, but I'm expecting 
to see us fix it (especially the translation part, if any) on cvs.gnome.org, 
not in a Red Hat patch.
Comment 2 Leon Ho 2003-01-02 22:56:48 EST
Another problem that catch in eyes is that in printer's font dialog it does not have 
any entries for those aliases (Monospace, Sans, Serif). It will not be intentional 
wouldn't it? 
Comment 3 Havoc Pennington 2003-01-03 00:33:45 EST
I don't know if it's intentional, should perhaps file a bug against 
libgnomeprintui (on bugzilla.gnome.org) and CC owen and myself.
Comment 4 Leon Ho 2003-01-03 00:50:34 EST
Done. Filed as http://bugzilla.gnome.org/show_bug.cgi?id=102400 
Comment 5 Havoc Pennington 2003-01-12 21:27:15 EST
Upstream
Comment 6 Leon Ho 2003-01-30 22:50:57 EST
It is fixed on gedit 2.2. It would be great if you can build the new package for 
libgnomeprint*22 2.2 and gedit 2.2. 
Comment 7 Akira TAGOH 2003-01-31 03:34:50 EST
No, Leon. it's not fixed in gedit/libgnomeprint[ui] 2.2 yet.
Right now three patches are needed.
For two patches, see
http://lists.gnome.org/archives/gnome-print-list/2003-January/msg00038.html threads.

Basically above two patches just works. but style selections for Sans, Serif and
Monospace doesn't work.
last patch is that. (these patches are included in libgnomeprint you've tested.)
I will submit it to the upstream, though.
Comment 8 Leon Ho 2003-01-31 06:04:10 EST
With those upgraded packages, I am able to preview and print from gedit. ie. 
zh_CN.GB18030 is using ZYSong18030 from default. Is there something I missed in 
sight?

Actually look like libgnomeprint 2.2 can able to get the desired font for alias 
like Monospace (by look at the output of 'fonts' test util. Of course again, I 
may missed something.
Comment 9 Leon Ho 2003-01-31 06:18:09 EST
Right I might understand now. It works because I used the package you have with 
the 'patches'. ;-) Thanks for clearing it up for me.