Bug 803870

Summary: [3.0.x] All bottom buttons get disabled after creating child resource
Product: [Other] RHQ Project Reporter: Charles Crouch <ccrouch>
Component: Core UIAssignee: Ian Springer <ian.springer>
Status: CLOSED DEFERRED QA Contact: Mike Foley <mfoley>
Severity: low Docs Contact:
Priority: medium    
Version: unspecifiedCC: ccrouch, hbrock, hrupp, jshaughn, loleary, lzoubek, mazz
Target Milestone: ---   
Target Release: JON 3.0.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 796096 Environment:
Last Closed: 2013-05-20 17:01:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 796096    
Bug Blocks:    

Description Charles Crouch 2012-03-15 15:26:19 EDT
+++ This bug was initially created as a clone of Bug #796096 +++

Version-Release number of selected component (if applicable):
Version: 3.0.1.GA
Build Number: dd8a001:fbca611
GWT Version: 2.0.4
SmartGWT Version: 2.4

How reproducible:always on firefox 3.6.24 and chromium 17


Steps to Reproduce:
1. have EAP5 in inventory
2. go to EAP5 resource, Inventory tab and create new child
3. upload some WAR, finish wizard
  
Actual results:All buttons on the bottom [Delete,Import,Create Child,Uninventory,Refresh] are disabled, so user cannot hit refresh to see if the child was deployed successfully.


Expected results: Running 'Create Child' wizard should not affect bottom buttons like 'Refresh' which should be enabled


Additional info: this is a minor issue

--- Additional comment from mfoley@redhat.com on 2012-02-27 12:13:03 EST ---

triage 2/27/2012 mfoley, asantos, crouch, loleary

--- Additional comment from mazz@redhat.com on 2012-03-15 11:44:46 EDT ---

this is yet another place we missed when we changed something in the component implementation. should be easy to fix though.

--- Additional comment from mazz@redhat.com on 2012-03-15 14:29:56 EDT ---

this is strange - this has been fixed in master for quite some time... see commit 85882c6e0e00d5d788032d9c4192577c21e4fcc6 done in august 2011.

--- Additional comment from mazz@redhat.com on 2012-03-15 14:33:08 EDT ---

(In reply to comment #3)
> this is strange - this has been fixed in master for quite some time... see
> commit 85882c6e0e00d5d788032d9c4192577c21e4fcc6 done in august 2011.

Ok, I confirmed this is in master but NOT in release/jon3.0.x branch.

We would need to cherry pick 85882c6e0e00d5d788032d9c4192577c21e4fcc6 to fix this.

--- Additional comment from mazz@redhat.com on 2012-03-15 14:58:25 EDT ---

this was fixed in the release/3.0.x branch, but the following commit undid that fix and reintroduced the bug:

http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=0d4efdc85ef65f6cdcf7954766cd28186a36ab63

--- Additional comment from ccrouch@redhat.com on 2012-03-15 15:02:14 EDT ---

Setting Target Release to be JON3.1.0 and setting to ONQA since its now fixed in master.
Comment 1 Charles Crouch 2012-03-15 15:28:28 EDT
This BZ is just tracking the fixing of the merge issue mazz describes below. Until 3.0.1 is released just create a patch that fixes this issue, once jon3.0.1 is released the patch can be applied to the release/jon3.0.x branch to bring it back into shape.
Comment 2 John Mazzitelli 2012-03-15 15:37:12 EDT
ResourceTypeRepository and ResourceCompositeSearchView are the two classes we need to look at to confirm they are fixed. ResourceCompositeSearchView for sure needs to be fixed, since its missing the changes that corrected the bug that this issue mentioned (the buttons not getting enabled).
Comment 3 John Mazzitelli 2012-03-15 15:43:45 EDT
(In reply to comment #2)
> ResourceTypeRepository and ResourceCompositeSearchView are the two classes we
> need to look at to confirm they are fixed. ResourceCompositeSearchView for sure
> needs to be fixed, since its missing the changes that corrected the bug that
> this issue mentioned (the buttons not getting enabled).

The changes between master and release/3.0.x in ResourceTypeRepository are trivial, I don't think anything is missing or broke here.

We just have to fix ResourceCompositeSearchView
Comment 4 John Mazzitelli 2012-03-15 15:57:58 EDT
by looking at the code, it appears we may have lost the fix for this too: bug #751421

That shows it was fixed for JON 3.0.0 but the code looks missing for 3.0.1 (in ResourceCompositeSearchView)
Comment 5 John Mazzitelli 2012-03-15 16:43:53 EDT
assigning to ips - he should have better knowledge of what was supposed to get checked in and what wasn't.

this should only be checked into the release/3.0.x branch AFTER the 3.0.1 release has gone out (as per charles).
Comment 6 Jay Shaughnessy 2013-02-26 16:19:23 EST
This has been fixed and, if it hasn't made it into a JON release yet, will make it into 3.2.
Comment 7 Larry O'Leary 2013-05-20 17:01:50 EDT
Closing this as DEFERRED. This fix was verified in downstream JBoss ON 3.1 as per bug 796096.