Bug 804309

Summary: [abrt] abrt-addon-ccpp-2.0.7-4.fc17: abrt-action-analyze-core:106:extract_info_from_core:IndexError: list index out of range
Product: [Fedora] Fedora Reporter: Mikhail <mikhail.v.gavrilov>
Component: abrtAssignee: abrt <abrt-devel-list>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: abrt-devel-list, awilliam, bruno, dvlasenk, hundred17, inbox+redhat, iprikryl, jfrieben, jmoskovc, jsmith.fedora, kklic, kparal, mads, marcos.brito.carvalho, mikhail.v.gavrilov, mjw, mmilata, mtoman, nb, npajkovs, robatino, salrefrisal
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=805447
Whiteboard: abrt_hash:80e073a19635ff8fdf61be575fcf17733ebbfc30 RejectedBlocker AcceptedNTH
Fixed In Version: abrt-2.0.10-1.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-18 18:58:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 752653    
Attachments:
Description Flags
File: backtrace none

Description Mikhail 2012-03-17 14:02:38 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python -u /usr/bin/abrt-action-analyze-core --core=coredump -o build_ids
executable:     /usr/bin/abrt-action-analyze-core
kernel:         3.3.0-0.rc6.git0.2.fc17.i686.PAE
reason:         abrt-action-analyze-core:106:extract_info_from_core:IndexError: list index out of range
time:           Сб. 17 марта 2012 16:47:39
uid:            1000
username:       mikhail

backtrace:      Text file, 14565 bytes

smolt_data:
:
:
:General
:=================================
:UUID: 6478aaa9-30e4-4a97-a123-b179d02652cd
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 3391.55
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Athlon(tm) II Neo K125 Processor
:CPU Stepping: 3
:CPU Family: 16
:CPU Model Num: 6
:Number of CPUs: 1
:CPU Speed: 1700
:System Memory: 3778
:System Swap: 4095
:Vendor: Acer
:System: AO521 Not Applicable
:Form factor: Notebook
:Kernel: 3.3.0-0.rc6.git0.2.fc17.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17297:4133:1085) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
:(4098:17302:4133:1085) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4130:38401:4133:1085) pci, None, HOST/PCI, RS880 Host Bridge
:(4130:38402:4130:1085) pci, None, PCI/PCI, RS780/RS880 PCI to PCI bridge (int gfx)
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(6505:8288:4133:1085) pci, atl1c, ETHERNET, AR8152 v1.1 Fast Ethernet
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(5772:43:4187:57397) pci, ath9k, NETWORK, AR9285 Wireless Network Adapter (PCI-Express)
:(4098:17285:0:0) pci, None, SERIAL, SBx00 SMBus Controller
:(4098:17309:4133:1085) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:4133:1085) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:38674:4133:1085) pci, radeon, VIDEO, M880G [Mobility Radeon HD 4200]
:(4098:38671:4098:38674) pci, snd_hda_intel, MULTIMEDIA, RS880 Audio Device [Radeon HD 4200]
:(4098:17303:4133:1085) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17302:4133:1085) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:4133:1085) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4130:38404:4133:1085) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 0)
:(4130:38405:4133:1085) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 1)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 6094889 3931060 3870038 1531904 1347360 1347360
:/dev/sda5 /home ext4 4096 4096 48953540 4825571 2374864 12255232 12100236 12100236
:
Comment 1 Mikhail 2012-03-17 14:02:43 EDT
Created attachment 570815 [details]
File: backtrace
Comment 2 Mikhail 2012-03-17 14:10:55 EDT
Create backtrace for tracker process with Local GNU Debugger

Package: abrt-addon-ccpp-2.0.7-4.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Mikhail 2012-03-19 07:24:41 EDT
try create backtrace for evolution

Package: abrt-addon-ccpp-2.0.7-4.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 4 Joachim Frieben 2012-03-20 13:10:32 EDT
I have tried to create an error repor for gnome-screenshot.

Package: abrt-addon-ccpp-2.0.7-4.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Joel 2012-03-20 16:32:12 EDT
I think this happened after google-chrome crashed and abrt sprung into action.

Package: abrt-addon-ccpp-2.0.7-4.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Mads Kiilerich 2012-03-21 06:08:51 EDT
trying to report a segfault

Package: abrt-addon-ccpp-2.0.7-4.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 7 Mads Kiilerich 2012-03-21 06:41:32 EDT
This is caused by Bug 805447 - eu-unstrip emits garbage for librt.so.1

It is however a bug in abrt that it doesn't ignore invalid lines. Fixed by:

--- abrt-action-analyze-core	2012-03-21 11:13:21.376638423 +0100
+++ /usr/bin/abrt-action-analyze-core	2012-03-21 11:21:20.609658068 +0100
@@ -100,7 +100,7 @@
 
     for line in lines:
         b_ids_line = line.split()
-        if len(b_ids_line) > 2:
+        if len(b_ids_line) > EXECUTABLE:
             # [exe] -> the executable itself
             # linux-vdso.so.1 -> Virtual Dynamic Shared Object
             if b_ids_line[EXECUTABLE] not in ["linux-vdso.so.1"]:

(Which also can be used as a workaround.)

These bugs will prevent reporting of other more serious bugs and is thus very unfortunate while we are testing. I thus nominate this as a f17betablocker.
Comment 8 Kamil Páral 2012-03-21 11:03:06 EDT
This is definitely a Final blocker:
"All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items"
https://fedoraproject.org/wiki/Fedora_17_Final_Release_Criteria

However, it seems quite logical we should demand to have ABRT functional earlier (Beta or Alpha), because it can catch a lot of bugs in Fedora Branched. I haven't found such criterion though. If other QA guys agree, I would be OK with adding this new criterion to Alpha/Beta and then mark this bug as a Beta blocker.
Comment 9 Mads Kiilerich 2012-03-21 11:38:37 EDT
Note that eu-unstrip (and thus abrt) apparently works just fine in many cases, and this issue might thus be less serious than I thought.
Comment 10 Adam Williamson 2012-03-21 13:19:19 EDT
I'm not sure I'd agree with a criterion to have abrt working at Alpha/Beta stage at least, since it can be fixed with an update. It may be worthwhile at final, not sure...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Kevin Fenzi 2012-03-21 18:58:27 EDT
-1 blocker, +1 NTH
Comment 12 Jared Smith 2012-03-21 19:02:34 EDT
-1 blocker, +1 NTH
Comment 13 Adam Williamson 2012-03-21 19:16:15 EDT
I'm -1 blocker here too, mainly on the basis that this isn't stopping all abrt reports, only a few. I've filed several abrt reports over the last few days without any issues.

I'm +/-0 NTH, since it's so easy to fix with an update, but I guess we might want to make sure as many live crashes as possible can be reported.

That's three -1s, so setting rejectedblocker: NTH status is still open, currently at +2. Kamil or Mads, if you come up with further data that merits re-consideration as blocker, please do add it!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Nick Bebout 2012-03-21 21:28:32 EDT
-1 blocker

+1 NTH - it'd be nice to have abrt working for beta
Comment 15 Bruno Wolff III 2012-03-21 22:21:19 EDT
-1 blocker

+0 NTH Arguably this will help with testing and people using live images aren't likely to updates. However with it affecting only some aborts and people doing installs likely getting updates, I am not convinced we need this for the beta release.
Comment 16 Mikhail 2012-03-21 22:22:58 EDT
try create backtrace for nautilus

Package: abrt-addon-ccpp-2.0.7-4.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 Kamil Páral 2012-03-22 07:27:11 EDT
I was initially afraid this stops most of the crashes being reported. If it concerns only some fraction of them, I'm -1 blocker +1 NTH.
Comment 18 Adam Williamson 2012-03-30 15:24:47 EDT
Discussed at 2012-03-30 NTH review meeting. Accepted as NTH as this affects reports of installation bugs and can't be fixed with an update for that context.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Mark Wielaard 2012-04-02 04:52:58 EDT
(In reply to comment #7)
> This is caused by Bug 805447 - eu-unstrip emits garbage for librt.so.1

There is now an upstream fix for this issue in elfutils. Do you want us to backport that to the fedora elfutils package? Or is your workaround in abrt enough for now?
Comment 20 Jiri Moskovcak 2012-04-02 07:33:02 EDT
(In reply to comment #19)
> (In reply to comment #7)
> > This is caused by Bug 805447 - eu-unstrip emits garbage for librt.so.1
> 
> There is now an upstream fix for this issue in elfutils. Do you want us to
> backport that to the fedora elfutils package? Or is your workaround in abrt
> enough for now?

- I'm going to add the patch with the proposed fix to F17, but would be great if this is also fixed in eu-unstrip - F17 is not yet so old to not backport it ;)
Comment 21 Fedora Update System 2012-04-02 09:32:13 EDT
abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17
Comment 22 Fedora Update System 2012-04-02 13:44:17 EDT
Package abrt-2.0.10-1.fc17, libreport-2.0.10-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.10-1.fc17 libreport-2.0.10-2.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5200/abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17
then log in and leave karma (feedback).
Comment 23 Mark Wielaard 2012-04-04 17:01:59 EDT
(In reply to comment #20)
> - I'm going to add the patch with the proposed fix to F17, but would be great
> if this is also fixed in eu-unstrip - F17 is not yet so old to not backport it
> ;)

elfutils-0.153-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/elfutils-0.153-2.fc17
Fix for bug 805447 - eu-unstrip emits garbage for librt.so.1

But it currently seems a bit stuck because of the beta change deadline.
Testing and karma appreciated to get it into f17 soon.
Comment 24 Kamil Páral 2012-04-12 08:19:05 EDT
Beta is out, moving to F17 Final NTH
Comment 25 Fedora Update System 2012-04-18 18:58:16 EDT
abrt-2.0.10-1.fc17, libreport-2.0.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.