This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 804881

Summary: Inserting a flash drive does not create a device usable for mounting it
Product: [Fedora] Fedora Reporter: Bruno Wolff III <bruno>
Component: systemdAssignee: udev-maint
Status: CLOSED EOL QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: bruno, harald, johannbg, jonathan, jsynacek, lnykryn, msekleta, s, systemd-maint, udev-maint, vpavlin, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-04 21:47:43 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Bruno Wolff III 2012-03-20 00:26:34 EDT
Description of problem:
I am not sure when this started, but now when I stick a flash drive (I tried three different kinds) in, the device is detected, but no /dev/sd* file is created.

Version-Release number of selected component (if applicable):
I tried both udev-182-1.fc17.i686 and udev-181-2.fc17.i686.

How reproducible:
100% so far

Steps to Reproduce:
1. Plug in a usb drive
2.
3.
  
Actual results:
Mar 19 23:25:03 bruno udevd[27769]: unknown key 'ID_INPUT_TOUCHPAD' in /usr/lib/udev/rules.d/65-libwacom.rules:39
Mar 19 23:25:03 bruno udevd[27769]: invalid rule '/usr/lib/udev/rules.d/65-libwacom.rules:39'
Mar 19 23:25:03 bruno kernel: [19979.656090] usb 1-1: new full-speed USB device number 14 using ohci_hcd
Mar 19 23:25:04 bruno kernel: [19979.848977] usb 1-1: New USB device found, idVendor=3538, idProduct=0059
Mar 19 23:25:04 bruno kernel: [19979.849035] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Mar 19 23:25:04 bruno kernel: [19979.849048] usb 1-1: Product: PQI USB Flash Drive
Mar 19 23:25:04 bruno kernel: [19979.849056] usb 1-1: Manufacturer: PQI
Mar 19 23:25:04 bruno kernel: [19979.849063] usb 1-1: SerialNumber: 00000000001AE1
Mar 19 23:25:04 bruno mtp-probe: checking bus 1, device 14: "/sys/devices/pci0000:00/0000:00:10.0/0000:02:00.0/usb1/1-1"
Mar 19 23:25:04 bruno mtp-probe: bus: 1, device: 14 was not an MTP device

But no /dev/sd* device created.

Expected results:
/dev/sd* device created

Additional info:
Comment 1 Bruno Wolff III 2012-03-20 10:38:00 EDT
This looks to be some sort of local configuration issue. It failed the same way on two machines (f17 and f18) at home, but works as expected on an f17 machine at work.
I look to see if I can figure out what's different between the machines.
These have all been yum upgraded between releases several times, so there may be some cruft causing a problem.
Comment 2 Bruno Wolff III 2012-03-24 14:29:13 EDT
Now I am just seeing this on f18. So maybe there is a fix that I just haven't gotten yet.
Comment 3 Fedora End Of Life 2013-04-03 13:56:33 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 4 Lennart Poettering 2015-01-04 21:47:43 EST
This bug really doesn't appear to be related to any recent version of systemd. Please reopen if you can reproduce this with current, supported versions of Fedora. Thanks.