Bug 805285

Summary: iwlwifi loses connection after "queue stuck" message
Product: [Fedora] Fedora Reporter: Joel Uckelman <uckelman>
Component: kernelAssignee: John W. Linville <linville>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: abelisle, belegdol, bernard, bfields, bugzilla.redhat, cameron.e.wood, cfergeau, crowed, david, devel.niks, gansalmon, gholms, itamar, jonathan, jperrin, kernel-maint, lord.quackstar, madhu.chinakonda, martin, mvrk, mwahren, nikodll, pgunn, rderooy, redhat-bugzilla, redhat, sgruszka, tobias.vogel, tom.jenkinson, wey-yi.w.guy
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-09 03:07:39 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
dmesg output none

Description Joel Uckelman 2012-03-20 15:48:34 EDT
Description of problem:

At seemingly random intervals, my wireless connection stops working (though NetworkManager shows I am still connected).

% lspci | grep Centrino
03:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 3e)

This is what I see in dmesg when the problem happens:

[ 4072.821675] iwlwifi 0000:03:00.0: Queue 2 stuck for 2000 ms.
[ 4072.821679] iwlwifi 0000:03:00.0: Current SW read_ptr 41 write_ptr 45
[ 4072.821734] iwlwifi 0000:03:00.0: Current HW read_ptr 41 write_ptr 45
[ 4072.821736] iwlwifi 0000:03:00.0: On demand firmware reload
[ 4072.822235] ieee80211 phy0: Hardware restart was requested
[ 4072.822303] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 4072.822479] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1

The problem has been happening for me with my Thinkpad W520 since at least kernel 3.2.2.

Version-Release number of selected component (if applicable):

kernel-3.2.10-3.fc16.x86_64

How reproducible:

Generally within fifteen minutes of booting.

Steps to Reproduce:
1. Connect to the wireless network.
2. Do anything which causes traffic.
  
Actual results:

Wireless flakes out.

Expected results:

Wireless should keep working.


Additional info:

This bug is presumably not the same as the one solved when Bug 785239 was closed, as many commenters there still have a problem. I've opened this bug so that there is an open bug to catch those problem reports.
Comment 1 John W. Linville 2012-03-21 10:03:29 EDT
Thanks for opening a new bug.  Hopefully that will isolate attention to the specific problem you are experiencing.
Comment 2 Stanislaw Gruszka 2012-03-21 10:19:25 EDT
Currently firmware restart is broken, perhaps firmware will recover itself without restart, try wd_disable=1 module option. If it will not help, please check if this is 11n issue, by run driver with 11n_disable=1 option
Comment 3 Joel Uckelman 2012-03-21 14:14:07 EDT
I tried wd_disable=1 on the current boot. It makes no difference that I can see. I'll try 11n_disable=1 the next time I boot.
Comment 4 Stanislaw Gruszka 2012-03-21 14:47:25 EDT
Apparently there should be no "Queue stuck" messages with wd_disable=1, device can still malfunction of course.
Comment 5 Joel Uckelman 2012-03-21 15:01:25 EDT
From dmesg:

[    0.000000] Command line: BOOT_IMAGE=/vmlinuz-3.2.10-3.fc16.x86_64 root=/dev/mapper/vg_scylla-lv_root ro quiet rhgb SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us wd_disable=1

When the connection went bad:

[  480.454781] iwlwifi 0000:03:00.0: Queue 2 stuck for 2000 ms.
[  480.454784] iwlwifi 0000:03:00.0: Current SW read_ptr 53 write_ptr 55
[  480.454840] iwlwifi 0000:03:00.0: Current HW read_ptr 53 write_ptr 55
[  480.454841] iwlwifi 0000:03:00.0: On demand firmware reload
[  480.455432] ieee80211 phy0: Hardware restart was requested
[  480.455502] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  480.455675] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1

So it looks like I do get "queue stuck" messages with wd_disable=1.
Comment 6 Stanislaw Gruszka 2012-03-21 16:23:57 EDT
If you want pass module parameter through kernel command line, module name should be specified i.e: iwlwifi.wd_disable=1

Note: you do not have to reboot to test module parameter, it can be done on run-time, like in example:

modprobe -r iwlwifi
modprobe  iwlwifi wd_disable=1
Comment 7 Julian Sikorski 2012-03-21 17:08:36 EDT
Mar 21 21:58:57 snowball2 kernel: [12172.136085] iwlwifi 0000:04:00.0: Queue 2 stuck for 10000 ms.
Mar 21 21:58:57 snowball2 kernel: [12172.136097] iwlwifi 0000:04:00.0: Current SW read_ptr 13 write_ptr 43
Mar 21 21:58:57 snowball2 kernel: [12172.136154] iwlwifi 0000:04:00.0: Current HW read_ptr 13 write_ptr 43
Mar 21 21:58:57 snowball2 kernel: [12172.136159] iwlwifi 0000:04:00.0: On demand firmware reload
Mar 21 21:58:57 snowball2 kernel: [12172.136675] ieee80211 phy0: Hardware restart was requested
Mar 21 21:58:57 snowball2 kernel: [12172.136816] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
Mar 21 21:58:57 snowball2 kernel: [12172.144112] iwlwifi 0000:04:00.0: Radio type=0x1-0x2-0x0

Same here, with 3.2.10-3.fc16.x86_64. I was experiencing bug 785239 before, but it was much more severe. This bug only manifest itself after uptime of hours while the old one was allowing the wlan connection to last mere minutes.
I have a Wireless-N 6320 card here.
Comment 8 Joel Uckelman 2012-03-21 20:27:23 EDT
(In reply to comment #6)
> If you want pass module parameter through kernel command line, module name
> should be specified i.e: iwlwifi.wd_disable=1

Aha, I thought it was a kernel parameter, not a module parameter. Thanks.

> Note: you do not have to reboot to test module parameter, it can be done on
> run-time, like in example:
> 
> modprobe -r iwlwifi
> modprobe  iwlwifi wd_disable=1

When I do this, it causes a different problem: It appears to crash the NetworkManager applet, and then when I restart the NM applet, the interface won't come back up:

[22467.238996] udevd[29403]: renamed network interface wlan0 to wlan1
[22543.139892] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[22543.140098] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[22543.378661] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[22543.378866] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[22543.497744] ADDRCONF(NETDEV_UP): wlan1: link is not ready

It seems like specifying the parameter it at boot time is a more reliable way for me to test, for the moment.

I've been running for an hour and a half now with iwlwifi.wd_disable=1 without any connection problems, so this is promising.
Comment 9 Joel Uckelman 2012-03-22 01:31:10 EDT
I've now run for 6:30 using iwlwifi.wd_disable=1 without issue.
Comment 10 Dave Jones 2012-03-22 12:50:35 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 11 Dave Jones 2012-03-22 12:54:51 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 12 Dave Jones 2012-03-22 13:05:33 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 13 Julian Sikorski 2012-03-22 15:47:20 EDT
$ uptime
 20:46:23 up  1:41,  3 users,  load average: 0.64, 0.74, 0.76
$ uname -r
3.3.0-4.fc16.x86_64
No problem with wlan until now.
Comment 14 Julian Sikorski 2012-03-22 16:37:07 EDT
Looks like I spoke too soon. After approx. 2 and a half hours of uptime problem has hit again:

[ 8776.800424] iwlwifi 0000:04:00.0: Queue 12 stuck for 10000 ms.
[ 8776.800427] iwlwifi 0000:04:00.0: Current SW read_ptr 47 write_ptr 14
[ 8776.800476] iwlwifi 0000:04:00.0: Current HW read_ptr 47 write_ptr 14
[ 8776.800477] iwlwifi 0000:04:00.0: On demand firmware reload
[ 8776.800954] ieee80211 phy0: Hardware restart was requested
[ 8776.801065] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[ 8776.808174] iwlwifi 0000:04:00.0: Radio type=0x1-0x2-0x0

I'll try with iwlwifi.wd_disable=1 later, probably tomorrow.
Comment 15 Joel Uckelman 2012-03-23 16:49:29 EDT
I still get stuck queues with kernel-3.3.0-4.fc16.x86_64 when not using iwlwifi.wd_disable=1.

[  966.188053] iwlwifi 0000:03:00.0: Queue 2 stuck for 2000 ms.
[  966.188063] iwlwifi 0000:03:00.0: Current SW read_ptr 75 write_ptr 80
[  966.188139] iwlwifi 0000:03:00.0: Current HW read_ptr 75 write_ptr 80
[  966.188144] iwlwifi 0000:03:00.0: On demand firmware reload
[  966.188667] ieee80211 phy0: Hardware restart was requested
[  966.188744] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  966.188921] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1

I don't know whether it's relevant, but in this case it happened first under heavy traffic, as I was pulling a VM image using rsync.
Comment 16 Julian Sikorski 2012-03-25 07:34:37 EDT
Created attachment 572519 [details]
dmesg output

I was running the laptop for almost 12 hours with wd_disable=1. A different type of error has appeared:

[11268.479420] iwlwifi 0000:04:00.0: Microcode SW error detected.  Restarting 0x82000000.
[11268.479432] iwlwifi 0000:04:00.0: Loaded firmware version: 17.168.5.2 build 35905
[11268.479581] iwlwifi 0000:04:00.0: Start IWL Error Log Dump:
[11268.479587] iwlwifi 0000:04:00.0: Status: 0x000412E5, count: 6
[11268.479594] iwlwifi 0000:04:00.0: 0x00002076 | ADVANCED_SYSASSERT          
[11268.479599] iwlwifi 0000:04:00.0: 0x00009AE8 | uPc
[11268.479603] iwlwifi 0000:04:00.0: 0x00009AA2 | branchlink1
[11268.479608] iwlwifi 0000:04:00.0: 0x00009AA2 | branchlink2
[11268.479612] iwlwifi 0000:04:00.0: 0x0000DC1A | interruptlink1
[11268.479617] iwlwifi 0000:04:00.0: 0x00000000 | interruptlink2
[11268.479621] iwlwifi 0000:04:00.0: 0x00000000 | data1
[11268.479626] iwlwifi 0000:04:00.0: 0x00000200 | data2
[11268.479630] iwlwifi 0000:04:00.0: 0x00000573 | line
[11268.479634] iwlwifi 0000:04:00.0: 0x00018C3A | beacon time
[11268.479639] iwlwifi 0000:04:00.0: 0x000003C6 | tsf low
[11268.479643] iwlwifi 0000:04:00.0: 0x00000000 | tsf hi
[11268.479647] iwlwifi 0000:04:00.0: 0x00000000 | time gp1
[11268.479652] iwlwifi 0000:04:00.0: 0x9EDE5538 | time gp2
[11268.479656] iwlwifi 0000:04:00.0: 0x00000000 | time gp3
[11268.479661] iwlwifi 0000:04:00.0: 0x000111A8 | uCode version
[11268.479665] iwlwifi 0000:04:00.0: 0x000000B0 | hw version
[11268.479670] iwlwifi 0000:04:00.0: 0x00480303 | board version
[11268.479674] iwlwifi 0000:04:00.0: 0x047D004E | hcmd
[11268.479679] iwlwifi 0000:04:00.0: 0x2F863082 | isr0
[11268.479683] iwlwifi 0000:04:00.0: 0x11406000 | isr1
[11268.479687] iwlwifi 0000:04:00.0: 0x00000F1F | isr2
[11268.479692] iwlwifi 0000:04:00.0: 0x014600C3 | isr3
[11268.479696] iwlwifi 0000:04:00.0: 0x00000000 | isr4
[11268.479700] iwlwifi 0000:04:00.0: 0x01000112 | isr_pref
[11268.479705] iwlwifi 0000:04:00.0: 0x00016712 | wait_event
[11268.479709] iwlwifi 0000:04:00.0: 0x00004288 | l2p_control
[11268.479714] iwlwifi 0000:04:00.0: 0x0000013A | l2p_duration
[11268.479718] iwlwifi 0000:04:00.0: 0x000003BF | l2p_mhvalid
[11268.479723] iwlwifi 0000:04:00.0: 0x001155C6 | l2p_addr_match
[11268.479727] iwlwifi 0000:04:00.0: 0x00000005 | lmpm_pmg_sel
[11268.479732] iwlwifi 0000:04:00.0: 0x10021048 | timestamp
[11268.479736] iwlwifi 0000:04:00.0: 0x00001020 | flow_handler
[11268.479741] iwlwifi 0000:04:00.0: CSR values:
[11268.479745] iwlwifi 0000:04:00.0: (2nd byte of CSR_INT_COALESCING is CSR_INT_PERIODIC_REG)
[11268.479777] iwlwifi 0000:04:00.0:        CSR_HW_IF_CONFIG_REG: 0X00480303
[11268.479806] iwlwifi 0000:04:00.0:          CSR_INT_COALESCING: 0X0000ff40
[11268.479837] iwlwifi 0000:04:00.0:                     CSR_INT: 0X00000000
[11268.479867] iwlwifi 0000:04:00.0:                CSR_INT_MASK: 0X00000000
[11268.479894] iwlwifi 0000:04:00.0:           CSR_FH_INT_STATUS: 0X00000000
[11268.479923] iwlwifi 0000:04:00.0:                 CSR_GPIO_IN: 0X00000030
[11268.479951] iwlwifi 0000:04:00.0:                   CSR_RESET: 0X00000000
[11268.479979] iwlwifi 0000:04:00.0:                CSR_GP_CNTRL: 0X080403c5
[11268.480010] iwlwifi 0000:04:00.0:                  CSR_HW_REV: 0X000000b0
[11268.480039] iwlwifi 0000:04:00.0:              CSR_EEPROM_REG: 0X5f4a0ffd
[11268.480071] iwlwifi 0000:04:00.0:               CSR_EEPROM_GP: 0X90000801
[11268.480120] iwlwifi 0000:04:00.0:              CSR_OTP_GP_REG: 0X00030001
[11268.480149] iwlwifi 0000:04:00.0:                 CSR_GIO_REG: 0X00080042
[11268.480177] iwlwifi 0000:04:00.0:            CSR_GP_UCODE_REG: 0X0000cf2d
[11268.480209] iwlwifi 0000:04:00.0:           CSR_GP_DRIVER_REG: 0X00000000
[11268.480236] iwlwifi 0000:04:00.0:           CSR_UCODE_DRV_GP1: 0X00000000
[11268.480265] iwlwifi 0000:04:00.0:           CSR_UCODE_DRV_GP2: 0X00000000
[11268.480293] iwlwifi 0000:04:00.0:                 CSR_LED_REG: 0X00000058
[11268.480321] iwlwifi 0000:04:00.0:        CSR_DRAM_INT_TBL_REG: 0X88127e51
[11268.480350] iwlwifi 0000:04:00.0:        CSR_GIO_CHICKEN_BITS: 0X27800200
[11268.480378] iwlwifi 0000:04:00.0:             CSR_ANA_PLL_CFG: 0X00000000
[11268.480406] iwlwifi 0000:04:00.0:           CSR_HW_REV_WA_REG: 0X0001001a
[11268.480434] iwlwifi 0000:04:00.0:        CSR_DBG_HPET_MEM_REG: 0Xffff0010
[11268.480439] iwlwifi 0000:04:00.0: FH register values:
[11268.480479] iwlwifi 0000:04:00.0:         FH_RSCSR_CHNL0_STTS_WPTR_REG: 0X1277a400
[11268.480517] iwlwifi 0000:04:00.0:        FH_RSCSR_CHNL0_RBDCB_BASE_REG: 0X012775b0
[11268.480554] iwlwifi 0000:04:00.0:                  FH_RSCSR_CHNL0_WPTR: 0X00000010
[11268.480592] iwlwifi 0000:04:00.0:         FH_MEM_RCSR_CHNL0_CONFIG_REG: 0X80819104
[11268.480630] iwlwifi 0000:04:00.0:          FH_MEM_RSSR_SHARED_CTRL_REG: 0X000000fc
[11268.480668] iwlwifi 0000:04:00.0:            FH_MEM_RSSR_RX_STATUS_REG: 0X07030000
[11268.480705] iwlwifi 0000:04:00.0:    FH_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000
[11268.480743] iwlwifi 0000:04:00.0:                FH_TSSR_TX_STATUS_REG: 0X07ff0001
[11268.480781] iwlwifi 0000:04:00.0:                 FH_TSSR_TX_ERROR_REG: 0X00000000
[11268.480861] iwlwifi 0000:04:00.0: Start IWL Event Log Dump: display last 20 entries
[11268.480904] iwlwifi 0000:04:00.0: EVT_LOGT:2665369992:0x0000097d:1547
[11268.480938] iwlwifi 0000:04:00.0: EVT_LOGT:2665369994:0x00000000:1548
[11268.480976] iwlwifi 0000:04:00.0: EVT_LOGT:2665370523:0x0000000d:1250
[11268.481011] iwlwifi 0000:04:00.0: EVT_LOGT:2665370524:0x00000001:1250
[11268.481049] iwlwifi 0000:04:00.0: EVT_LOGT:2665370524:0x00000249:1246
[11268.481083] iwlwifi 0000:04:00.0: EVT_LOGT:2665370526:0x01000000:1242
[11268.481119] iwlwifi 0000:04:00.0: EVT_LOGT:2665370588:0x00000200:0103
[11268.481156] iwlwifi 0000:04:00.0: EVT_LOGT:2665370615:0x00000040:1243
[11268.481192] iwlwifi 0000:04:00.0: EVT_LOGT:2665370621:0x00000004:0463
[11268.481230] iwlwifi 0000:04:00.0: EVT_LOGT:2665370659:0x00000080:1243
[11268.481271] iwlwifi 0000:04:00.0: EVT_LOGT:2665370659:0x00040000:1243
[11268.481318] iwlwifi 0000:04:00.0: EVT_LOGT:2665370732:0x00000034:0454
[11268.481369] iwlwifi 0000:04:00.0: EVT_LOGT:2665370733:0x00000015:0472
[11268.481434] iwlwifi 0000:04:00.0: EVT_LOGT:2665370739:0x00000004:0463
[11268.481476] iwlwifi 0000:04:00.0: EVT_LOGT:2665370741:0x00000000:0663
[11268.481543] iwlwifi 0000:04:00.0: EVT_LOGT:2665370904:0x00000040:1243
[11268.481591] iwlwifi 0000:04:00.0: EVT_LOGT:2665370926:0x00000080:1243
[11268.481639] iwlwifi 0000:04:00.0: EVT_LOGT:2665370926:0x00040000:1243
[11268.481676] iwlwifi 0000:04:00.0: EVT_LOGT:2665370933:0x047d004e:0401
[11268.481711] iwlwifi 0000:04:00.0: EVT_LOGT:2665370956:0x00000000:0125
[11268.481815] iwlwifi 0000:04:00.0: Error: Response NULL in 'REPLY_ADD_STA'
[11268.481831] iwlwifi 0000:04:00.0: Adding station a0:21:b7:ac:c4:c3 failed.
[11268.481843] iwlwifi 0000:04:00.0: Command REPLY_ADD_STA failed: FW Error
[11268.481853] iwlwifi 0000:04:00.0: Adding station ff:ff:ff:ff:ff:ff failed.
[11268.481866] iwlwifi 0000:04:00.0: Command REPLY_RXON_TIMING failed: FW Error
[11268.481877] iwlwifi 0000:04:00.0: Failed to send timing (-5)!
[11268.482397] ieee80211 phy0: Hardware restart was requested

Then, later, connection was completely lost:

[37279.646691] iwlwifi 0000:04:00.0: fail to flush all tx fifo queues
[37399.630111] iwlwifi 0000:04:00.0: fail to flush all tx fifo queues
[37519.404710] iwlwifi 0000:04:00.0: fail to flush all tx fifo queues
[37639.290261] iwlwifi 0000:04:00.0: fail to flush all tx fifo queues
[37643.895199] iwlwifi 0000:04:00.0: fail to flush all tx fifo queues

NM kept asking for password which was correctly stored in the keyring. Full dmesg is attached.
Comment 17 Stanislaw Gruszka 2012-03-27 06:05:01 EDT
That is firmware problem or driver do not talk nicely to firmware.

Driver internal watchdog check for that issues, and reset firmware if error occurs, but since currently firmware reset is broken we are not able to recover.
Comment 18 Julian Sikorski 2012-03-27 06:26:25 EDT
Does this mean you have the information you asked for or should we run more tests?
Comment 19 Stanislaw Gruszka 2012-03-27 06:58:13 EDT
No new information is needed from You. I reported problem to Intel, I'm waiting for they fix.
Comment 20 Joel Uckelman 2012-04-03 08:32:37 EDT
I've noticed that with iwlwifi.wd_disable=1 using kernels 3.3.0-4.fc16.x86_64 and 3.3.0-8.fc16.x86_64, I get a different kind of disconnection problem, sometimes very frequently, sometimes not. dmesg says:

[14010.316211] wlan1: moving STA c0:25:06:55:ae:fe to state 2
[14010.316216] wlan1: moving STA c0:25:06:55:ae:fe to state 1
[14010.316218] wlan1: moving STA c0:25:06:55:ae:fe to state 0
[14010.321076] cfg80211: Calling CRDA to update world regulatory domain
[14010.326180] cfg80211: World regulatory domain updated:
[14010.326182] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[14010.326184] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[14010.326186] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[14010.326187] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[14010.326188] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[14010.326189] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[14010.326268] cfg80211: Calling CRDA for country: NL
[14010.328312] cfg80211: Regulatory domain changed to country: NL
[14010.328314] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[14010.328315] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[14010.328317] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[14010.328318] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[14010.328319] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[14013.049941] wlan1: authenticate with c0:25:06:55:ae:fe (try 1)
[14013.052735] wlan1: authenticated
[14013.053929] wlan1: associate with c0:25:06:55:ae:fe (try 1)
[14013.057633] wlan1: RX ReassocResp from c0:25:06:55:ae:fe (capab=0x431 status=0 aid=2)
[14013.057636] wlan1: associated
[14013.057637] wlan1: moving STA c0:25:06:55:ae:fe to state 1
[14013.057639] wlan1: moving STA c0:25:06:55:ae:fe to state 2
[14013.057640] wlan1: No basic rates in AssocResp. Using min supported rate instead.
[14013.070693] cfg80211: Calling CRDA for country: DE
[14013.072798] cfg80211: Regulatory domain changed to country: DE
[14013.072800] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[14013.072802] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
[14013.072804] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[14013.072806] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[14013.072808] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
[14013.081154] wlan1: moving STA c0:25:06:55:ae:fe to state 3

Is the fact that it's setting the regulatory domain to DE unusual since I'm in NL?
Comment 21 Stanislaw Gruszka 2012-04-03 09:37:07 EDT
Yet another bug, seems 3.2 -> 3.3 regression on mac80211, please open a different report for it. 

Regulatory domain is set based on timezone, do you have correct zone in /etc/sysconfig/clock ?
Comment 22 Joel Uckelman 2012-04-06 11:13:14 EDT
(In reply to comment #21)
> Yet another bug, seems 3.2 -> 3.3 regression on mac80211, please open a
> different report for it. 

Reported as Bug 810593.

> Regulatory domain is set based on timezone, do you have correct zone in
> /etc/sysconfig/clock ?

Yes, I have ZONE="Europe/Amsterdam", which I believe is correct.
Comment 23 Joel Uckelman 2012-04-06 11:14:33 EDT
(In reply to comment #22)
> (In reply to comment #21)
> > Yet another bug, seems 3.2 -> 3.3 regression on mac80211, please open a
> > different report for it. 
> 
> Reported as Bug 810593.

Ack, that should be Bug 810539.
Comment 24 Aaron Belisle 2012-04-06 16:08:55 EDT
I am in the United States and am having the same original issue. Wireless shows connected and ok and no errors. It just crashes Network Manager. Can't hit any ips including my router its connected to. I simply disable the wireless and reenable and this resolves the issue for a while. Really need to get a quick fix on this and it should be a sev 1 ticket as this is major bug that causes me to loose my virtual box connections. Below is my snippit from the messages log when this issue occurs. 

Apr  6 15:15:17 localhost kernel: [69335.967595] FIREWALL: IN=wlan0 OUT= MAC=01:00:5e:00:00:fb:e0:b9:ba:be:7f:c2:08:00 SRC=192.168.0.101 DST=224.0.0.251 LEN=77 TOS=0x00 PREC=0x00 TTL=255 ID=14165 PROTO=UDP SPT=5353 DPT=5353 LEN=57 
Apr  6 15:15:23 localhost kernel: [69341.920275] cfg80211: Calling CRDA to update world regulatory domain
Apr  6 15:15:24 localhost NetworkManager[1152]: <info> (wlan0): supplicant interface state: completed -> scanning
Apr  6 15:15:24 localhost NetworkManager[1152]: NetworkManager[1152]: <info> (wlan0): supplicant interface state: completed -> scanning
Apr  6 15:15:24 localhost kernel: [69342.378000] cfg80211: World regulatory domain updated:
Apr  6 15:15:24 localhost kernel: [69342.378008] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Apr  6 15:15:24 localhost kernel: [69342.378010] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr  6 15:15:24 localhost kernel: [69342.378012] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Apr  6 15:15:24 localhost kernel: [69342.378014] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Apr  6 15:15:24 localhost kernel: [69342.378016] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr  6 15:15:24 localhost kernel: [69342.378017] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr  6 15:15:24 localhost kernel: [69342.378226] cfg80211: Calling CRDA for country: US
Apr  6 15:15:24 localhost kernel: [69342.380898] cfg80211: Regulatory domain changed to country: US
Apr  6 15:15:24 localhost kernel: [69342.380900] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Apr  6 15:15:24 localhost kernel: [69342.380903] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Apr  6 15:15:24 localhost kernel: [69342.380905] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
Apr  6 15:15:24 localhost kernel: [69342.380907] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr  6 15:15:24 localhost kernel: [69342.380909] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr  6 15:15:24 localhost kernel: [69342.380910] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr  6 15:15:24 localhost kernel: [69342.380912] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
Apr  6 15:15:27 localhost NetworkManager[1152]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Apr  6 15:15:27 localhost NetworkManager[1152]: NetworkManager[1152]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Apr  6 15:15:27 localhost NetworkManager[1152]: <info> (wlan0): supplicant interface state: authenticating -> associating
Apr  6 15:15:27 localhost NetworkManager[1152]: NetworkManager[1152]: <info> (wlan0): supplicant interface state: authenticating -> associating
Apr  6 15:15:27 localhost NetworkManager[1152]: <info> (wlan0): supplicant interface state: associating -> associated
Apr  6 15:15:27 localhost NetworkManager[1152]: NetworkManager[1152]: <info> (wlan0): supplicant interface state: associating -> associated
Apr  6 15:15:27 localhost NetworkManager[1152]: <info> (wlan0): supplicant interface state: associated -> 4-way handshake
Apr  6 15:15:27 localhost NetworkManager[1152]: NetworkManager[1152]: <info> (wlan0): supplicant interface state: associated -> 4-way handshake
Apr  6 15:15:27 localhost NetworkManager[1152]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed
Apr  6 15:15:27 localhost NetworkManager[1152]: NetworkManager[1152]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed
Apr  6 15:15:38 localhost kernel: [69356.209415] FIREWALL: IN=wlan0 OUT= MAC=ff:ff:ff:ff:ff:ff:00:1f:5b:ee:e9:44:08:00 SRC=192.168.0.109 DST=255.255.255.255 LEN=147 TOS=0x00 PREC=0x00 TTL=64 ID=18287 PROTO=UDP SPT=17500 DPT=17500 LEN=127 
Apr  6 15:16:08 localhost kernel: [69386.159444] FIREWALL: IN=wlan0 OUT= MAC=ff:ff:ff:ff:ff:ff:00:1f:5b:ee:e9:44:08:00 SRC=192.168.0.109 DST=255.255.255.255 LEN=147 TOS=0x00 PREC=0x00 TTL=64 ID=5978 PROTO=UDP SPT=17500 DPT=17500 LEN=127 
Apr  6 15:16:15 localhost kernel: [69393.727131] iwlwifi 0000:03:00.0: Queue 12 stuck for 2000 ms.
Apr  6 15:16:15 localhost kernel: [69393.727138] iwlwifi 0000:03:00.0: Current SW read_ptr 213 write_ptr 2
Apr  6 15:16:15 localhost kernel: [69393.727193] iwlwifi 0000:03:00.0: Current HW read_ptr 213 write_ptr 2
Apr  6 15:16:15 localhost kernel: [69393.727197] iwlwifi 0000:03:00.0: On demand firmware reload
Apr  6 15:16:15 localhost kernel: [69393.727736] ieee80211 phy0: Hardware restart was requested
Apr  6 15:16:15 localhost kernel: [69393.727823] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
Apr  6 15:16:15 localhost kernel: [69393.728037] iwlwifi 0000:03:00.0: Radio type=0x1-0x3-0x1


As you see I just restart the wireless to get this to work. Please fix this bug!!
Comment 25 Erik Berg 2012-05-03 19:08:55 EDT
(In reply to comment #19)
> No new information is needed from You. I reported problem to Intel, I'm waiting
> for they fix.

Any news / updates from Intel? It's happening quite frequently on my Thinkpad x220. Linux 3.3.2-6.fc16.x86_64

03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 (rev 34)

[52337.348824] iwlwifi 0000:03:00.0: Queue 2 stuck for 10000 ms.
[52337.348828] iwlwifi 0000:03:00.0: Current SW read_ptr 23 write_ptr 28
[52337.348878] iwlwifi 0000:03:00.0: Current HW read_ptr 23 write_ptr 28
[52337.348880] iwlwifi 0000:03:00.0: On demand firmware reload
[52337.353655] iwlwifi 0000:03:00.0: Failing on timeout while stopping DMA channel 1 [0x07fd0001]
[52337.354063] ieee80211 phy0: Hardware restart was requested
[52337.354161] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[52337.354330] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
Comment 26 Stanislaw Gruszka 2012-05-07 03:03:17 EDT
I did't get any answer about that for long time. Finally I opened a bug report on their bugzilla to track the problem:
http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2359
They confirm there, that the bug is reproducible and they will debug it.
Comment 27 Kaare Fiedler Christiansen 2012-06-16 02:24:14 EDT
There is a proposed patch at http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2359
I tried applying it, but it doesn't match the sources in kernel-3.4.0-1.fc17.src.rpm and frankly the source in http://git.kernel.org/?p=linux/kernel/git/iwlwifi is sufficiently different to mine that I'm not sure how I would go ahead.
But if someone with more kernel patching knowledge than me could give the patch a spin, that would be great!
Comment 28 Bernard Ladenthin 2012-06-20 17:16:23 EDT
Hello,

i think i have the same problem? My WLAN crash very often. Or should i open a new bug? Or can i help?

tail -f /var/log/messages

Jun 20 22:51:40 polaris kernel: [31979.364597] iwlwifi 0000:03:00.0: Queue 11 stuck for 2000 ms.
Jun 20 22:51:40 polaris kernel: [31979.364606] iwlwifi 0000:03:00.0: Current SW read_ptr 19 write_ptr 22
Jun 20 22:51:40 polaris kernel: [31979.364675] iwlwifi 0000:03:00.0: Current HW read_ptr 19 write_ptr 22
Jun 20 22:51:40 polaris kernel: [31979.364680] iwlwifi 0000:03:00.0: On demand firmware reload
Jun 20 22:51:40 polaris kernel: [31979.365217] ieee80211 phy0: Hardware restart was requested
Jun 20 22:51:40 polaris kernel: [31979.365346] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
Jun 20 22:51:40 polaris kernel: [31979.365549] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
Jun 20 22:52:49 polaris kernel: [32048.370223] cfg80211: Calling CRDA to update world regulatory domain
Jun 20 22:52:49 polaris NetworkManager[1371]: <info> (wlan0): supplicant interface state: completed -> disconnected
Jun 20 22:52:49 polaris kernel: [32048.392046] cfg80211: World regulatory domain updated:
Jun 20 22:52:49 polaris kernel: [32048.392054] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Jun 20 22:52:49 polaris kernel: [32048.392061] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jun 20 22:52:49 polaris kernel: [32048.392067] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Jun 20 22:52:49 polaris kernel: [32048.392072] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Jun 20 22:52:49 polaris kernel: [32048.392077] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jun 20 22:52:49 polaris kernel: [32048.392082] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jun 20 22:52:49 polaris kernel: [32048.392105] cfg80211: Calling CRDA for country: DE
Jun 20 22:52:49 polaris kernel: [32048.402216] cfg80211: Regulatory domain changed to country: DE
Jun 20 22:52:49 polaris kernel: [32048.402225] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Jun 20 22:52:49 polaris kernel: [32048.402234] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
Jun 20 22:52:49 polaris kernel: [32048.402241] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Jun 20 22:52:49 polaris kernel: [32048.402248] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Jun 20 22:52:49 polaris kernel: [32048.402254] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
Jun 20 22:52:49 polaris NetworkManager[1371]: <info> (wlan0): supplicant interface state: disconnected -> scanning
Jun 20 22:52:51 polaris NetworkManager[1371]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Jun 20 22:52:52 polaris NetworkManager[1371]: <info> (wlan0): supplicant interface state: authenticating -> associating
Jun 20 22:52:52 polaris kernel: [32051.353761] cfg80211: Calling CRDA for country: DE
Jun 20 22:52:52 polaris kernel: [32051.356898] cfg80211: Regulatory domain changed to country: DE
Jun 20 22:52:52 polaris kernel: [32051.356901] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Jun 20 22:52:52 polaris kernel: [32051.356904] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
Jun 20 22:52:52 polaris kernel: [32051.356905] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Jun 20 22:52:52 polaris kernel: [32051.356907] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Jun 20 22:52:52 polaris kernel: [32051.356909] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
Jun 20 22:52:52 polaris NetworkManager[1371]: <info> (wlan0): supplicant interface state: associating -> 4-way handshake
Jun 20 22:52:52 polaris NetworkManager[1371]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed
Comment 29 Jim Perrin 2012-06-26 16:28:47 EDT
I also get this, though with fedora 17.
Comment 30 Dario Faggioli 2012-07-10 17:45:47 EDT
I seem to be experiencing right the same issue, although only on some networks, and wd_disable=1 and 11n_disable=1 seem to help getting rid of it...
Comment 31 Dave Jones 2012-10-23 11:37:02 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 32 Joel Uckelman 2012-11-08 16:10:26 EST
I haven't been having this problem with 3.6.3-1.fc17.x86_64, which is a bit newer than the kernel asked about above.
Comment 33 lord.quackstar 2012-11-26 08:39:27 EST
Reproducable in fresh install (fully updated) Fedora 17.

Uname:
Linux quackpad-fedora 3.6.7-4.fc17.x86_64 #1 SMP Tue Nov 20 19:40:01 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Card:
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 (rev 34)

Laptop:
Lenovo x220

Dmesg:
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316003] ------------[ cut here ]------------
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316038] WARNING: at drivers/net/wireless/iwlwifi/dvm/tx.c:1187 iwlagn_rx_reply_tx+0x9b6/0x9f0 [iwldvm]()
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316041] Hardware name: 4298CTO
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316044] Modules linked in: ip6table_filter ip6_tables nfsv4 auth_rpcgss nfs lockd sunrpc dns_resolver fscache twofish_generic twofish_avx_x86_64 twofish_x86_64_3way lrw glue_helper twofish_x86_64 twofish_common tun ip6t_REJECT rfcomm nf_conntrack_ipv6 nf_defrag_ipv6 bnep nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack fuse snd_hda_codec_hdmi snd_hda_codec_conexant arc4 iwldvm coretemp snd_hda_intel snd_hda_codec snd_hwdep kvm_intel snd_seq snd_seq_device snd_pcm mac80211 btusb kvm bluetooth iTCO_wdt iTCO_vendor_support lpc_ich mei iwlwifi thinkpad_acpi snd_page_alloc cfg80211 snd_timer mfd_core microcode e1000e i2c_i801 snd rfkill soundcore uinput xts gf128mul dm_crypt crc32c_intel ghash_clmulni_intel usb_storage sdhci_pci sdhci mmc_core wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: ip6_tables]
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316117] Pid: 0, comm: swapper/0 Tainted: G        W    3.6.7-4.fc17.x86_64 #1
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316118] Call Trace:
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316120]  <IRQ>  [<ffffffff8105c8ef>] warn_slowpath_common+0x7f/0xc0
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316125]  [<ffffffff8105c94a>] warn_slowpath_null+0x1a/0x20
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316129]  [<ffffffffa0407396>] iwlagn_rx_reply_tx+0x9b6/0x9f0 [iwldvm]
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316132]  [<ffffffff81065470>] ? __do_softirq+0x80/0x210
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316136]  [<ffffffffa0411163>] iwl_rx_dispatch+0xa3/0x110 [iwldvm]
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316141]  [<ffffffffa0242ec8>] iwl_irq_tasklet+0x798/0xb10 [iwlwifi]
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316143]  [<ffffffff81065a53>] tasklet_action+0x63/0xd0
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316145]  [<ffffffff810654c0>] __do_softirq+0xd0/0x210
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316148]  [<ffffffff8101b933>] ? native_sched_clock+0x13/0x80
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316150]  [<ffffffff81627efc>] call_softirq+0x1c/0x30
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316152]  [<ffffffff81016205>] do_softirq+0x75/0xb0
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316154]  [<ffffffff810658b5>] irq_exit+0xb5/0xc0
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316156]  [<ffffffff81628753>] do_IRQ+0x63/0xe0
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316158]  [<ffffffff8161f02a>] common_interrupt+0x6a/0x6a
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316158]  <EOI>  [<ffffffff810ac2d2>] ? ktime_get+0x52/0xe0
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316163]  [<ffffffff8133876d>] ? intel_idle+0xed/0x150
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316165]  [<ffffffff8133874e>] ? intel_idle+0xce/0x150
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316167]  [<ffffffff814cb919>] cpuidle_enter+0x19/0x20
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316168]  [<ffffffff814cbfa9>] cpuidle_idle_call+0xa9/0x250
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316170]  [<ffffffff8101d52f>] cpu_idle+0xaf/0x120
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316172]  [<ffffffff815fb76e>] rest_init+0x72/0x74
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316174]  [<ffffffff81cfbc3a>] start_kernel+0x3c7/0x3d4
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316176]  [<ffffffff81cfb672>] ? repair_env_string+0x5e/0x5e
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316177]  [<ffffffff81cfb356>] x86_64_start_reservations+0x131/0x135
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316179]  [<ffffffff81cfb45a>] x86_64_start_kernel+0x100/0x10f
Nov 26 08:14:44 quackpad-fedora kernel: [143100.316180] ---[ end trace 15f82503f3798580 ]---
Nov 26 08:14:44 quackpad-fedora kernel: [143100.324471] wlan0: authenticate with 5c:50:15:d8:32:6e
Nov 26 08:14:44 quackpad-fedora kernel: [143100.343737] wlan0: send auth to 5c:50:15:d8:32:6e (try 1/3)
Nov 26 08:14:44 quackpad-fedora NetworkManager[767]: <info> (wlan0): supplicant interface state: completed -> authenticating
Nov 26 08:14:44 quackpad-fedora kernel: [143100.544094] wlan0: send auth to 5c:50:15:d8:32:6e (try 2/3)
Nov 26 08:14:44 quackpad-fedora kernel: [143100.544766] wlan0: authenticated
Nov 26 08:14:44 quackpad-fedora kernel: [143100.545718] wlan0: waiting for beacon from 5c:50:15:d8:32:6e
Nov 26 08:14:44 quackpad-fedora NetworkManager[767]: <info> (wlan0): supplicant interface state: authenticating -> associating
Nov 26 08:14:44 quackpad-fedora kernel: [143100.585047] wlan0: associate with 5c:50:15:d8:32:6e (try 1/3)
Nov 26 08:14:44 quackpad-fedora kernel: [143100.588232] wlan0: RX AssocResp from 5c:50:15:d8:32:6e (capab=0x111 status=0 aid=1)
Nov 26 08:14:44 quackpad-fedora kernel: [143100.591155] wlan0: associated
Nov 26 08:14:44 quackpad-fedora NetworkManager[767]: <info> (wlan0): supplicant interface state: associating -> associated
Nov 26 08:14:44 quackpad-fedora NetworkManager[767]: <info> (wlan0): supplicant interface state: associated -> completed
[abrtd opps logging] 
Nov 26 08:14:48 quackpad-fedora NetworkManager[767]: <info> (wlan0): roamed from BSSID 58:35:D9:64:91:11 (ulsecure) to 5C:50:15:D8:32:6E (ulsecure)
Nov 26 08:15:21 quackpad-fedora kernel: [143137.376709] iwlwifi 0000:03:00.0: fail to flush all tx fifo queues
Comment 34 David Strauss 2013-02-06 17:49:01 EST
I'm also seeing this on a ThinkPad X220 with Fedora 17 and the following kernel:
Linux athena 3.7.6-102.fc17.x86_64 #1 SMP Mon Feb 4 17:40:25 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 35 David Strauss 2013-02-06 17:52:58 EST
I don't see quite the same log, though:
[nothing for 15 minutes here]
Feb  6 14:33:24 athena kernel: [63338.437970] iwlwifi 0000:03:00.0: fail to flush all tx fifo queues
Feb  6 14:33:26 athena kernel: [63340.437363] iwlwifi 0000:03:00.0: fail to flush all tx fifo queues
Feb  6 14:33:26 athena kernel: [63340.484130] cfg80211: Calling CRDA to update world regulatory domain
Feb  6 14:33:26 athena NetworkManager[1114]: <info> (wlan0): supplicant interface state: completed -> disconnected
Feb  6 14:33:26 athena kernel: [63340.496488] cfg80211: World regulatory domain updated:
Feb  6 14:33:26 athena kernel: [63340.496496] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Feb  6 14:33:26 athena kernel: [63340.496501] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb  6 14:33:26 athena kernel: [63340.496506] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Feb  6 14:33:26 athena kernel: [63340.496509] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Feb  6 14:33:26 athena kernel: [63340.496512] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb  6 14:33:26 athena kernel: [63340.496515] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb  6 14:33:26 athena kernel: [63340.496550] cfg80211: Calling CRDA for country: US
Feb  6 14:33:26 athena kernel: [63340.501056] cfg80211: Regulatory domain changed to country: US
Feb  6 14:33:26 athena kernel: [63340.501064] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Feb  6 14:33:26 athena kernel: [63340.501069] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Feb  6 14:33:26 athena kernel: [63340.501073] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
Feb  6 14:33:26 athena kernel: [63340.501077] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb  6 14:33:26 athena kernel: [63340.501080] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb  6 14:33:26 athena kernel: [63340.501083] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb  6 14:33:26 athena kernel: [63340.501086] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
Feb  6 14:33:26 athena kernel: [63340.501090] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
Feb  6 14:33:27 athena NetworkManager[1114]: <info> (wlan0): supplicant interface state: disconnected -> scanning
Feb  6 14:33:27 athena kernel: [63341.025466] wlan0: authenticate with 5c:50:15:23:ac:50
Feb  6 14:33:27 athena kernel: [63341.060673] wlan0: send auth to 5c:50:15:23:ac:50 (try 1/3)
Feb  6 14:33:27 athena NetworkManager[1114]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Feb  6 14:33:27 athena kernel: [63341.261198] wlan0: send auth to 5c:50:15:23:ac:50 (try 2/3)
Feb  6 14:33:27 athena kernel: [63341.261932] wlan0: authenticated
Feb  6 14:33:27 athena kernel: [63341.263195] wlan0: associate with 5c:50:15:23:ac:50 (try 1/3)
Feb  6 14:33:27 athena kernel: [63341.264602] wlan0: RX AssocResp from 5c:50:15:23:ac:50 (capab=0x111 status=0 aid=8)
Feb  6 14:33:27 athena NetworkManager[1114]: <info> (wlan0): supplicant interface state: authenticating -> associating
Feb  6 14:33:27 athena kernel: [63341.269683] wlan0: associated
Feb  6 14:33:27 athena NetworkManager[1114]: <info> (wlan0): supplicant interface state: associating -> completed
Feb  6 14:33:28 athena NetworkManager[1114]: <info> (wlan0): roamed from BSSID 5C:50:15:4D:6D:E0 (Pantheon) to 5C:50:15:23:AC:50 (Pantheon)
Feb  6 14:34:04 athena kernel: [63378.642708] iwlwifi 0000:03:00.0: fail to flush all tx fifo queues
Comment 36 Stanislaw Gruszka 2013-02-07 07:45:32 EST
Please open a new bug report for that issue, describe the problem and attach full dmesg there.