This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 805348

Summary: [abrt] kernel: WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x257/0x260()
Product: [Fedora] Fedora Reporter: Christopher Atherton <the8lack8ox>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:43b7be7cb5e493d9193d1d70fee2ecdf12b406a5
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-21 10:00:59 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Christopher Atherton 2012-03-20 20:26:03 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-2.fc16.x86_64 root=UUID=75c6b695-f13e-46b8-a0b6-c4448c8ab02e ro KEYTABLE=dvorak rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
comment:        Problem occurs several times per day whenever IOMMU turned is on in BIOS.  Network adapter becomes unusable.  Can rmmod r8169 and modprobe it again and the adapter comes back to life.
kernel:         3.3.0-2.fc16.x86_64
reason:         WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x257/0x260()
time:           Tue 20 Mar 2012 12:38:27 PM EDT

backtrace:
:WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x257/0x260()
:Hardware name: GA-970A-UD3
:NETDEV WATCHDOG: p9p1 (r8169): transmit queue 0 timed out
:Modules linked in: usb_storage ppdev parport_pc lp parport fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc lockd be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi it87 hwmon_vid ip6t_REJECT ip6t_ipv6header nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_filter nf_conntrack_ipv4 nf_defrag_ipv4 ip6_tables xt_state nf_conntrack rc_hauppauge lgdt3305 joydev uvcvideo snd_usb_audio videobuf2_core snd_usbmidi_lib videobuf2_vmalloc videobuf2_memops binfmt_misc cx25840 snd_hda_codec_hdmi ir_lirc_codec lirc_dev ir_mce_kbd_decoder ir_sanyo_decoder ir_sony_decoder snd_hda_codec_realtek ir_jvc_decoder ir_rc6_decoder ir_rc5_decoder edac_core cx23885 serio_raw edac_mce_amd ir_nec_decoder snd_hda_intel snd_oxygen fam15h_power rc_core microcode snd_oxy
:gen_lib k10temp snd_hda_codec videobuf_dma_sg altera_stapl snd_mpu401_uart sp5100_tco snd_rawmidi cx2341x tda18271 i2c_piix4 snd_hwdep snd_seq videobuf_dvb snd_seq_device videobuf_core v4l2_common videodev snd_pcm media v4l2_compat_ioctl32 altera_ci snd_timer dvb_core snd btcx_risc soundcore r8169 tveeprom snd_page_alloc mii vhost_net macvtap macvlan tun virtio_net kvm_amd kvm uinput sunrpc btrfs zlib_deflate libcrc32c firewire_ohci firewire_core crc_itu_t mvsas libsas scsi_transport_sas wmi radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 0, comm: swapper/2 Not tainted 3.3.0-2.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff81057b1f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81057c16>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff810727c0>] ? __queue_work+0xe0/0x3e0
: [<ffffffff810939a1>] ? trigger_load_balance+0x61/0x2d0
: [<ffffffff81503ab7>] dev_watchdog+0x257/0x260
: [<ffffffff8106716c>] run_timer_softirq+0x12c/0x3b0
: [<ffffffff8101bc59>] ? sched_clock+0x9/0x10
: [<ffffffff81503860>] ? qdisc_reset+0x50/0x50
: [<ffffffff8105f148>] __do_softirq+0xb8/0x230
: [<ffffffff8101b6c9>] ? read_tsc+0x9/0x20
: [<ffffffff8101bc59>] ? sched_clock+0x9/0x10
: [<ffffffff8108dad5>] ? sched_clock_local+0x25/0x90
: [<ffffffff815fd51c>] call_softirq+0x1c/0x30
: [<ffffffff81016455>] do_softirq+0x65/0xa0
: [<ffffffff8105f55e>] irq_exit+0x9e/0xc0
: [<ffffffff815fde6e>] smp_apic_timer_interrupt+0x6e/0x99
: [<ffffffff815fcb1e>] apic_timer_interrupt+0x6e/0x80
: <EOI>  [<ffffffff81343ece>] ? arch_local_irq_enable+0x8/0xd
: [<ffffffff8108de1a>] ? sched_clock_idle_wakeup_event+0x1a/0x20
: [<ffffffff81344c0d>] acpi_idle_enter_simple+0xd3/0x115
: [<ffffffff814a4091>] cpuidle_idle_call+0xc1/0x280
: [<ffffffff8101322f>] cpu_idle+0xcf/0x120
: [<ffffffff815e3b2a>] start_secondary+0x282/0x284

smolt_data:
:
:
:General
:=================================
:UUID: 2ab15e59-dc88-4561-b3c8-7c62647abd79
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 6242.07
:CPU Vendor: AuthenticAMD
:CPU Model: AMD FX(tm)-8120 Eight-Core Processor
:CPU Stepping: 2
:CPU Family: 21
:CPU Model Num: 1
:Number of CPUs: 8
:CPU Speed: 3100
:System Memory: 15968
:System Swap: 0
:Vendor: Gigabyte Technology Co., Ltd.
:System: GA-970A-UD3 
:Form factor: Desktop
:Kernel: 3.3.0-2.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17297:5208:45058) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
:(4098:23069:4098:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (external gfx1 port A)
:(4098:43608:5208:43608) pci, snd_hda_intel, MULTIMEDIA, Juniper HDMI Audio [Radeon HD 5700 Series]
:(5110:34696:29316:38785) pci, snd_oxygen, MULTIMEDIA_AUDIO, CLARO halo
:(4098:23075:4098:23075) pci, None, BASE, N/A
:(4098:23060:4098:23060) pci, None, HOST/PCI, RD890 PCI to PCI bridge (external gfx0 port B)
:(4358:12356:5208:4096) pci, firewire_ohci, FIREWIRE, GA-7VT600-1394 Motherboard
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(4130:5637:0:0) pci, None, HOST/PCI, Family 15h Processor Function 5
:(4130:5636:0:0) pci, fam15h_power, HOST/PCI, Family 15h Processor Function 4
:(4130:5633:0:0) pci, None, HOST/PCI, Family 15h Processor Function 1
:(4130:5632:0:0) pci, None, HOST/PCI, Family 15h Processor Function 0
:(4130:5635:0:0) pci, k10temp, HOST/PCI, Family 15h Processor Function 3
:(4130:5634:0:0) pci, None, HOST/PCI, Family 15h Processor Function 2
:(4098:17302:5208:20484) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(7045:4129:7045:4129) pci, mvsas, SCSI, N/A
:(5361:34944:112:8721) pci, cx23885, MULTIMEDIA_VIDEO, CX23887/8 PCIe Broadcast Audio and Video Decoder with 3D Comb
:(4098:17312:4098:0) pci, pcieport, PCI/PCI, SB700/SB800 PCI to PCI bridge (PCIE port 0)
:(4098:23062:4098:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port B)
:(4098:17285:0:0) pci, None, SERIAL, SBx00 SMBus Controller
:(4098:17309:4098:17309) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:5208:40962) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17305:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:17302:5208:20484) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:26810:5208:8716) pci, radeon, VIDEO, Juniper XT [AMD Radeon HD 6000 Series]
:(4098:17303:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17302:5208:20484) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(7023:28707:5208:20487) pci, xhci_hcd, USB, N/A
:(4098:23068:4098:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port H)
:(7023:28707:5208:20487) pci, xhci_hcd, USB, N/A
:(4098:23064:4098:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port D)
:(4098:23065:4098:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port E)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sdf1 / btrfs 4096 4096 29306880 27140210 25817604 0 0 0
:/dev/sdc2 /boot btrfs 4096 4096 384000 364974 205298 0 0 0
:/dev/sda3 /home btrfs 4096 4096 549044736 449146090 427363494 0 0 0
:/dev/sdd1 WITHHELD btrfs 4096 4096 488378385 395092087 375686840 0 0 0
:
Comment 1 Josh Boyer 2012-03-21 10:00:59 EDT

*** This bug has been marked as a duplicate of bug 715137 ***