Bug 806539

Summary: Telepathy Authentication Handler pops up in sugar-desktop asks Password for KDE Wallet then for Jabber Password which is direct conflict with jabber.sugarlabs.org in sugar. kills working jabber connection
Product: [Fedora] Fedora Reporter: satellitgo
Component: ksecretsAssignee: Ngo Than <than>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 17CC: awilliam, jreznik, kevin, ltinkl, rdieter, rnovacek, satellitgo, than
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard: RejectedNTH
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-06 16:44:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 484945    
Bug Blocks:    

Description satellitgo 2012-03-24 14:44:01 UTC
Description of problem:
# LXDE; Gnome; KDE; sugar; Xfce installed; KDE DaemonSecretService keeps popping up, does not save password
# ↑ Telepathy Authentication Handler pops up in sugar-desktop asks Password for KDE Wallet then for Jabber Password which is direct conflict with jabber.sugarlabs.org in sugar. when cancelled kills working jabber connection

Version-Release number of selected component (if applicable):
Fedora-17-Beta-x86_64-netinst.iso  LXDE; Gnome; KDE; sugar; Xfce installed

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
 KDE DaemonSecretService not activate in sugar-desktop


Additional info:

Comment 1 satellitgo 2012-03-24 15:47:04 UTC
(In reply to comment #0)
> Description of problem:
> # LXDE; Gnome; KDE; sugar; Xfce installed; KDE DaemonSecretService keeps
> popping up, does not save password
> # ↑ Telepathy Authentication Handler pops up in sugar-desktop asks Password for
> KDE Wallet then for Jabber Password which is direct conflict with
> jabber.sugarlabs.org in sugar. when cancelled kills working jabber connection
> 
> Version-Release number of selected component (if applicable):
> Fedora-17-Beta-x86_64-netinst.iso  LXDE; Gnome; KDE; sugar; Xfce installed
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
>  KDE DaemonSecretService not activate in sugar-desktop
> 
> 
> Additional info:
"yum remove ksecrets"
 fixes this problem

Comment 2 Rex Dieter 2012-03-24 16:09:10 UTC
$ grep org.freedesktop.secrets *
org.freedesktop.secrets.service:Name=org.freedesktop.secrets
org.kde.ksecretsserviced.service:Name=org.freedesktop.secrets

[rdieter1@localhost services]$ rpm -q -f org.freedesktop.secrets.service org.kde.ksecretsserviced.service 
gnome-keyring-3.3.92-1.fc17.x86_64
ksecrets-4.8.1-2.fc17.x86_64

My guess atm is that there's a race in dbus on who gets to provide org.freedesktop.secrets dbus service first.

So, seems to be a variant of an old dbus bug #484945

Comment 3 Adam Williamson 2012-03-24 16:12:46 UTC
proposing as beta NTH, Sugar is a non-supported desktop but v. sensitive to NTH as it's often used as a live image.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Kevin Kofler 2012-03-24 18:22:22 UTC
But the Sugar live image isn't shipping ksecrets in the first place.

Comment 5 Rex Dieter 2012-03-24 20:04:14 UTC
True, the reporter's test was done as a netinstall of 5 desktops:  LXDE; Gnome; KDE; sugar; Xfce

Comment 6 Adam Williamson 2012-03-30 19:28:47 UTC
Discussed at 2012-03-30 NTH review meeting. Rejected as NTH because the reproducer is unusual (install both Sugar and KDE) and the fix is not straightforward and affects a core component (dbus).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Kevin Kofler 2012-04-02 15:21:04 UTC
FYI, we changed comps to no longer install ksecrets by default. It does not currently work as a drop-in replacement for gnome-keyring as intended (as evidenced by this bug among other feedback), nor is support for it in the KWallet libraries ready yet (it exists as a patch to kdelibs, but the kdelibs maintainers wanted it as a plugin instead and refused the patch, the plugin is not ready).

Comment 8 satellitgo 2012-04-12 14:09:26 UTC
rc4 netinstall i686: configure now:: ksecrets no longer selected in KDE install

Comment 9 Rex Dieter 2012-10-06 16:44:11 UTC
Closing CANTFIX (since it's essentially a problem with dbus implementation at this point).

Can consider reopen when/if the situation changes