Bug 806897

Summary: IPMI: return code can be invalid
Product: Red Hat Enterprise Linux 6 Reporter: Marek Grac <mgrac>
Component: fence-agentsAssignee: Marek Grac <mgrac>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: high Docs Contact:
Priority: high    
Version: 6.4CC: cluster-maint, djansa, jsvarova, mjuricek, sbradley
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: fence-agents-3.1.5-16.el6 Doc Type: Bug Fix
Doc Text:
* Prior to this update, the fence agent for IPMI (Intelligent Platform Management Interface) could return an invalid return code when the "-M cycle" option was used. This invalid return code could cause invalid interpretation of success of a fence action, eventually causing the cluster to become unresponsive. This bug has been fixed and only predefined return codes are now returned in the described scenario.
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-20 14:40:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1012574    

Description Marek Grac 2012-03-26 12:58:44 UTC
IPMI fence agent can return invalid return code when used with method "cycle"

[marx@nox ipmilan]$ ./fence_ipmilan -a ibm-x3250m3-01-imm -l USER -p PASS -o reboot -M cycle; echo $?

Rebooting machine @ IPMI:ibm-x3250m3-01-imm.mpc.lab.eng.bos.redhat.com...Done
255

Comment 8 errata-xmlrpc 2012-06-20 14:40:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0943.html