This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 807879

Summary: When running inside a KVM, libvirt sets up a virbr0 with IP of 192.168.122.1 (same as virbr0 on the host), screwing up the KVM's networking
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 17CC: berrange, clalancette, crobinso, dougsland, itamar, jforbes, jhrozek, jyang, laine, libvirt-maint, notting, robatino, rstrode, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-29 00:37:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752649    

Description Adam Williamson 2012-03-28 22:24:44 EDT
I'm no networking expert, so there may be errors in the description here, but I hope the gist comes through.

If you just use Fedora's default virt stack to set up a VM, in the dumb pointy-clicky virt-manager way, you'll get a 'virbr0' interface on the host machine with an IP of 192.168.122.1. VMs will have 'eth0' interfaces with IP address in the 192.168.122.[2-255] range (actually probably a narrower higher range, but you get the idea). Effectively libvirt is handling NAT for the VMs behind it. The VMs get their DNS server set to 192.168.122.1, and everything works, and I don't have to think too hard about why.

If I boot a VM using a live image which has Boxes included (and probably if you just 'yum install boxes' into a VM and reboot), the *VM itself* has a virbr0 interface with an IP of 192.168.122.1. The VM can ping out to numeric IP addresses, it seems - ping 8.8.8.8 works - but it can't resolve any hostnames, presumably because the guest virbr0 is conflicting with the host virbr0 and messing things up.

I have no idea how this should be fixed, I just know it should, because the user-visible impact is that 'networking is horked in KVMs with Boxes installed'.

This may be a libvirt issue rather than a Boxes one, I guess. I'm not sure. CCing the Dans Berrange and Veillard.

If we wanted to have Boxes in the F17 release, this would be a release blocker.
Comment 1 Adam Williamson 2012-03-28 22:27:54 EDT
wrong Boxes. let's just assign this to libvirt, anyhow.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Adam Williamson 2012-03-29 00:05:00 EDT
Well, fuck.

Bill added gnome-boxes to comps a day or so ago:

http://git.fedorahosted.org/git/?p=comps.git;a=commit;h=5674acffc704dadc9543677c2b3e260d33185e1c

so this is now affecting Beta RC2 :(

Network is broken OOTB with Beta RC2 Desktop booted in a KVM. Proposing as Beta blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2012-03-29 00:37:26 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 802475 ***