Bug 808564

Summary: TypeError: bad operand type for unary -: 'str'
Product: [Fedora] Fedora Reporter: Paul Wouters <pwouters>
Component: yum-prestoAssignee: Jonathan Dieter <jdieter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: james.antill, jdieter, tla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-30 18:08:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Wouters 2012-03-30 18:03:20 UTC
Description of problem:
running a yum install for some packages used yum-presto and died


Version-Release number of selected component (if applicable):


How reproducible:
(i worked around it by doing rpm e yum-presto to upgrade. so unsure

[root@thinkpad linux-3.3.0-8.fc17.x86_64]# yum install qt3-devel
libXi-devel
Loaded plugins: langpacks, presto, refresh-packagekit
fedora/metalink                                          | 9.7 kB
00:00     
fedora                                                   | 4.2 kB
00:00     
fedora/primary_db                                        |  14 MB
00:10     
fedora/group_gz                                          | 426 kB
00:00     
rpmfusion-free-rawhide                                   | 1.2 kB
00:00     
rpmfusion-free-rawhide/primary                           | 172 kB
00:00     
rpmfusion-nonfree                                        | 1.2 kB
00:00     
rpmfusion-nonfree/primary                                |  66 kB
00:00     
rpmfusion-nonfree-updates                                | 1.2 kB
00:00     
rpmfusion-nonfree-updates/primary                        |  207 B
00:00     
rpmfusion-nonfree-updates-testing                        | 3.3 kB
00:00     
rpmfusion-nonfree-updates-testing/primary_db             |  49 kB
00:00     
rpmfusion-nonfree-updates-testing/group_gz               | 1.0 kB
00:00     
updates/metalink                                         |  19 kB
00:00     
updates                                                  | 2.6 kB
00:00     
updates/primary_db                                       | 1.2 kB
00:00     
updates-testing/metalink                                 |  15 kB
00:00     
updates-testing                                          | 4.5 kB
00:00     
updates-testing/primary_db                               | 4.5 MB
00:04     
updates-testing/group_gz                                 | 426 kB
00:00     
rpmfusion-free-rawhide
429/429
rpmfusion-nonfree
194/194
Setting up Install Process
Package libXi-devel-1.5.99.2-4.20111222gitae0187c87.fc17.x86_64 already
installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package qt3-devel.x86_64 0:3.3.8b-41.fc17 will be installed
--> Processing Dependency: qt3 = 3.3.8b-41.fc17 for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: mesa-libGLU-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: mesa-libGL-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: libpng-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: libmng-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: libXrender-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: libXrandr-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: libXinerama-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: libXft-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: libXcursor-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: freetype-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: fontconfig-devel for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: libqui.so.1()(64bit) for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Processing Dependency: libqt-mt.so.3()(64bit) for package:
qt3-devel-3.3.8b-41.fc17.x86_64
--> Running transaction check
---> Package fontconfig-devel.x86_64 0:2.8.0-6.fc17 will be installed
---> Package freetype-devel.x86_64 0:2.4.8-2.fc17 will be installed
---> Package libXcursor-devel.x86_64 0:1.1.13-1.fc17 will be installed
--> Processing Dependency: pkgconfig(xfixes) for package:
libXcursor-devel-1.1.13-1.fc17.x86_64
---> Package libXft-devel.x86_64 0:2.3.0-2.fc17 will be installed
---> Package libXinerama-devel.x86_64 0:1.1.2-1.fc17 will be installed
---> Package libXrandr-devel.x86_64 0:1.3.1-3.fc17 will be installed
---> Package libXrender-devel.x86_64 0:0.9.7-1.fc17 will be installed
---> Package libmng-devel.x86_64 0:1.0.10-6.fc17 will be installed
---> Package libpng-devel.x86_64 2:1.5.9-1.fc17 will be installed
---> Package mesa-libGL-devel.x86_64 0:8.0.1-9.fc17 will be installed
--> Processing Dependency: mesa-libGL = 8.0.1-9.fc17 for package:
mesa-libGL-devel-8.0.1-9.fc17.x86_64
--> Processing Dependency: pkgconfig(libdrm) >= 2.4.24 for package:
mesa-libGL-devel-8.0.1-9.fc17.x86_64
--> Processing Dependency: pkgconfig(xxf86vm) for package:
mesa-libGL-devel-8.0.1-9.fc17.x86_64
--> Processing Dependency: pkgconfig(xdamage) for package:
mesa-libGL-devel-8.0.1-9.fc17.x86_64
---> Package mesa-libGLU-devel.x86_64 0:8.0.1-9.fc17 will be installed
--> Processing Dependency: mesa-libGLU = 8.0.1-9.fc17 for package:
mesa-libGLU-devel-8.0.1-9.fc17.x86_64
---> Package qt3.x86_64 0:3.3.8b-41.fc17 will be installed
--> Running transaction check
---> Package libXdamage-devel.x86_64 0:1.1.3-3.fc17 will be installed
---> Package libXfixes-devel.x86_64 0:5.0-2.fc17 will be installed
---> Package libXxf86vm-devel.x86_64 0:1.1.2-1.fc17 will be installed
---> Package libdrm-devel.x86_64 0:2.4.32-1.fc17 will be installed
---> Package mesa-libGL.x86_64 0:8.0.1-7.fc17 will be updated
---> Package mesa-libGL.x86_64 0:8.0.1-9.fc17 will be an update
---> Package mesa-libGLU.x86_64 0:8.0.1-7.fc17 will be updated
---> Package mesa-libGLU.x86_64 0:8.0.1-9.fc17 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch       Version             Repository
Size
================================================================================
Installing:
 qt3-devel             x86_64     3.3.8b-41.fc17      fedora
8.6 M
Installing for dependencies:
 fontconfig-devel      x86_64     2.8.0-6.fc17        updates-testing
199 k
 freetype-devel        x86_64     2.4.8-2.fc17        fedora
345 k
 libXcursor-devel      x86_64     1.1.13-1.fc17       fedora
22 k
 libXdamage-devel      x86_64     1.1.3-3.fc17        fedora
9.1 k
 libXfixes-devel       x86_64     5.0-2.fc17          fedora
12 k
 libXft-devel          x86_64     2.3.0-2.fc17        fedora
18 k
 libXinerama-devel     x86_64     1.1.2-1.fc17        fedora
13 k
 libXrandr-devel       x86_64     1.3.1-3.fc17        fedora
19 k
 libXrender-devel      x86_64     0.9.7-1.fc17        fedora
16 k
 libXxf86vm-devel      x86_64     1.1.2-1.fc17        fedora
17 k
 libdrm-devel          x86_64     2.4.32-1.fc17       updates-testing
73 k
 libmng-devel          x86_64     1.0.10-6.fc17       fedora
85 k
 libpng-devel          x86_64     2:1.5.9-1.fc17      fedora
120 k
 mesa-libGL-devel      x86_64     8.0.1-9.fc17        fedora
472 k
 mesa-libGLU-devel     x86_64     8.0.1-9.fc17        fedora
90 k
 qt3                   x86_64     3.3.8b-41.fc17      fedora
3.4 M
Updating for dependencies:
 mesa-libGL            x86_64     8.0.1-9.fc17        fedora
147 k
 mesa-libGLU           x86_64     8.0.1-9.fc17        fedora
179 k

Transaction Summary
================================================================================
Install  1 Package  (+16 Dependent packages)
Upgrade             (  2 Dependent packages)

Total download size: 14 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
fedora/prestodelta                                       |   78 B
00:00     
Processing delta metadata
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 321, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 229, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 547, in doTransaction
    problems = self.downloadPkgs(downloadpkgs,
callback_total=self.download_callback_total_cb) 
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2147, in
downloadPkgs
    self.plugins.run('predownload', pkglist=pkglist)
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 187, in
run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/presto.py", line 633, in predownload_hook
    (problems, more) = downloadPkgs(conduit, pinfo, download_pkgs)
  File "/usr/lib/yum-plugins/presto.py", line 321, in downloadPkgs
    delta = getDelta(po, presto, conduit, conf_mp)
  File "/usr/lib/yum-plugins/presto.py", line 198, in getDelta
    conduit.info(5, -("Could not find delta rpm for package %s.%s.")
TypeError: bad operand type for unary -: 'str'

Comment 1 Jonathan Dieter 2012-03-30 18:08:49 UTC

*** This bug has been marked as a duplicate of bug 808130 ***