Bug 808869

Summary: upgrade various gnome-shell-extension to gnome 3.4
Product: [Fedora] Fedora Reporter: collura
Component: gnome-shell-extensionsAssignee: Rahul Sundaram <metherid>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 17CC: collura, kalevlember, metherid, michel, pikachu.2014
Target Milestone: ---   
Target Release: ---   
Hardware: noarch   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-01 07:36:13 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description collura 2012-04-01 07:28:23 EDT
Description of problem:

  many of the gnome-shell-extensions have been upgraded to gnome 3.4
  but there are some that arent ready so here is a list to track
  (filed seperately since probably be done piecemeal)

Version-Release number of selected component (if applicable):

  https://bugzilla.redhat.com/show_bug.cgi?id=808826
  gnome-shell-extension-calc-0-0.3.git2fca097.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808827
  gnome-shell-extension-cpu-temperature-0-0.4.gite1777e6.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808830
  gnome-shell-extension-icon-manager-0-0.5.gitc34779c.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808831
  gnome-shell-extension-mediaplayers-0-0.3.git1225d49.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808832
  gnome-shell-extension-noim-1.0-2.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808834
  gnome-shell-extension-noripple-1.0-2.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808835
  gnome-shell-extension-pidgin-0-0.6.git80d4ea4b59.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808838
  gnome-shell-extension-pomodoro-0-0.3.git13030cd.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808840
  gnome-shell-extension-presentation-mode-0-0.3.gitc3ce6b2.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808842
  gnome-shell-extension-remove-accessibility-icon-20111008-2.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808844
  gnome-shell-extension-remove-bluetooth-icon-0.2.1-2.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808857
  gnome-shell-extension-remove-volume-icon-0.3.1-2.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808862
  gnome-shell-extension-righthotcorner-1.0-2.fc17.noarch

  https://bugzilla.redhat.com/show_bug.cgi?id=808865
  gnome-shell-extension-gpaste-2.2.1-1.fc17.noarch

How reproducible:

  always

Steps to Reproduce:
1. install extension
2.
3.
  
Actual results:

  extension doesnt function, 
  gnome-tweek-tool grays out toggle switch and 
    lists as'Extension does not support shell version' 


Expected results:

  extension functions,
  gnome-tweak-tool can enable/disable extension and has no error


Additional info:
Comment 1 Mohamed El Morabity 2012-04-01 07:36:13 EDT
All these extensions have nothing to do with the "official" GNOME Shell extensions.
Comment 2 Kalev Lember 2012-04-01 07:42:04 EDT
Hi collura,

I am not involved in gnome-shell-extensions packaging at all and don't really use any of them, but I wanted to say that what you are doing is great initiative. Checking all the extensions for gnome-shell 3.4 compatibility and filing individual bugs like you did is exactly what's needed to make sure these stay working.

Thanks!