Bug 809018

Summary: impress is quite slow loading / showing a presentation
Product: [Fedora] Fedora Reporter: Hans de Goede <hdegoede>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: caolanm, dtardon, erack, ltinkl, mstahl, sbergman
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libreoffice-3.5.2.1-6.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-11 05:37:11 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hans de Goede 2012-04-02 05:03:06 EDT
Loading a presentation which I've used / given before on my Core 2 duo laptop (yeah the machine is getting a bit old) which I've recently updated to Fedora 17 (and is fully up2date as of today).  I notice that loading the presentation takes a significant time, I can actually see some parts of the slides being drawn bit by bit (images first show up as a broken image like icon, then later get loaded).

The images in question are the Fedora logo from one of the standard Fedora presentation templates:
http://fedoraproject.org/w/uploads/8/85/Fedora-designninja-presentation-submission.otp

So this is not an image heavy presentation (at leas I don't think so). This presentation used to load a lot quicker in F-16 and older.
Comment 1 Hans de Goede 2012-04-02 05:09:40 EDT
p.s. libreoffice version:
libreoffice-core-3.5.2.1-1.fc17.x86_64
Comment 2 Michael Stahl 2012-04-10 13:18:28 EDT
due to an unfortunate interaction between the spec file
setting CFLAGS/CXXFLAGS to something that does not include
any optimization flags, and the LO build system in 3.5
newly respecting CFLAGS/CXXFLAGS passed to configure,
the 3.5 versions up to 3.5.2.1-3 were built
without any compiler optimization.

please try if your performance problem is gone
in version 3.5.2.1-4.
Comment 3 Hans de Goede 2012-04-10 15:31:29 EDT
I tested with 3.5.2.1-5.fc17 and the speed seems back to normal.
Comment 4 Fedora Update System 2012-04-12 10:19:50 EDT
libreoffice-3.5.2.1-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.2.1-6.fc17
Comment 5 Fedora Update System 2012-04-18 19:05:22 EDT
libreoffice-3.5.2.1-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.