Bug 80919

Summary: switching icons w/ gnome-theme-manager breaks desktop icons
Product: [Retired] Red Hat Public Beta Reporter: Daniel Resare <noa-bugzilla-redhat>
Component: control-centerAssignee: Jonathan Blandford <jrb>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: ddumas
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-14 22:54:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Daniel Resare 2003-01-02 13:19:17 UTC
Description of problem:

When i open gnome-theme-manager in a freshly installed account, select gnome
icons and then switch back to bluecurve icons, the $USER's Home and Trash icons
on the desktop disapperas and is replaced by ugly default icons.

Version-Release number of selected component (if applicable):
control-center-2.1.3-1

How reproducible:
always

Steps to Reproduce:
1. create a new account and log in
2. run gnome-theme-manager
3. select Gnome icons under the icons tab and then select Bluecurve icons.
    
Actual results:

Ugly default (empty paper) icons on the desktop

Expected results:

The same icons as on first login

Comment 1 Matthias Saou 2003-01-07 16:39:48 UTC
Apparent problem :

Under /usr/share/icons there is a "gnome" directory whereas it seems to be
expected as "Gnome". I remember the first time I went to change the icons, I had
the choice between three : "Bluecurve", "Gnome" and "gnome" and got the same
problem you did when I tried to click any of them.

Temporary workaround :

What I did (and it seems to circumvent the issue) :
ln -s gnome /usr/share/icons/Gnome
And I now have only the two correct and working choices, but when choosing
"Bluecurve" again I did get blurry (under/oversized?) icons for lock screen and
shutdown in my menus (bug 80749 it seems).

HTH,
Matthias

Comment 2 Jonathan Blandford 2003-01-14 22:54:47 UTC
Fixed in Rawhide/CVS.