Bug 810580

Summary: AMD Magny-cours processors have wrong topology
Product: [Community] Virtualization Tools Reporter: Tad Kollar <tad.kollar>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED DEFERRED QA Contact:
Severity: medium Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: crobinso, mzhan, rbalakri, xen-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-03-23 17:02:35 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tad Kollar 2012-04-06 16:41:13 EDT
Description of problem:
Magny-cours processors with 12 cores per physical socket should be detected as either having one socket and 12 cores, or possibly two sockets with 6 cores each. Instead they are detected as one socket and six cores, so only half the cores are usable by libvirt.

Version-Release number of selected component (if applicable):
0.9.11, 0.9.10, and possibly more after 0.9.4.

How reproducible:
Always.

Steps to Reproduce:
1. Run virsh capabilities on a host with an AMD Opteron 6174 or similar processor
2. Examine the topology entry
3.
  
Actual results:
<capabilities>

  <host>
    <uuid>48385147-3600-0030-48fe-003048fe7e7e</uuid>
    <cpu>
      <arch>x86_64</arch>
      <model>Opteron_G3</model>
      <vendor>AMD</vendor>
      <topology sockets='4' cores='6' threads='1'/>
...

Expected results:
<capabilities>

  <host>
    <uuid>48385147-3600-0030-48fe-003048fe7e7e</uuid>
    <cpu>
      <arch>x86_64</arch>
      <model>Opteron_G3</model>
      <vendor>AMD</vendor>
      <topology sockets='4' cores='12' threads='1'/>
...

Additional info:
There seems to be confusion between the topology reported by numa and the physical topology that's causing the problem. Numa detects 8 sockets with 6 cores each, yet there are four physical sockets with 12 cores. The issue did not exist in libvirt 0.9.4.
Comment 1 Cole Robinson 2016-03-23 17:02:35 EDT
Sorry this never received a response. I'm not sure if this was ever fixed since I don't have that system. If you can still reproduce with newer libvirt please reopen this bug and provide /proc/cpuinfo