Bug 811438

Summary: 17 Beta RC4 KDE Lives are oversized (larger than 700 MiB)
Product: [Fedora] Fedora Reporter: Andre Robatino <robatino>
Component: livecd-toolsAssignee: Brian Lane <bcl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: adam.stokes, awilliam, bcl, bruno, dennis, dhuff, Jasper.Hartline, jsmith.fedora, katzj, kevin, rdieter, satellitgo, tflink
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: livecd-tools-17.11-1.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-01 17:54:30 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 765956    

Description Andre Robatino 2012-04-11 00:32:47 EDT
Description of problem:
For 17 Beta RC4, the KDE Lives are too large:

Fedora-17-Beta-i686-Live-KDE.iso : 754974720

Fedora-17-Beta-x86_64-Live-KDE.iso : 752877568

Waiting to see if 17 Beta RC4.1 Lives will be small enough (<= 734003200 bytes = 700 MiB).

Version-Release number of selected component (if applicable):
17 Beta RC4
Comment 1 Adam Williamson 2012-04-11 00:35:35 EDT
+1 blocker. RC4.1 ought to fix this, if I'm right that the new livecd-creator causes this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Andre Robatino 2012-04-11 06:08:46 EDT
Confirmed fixed with RC4.1:

Fedora-17-Beta-i686-Live-KDE.iso : 718274560

Fedora-17-Beta-x86_64-Live-KDE.iso : 715128832

All other size and checksum tests pass for RC4.1 as well.
Comment 3 Adam Williamson 2012-04-11 12:18:15 EDT
Please leave this open until go/no-go, as we have not made the decision what to ship as Beta.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Tim Flink 2012-04-11 13:34:20 EDT
+1 for F17 beta blocker
Comment 5 Jared Smith 2012-04-11 13:45:57 EDT
-1 blocker if we ship RC4.1.  +1 blocker if we ship RC4.  (Will y'all hate me if I add logic to my votes like that?)
Comment 6 Jared Smith 2012-04-11 13:54:13 EDT
For the record, my -1 and +1 votes are for Beta blocker.
Comment 7 Adam Williamson 2012-04-11 14:05:15 EDT
OK, this is accepted as a blocker. Of course, a decision to ship RC4.1 would result in this bug being considered closed. The impact of accepting this as a blocker is that we cannot choose to ship RC4.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Kevin Kofler 2012-04-12 11:29:47 EDT
(The current de-facto maintainer of the KDE live image speaking here.) What exactly changed in livecd-tools that made the images grow so much? Was that an intentional change? (I'd hope not!) I'm worried that the size issue might come back for Final.
Comment 9 Tim Flink 2012-04-12 11:37:01 EDT
(In reply to comment #8)
> (The current de-facto maintainer of the KDE live image speaking here.) What
> exactly changed in livecd-tools that made the images grow so much? Was that an
> intentional change? (I'd hope not!) I'm worried that the size issue might come
> back for Final.

My understanding is that the change had to do mostly with support for apple's EFI (I think that another boot image is added) but I'm not intimately familiar with the details.

However, I suspect that you are correct in assuming that the problem will come back once we do make the move to newer livecd-creator.
Comment 10 Kevin Kofler 2012-04-12 11:41:25 EDT
This is a 35 MiB (!) size hit, it's not something we can take in the KDE live image, especially this late in the release cycle. I see the offending livecd-tools already went stable (or I'd have karma'd them down into oblivion). This really needs to get reverted for Final.
Comment 11 Kevin Kofler 2012-04-12 11:45:54 EDT
(The x86_64 image even grew by 36 MiB.)
Comment 12 Kevin Kofler 2012-04-12 11:48:07 EDT
5% (i686) resp. 5.14% (x86_64) of the entire available media size is taken up by the added bloat!
Comment 13 Adam Jackson 2012-04-12 13:30:56 EDT
(In reply to comment #10)
> This really needs to get reverted for Final.

You have a bad habit of saying "reverted" when you ought to say "fixed".  Perhaps you could work on that.
Comment 14 Bill Nottingham 2012-04-12 13:51:14 EDT
(In reply to comment #10)
> This is a 35 MiB (!) size hit, it's not something we can take in the KDE live
> image, especially this late in the release cycle. I see the offending
> livecd-tools already went stable (or I'd have karma'd them down into oblivion).
> This really needs to get reverted for Final.

Fixed seems to be simpler.

<mjg59> tflink: Ok, turns out the kernel and initramfs were being included in the efi boot images, despite not being needed

Moving to livecd-tools.
Comment 15 Kevin Kofler 2012-04-12 15:06:04 EDT
Glad to hear that the massive size increase is a bug that should be easy to fix, I'm looking forward to a fix.
Comment 16 Adam Williamson 2012-04-13 18:00:29 EDT
kev: BTW, the livecd-tools was pushed stable because that's the only way we could actually build RC4 with it, apparently. FWIW I do think we made a mistake in taking it as NTH for RC4, I've put that in the QA retrospective. We should have stuck with 17.4 for Beta.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Adam Williamson 2012-04-13 18:02:31 EDT
Secretaryizing after the fact - at the go/no-go meeting - http://meetbot.fedoraproject.org/fedora-meeting-1/2012-04-11/f17_beta_go_no_go_meeting.2012-04-11-21.00.html - we decided to ship the RC4.1 live images, which are the ones respun with livecd-creator 17.4. Consequently this bug is demoted from blocker status because the images we're actually shipping are fine. Not closing the bug because it's being used to track the actual bug in 17.7 which resulted in the large images.
Comment 18 Kevin Kofler 2012-04-13 18:46:26 EDT
This is NOT fixed in 17.7.
Comment 19 Brian Lane 2012-04-13 20:02:57 EDT
Sorry, should have been 17.8-1
Comment 20 Kevin Kofler 2012-04-14 07:35:47 EDT
When will 17.8 be built and filed in Bodhi?
Comment 21 Fedora Update System 2012-04-16 20:56:09 EDT
livecd-tools-16.12-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.12-1.fc16
Comment 22 Fedora Update System 2012-04-16 20:57:12 EDT
livecd-tools-17.8-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.8-1.fc17
Comment 23 Fedora Update System 2012-04-18 15:43:18 EDT
Package livecd-tools-16.12-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-16.12-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6062/livecd-tools-16.12-1.fc16
then log in and leave karma (feedback).
Comment 24 Kevin Kofler 2012-04-21 17:15:18 EDT
Proposing as blocker for F17 Final per the image size criterion.
Comment 25 Fedora Update System 2012-04-24 18:14:31 EDT
livecd-tools-17.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.9-1.fc17
Comment 26 Fedora Update System 2012-04-25 14:08:36 EDT
livecd-tools-16.13-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.13-1.fc16
Comment 27 Tim Flink 2012-04-26 14:46:21 EDT
This appears to have been fixed for final TC1 - I'm seeing 684M for the kde live cd.

I'm wondering if this can be closed but it would be a clear violation of the release criteria if it is still valid.

+1 blocker if it isn't closed
Comment 28 Fedora Update System 2012-04-26 18:10:15 EDT
livecd-tools-17.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.10-1.fc17
Comment 29 Kevin Kofler 2012-04-26 20:33:14 EDT
What version of livecd-tools was used to spin TC1?
Comment 30 Rex Dieter 2012-04-28 16:14:17 EDT
I can confirm building kde spin with livecd-tools-17.10-1.fc17.x86_64 and current spin-kickstarts f17 branch is < 700 MiB
Comment 31 Tim Flink 2012-05-01 17:54:30 EDT
Since the specific issue has been fixed, I'm closing the bug.
Comment 32 Fedora Update System 2012-05-03 19:18:48 EDT
livecd-tools-16.15-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.15-1.fc16
Comment 33 Fedora Update System 2012-05-03 19:34:38 EDT
livecd-tools-17.11-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.11-1.fc17
Comment 34 Fedora Update System 2012-05-08 00:32:51 EDT
livecd-tools-17.11-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.