This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours

Bug 812165

Summary: 3.x kernels break sound of laptop docking
Product: [Fedora] Fedora Reporter: Christoph Wickert <cwickert>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 17CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---Keywords: HardwareEnablement, Regression
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-12 19:51:21 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Christoph Wickert 2012-04-12 19:46:18 EDT
Description of problem:
I have a Thinkpad X201 with docking and a set of speakers attached to it. All of Fedora's 3.x kernels break sound output of the docking, the speakers remain silent. When I however plug the speakers directly into the laptop output, they work fine.

The docking does not have a sound card, just line-out and mic-in. If I plug the speakers into the docking or the laptop itself, the internal speaker is turned of, but I guess this is done in hardware.

Version-Release number of selected component (if applicable):
kernel-3.3.0-1.fc17.x86_64
kernel-3.3.0-8.fc17.x86_64
kernel-3.3.1-3.fc17.x86_64
kernel-3.3.1-5.fc17.x86_64

For testing I installed an kernel-2.6.42.12-1.fc15.x86_64 and sound on the docking works fine.

How reproducible:
always

Steps to Reproduce:
1. upgrade from F15 to F17
  
Actual results:
no more sound.

Expected results:
Let there be sound!

Additional info:
My smolt profile: http://www.smolts.org/client/show/pub_260fd7f2-040f-4d1f-8d60-1c8d0c1ff861
Comment 1 Christoph Wickert 2012-04-12 19:51:21 EDT

*** This bug has been marked as a duplicate of bug 806217 ***