Bug 812528

Summary: creating LV partitions sometimes overwrites previous definitions
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: anacondaAssignee: David Lehman <dlehman>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: anaconda-maint-list, awilliam, g.kaviyarasu, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedNTH
Fixed In Version: anaconda-17.26-1.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-12 12:21:52 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752653    
Attachments:
Description Flags
bug video demonstration
none
anaconda.log
none
program.log
none
storage.log
none
syslog
none
X.log
none
storage.state none

Description Kamil Páral 2012-04-14 08:57:31 EDT
Created attachment 577456 [details]
bug video demonstration

Description of problem:
When I do a custom layout and create new LV partitions, I have found a way where first I create root partition and then I try to add swap partition, but the swap partition definition overwrites the root partition definition (the root partition disappears). It's more obvious from the attached video.

Simple workaround is present, just name your partition differently from default "lv". It is then not overwritten.

Version-Release number of selected component (if applicable):
anaconda 17.20

How reproducible:
always

Steps to Reproduce:
1. follow the steps in the video
Comment 1 Kamil Páral 2012-04-14 08:59:07 EDT
Even though this bug is not critical, it might be confusing (people might not notice that some partitions were overwritten by another ones). Proposing as at least NTH. A full blocker may be discussed as well.
Comment 2 Jesse Keating 2012-04-17 17:07:25 EDT
Would be useful to get the anaconda logs when this happens.  Any chance you can upload those?

https://fedoraproject.org/wiki/How_to_debug_installation_problems#Log_Files
Comment 3 Kamil Páral 2012-04-18 03:16:57 EDT
I suspected it as a UI bug, so I didn't expect anything useful to be shown in logs. Also it can be extremely easily reproduced. But here you go.

PS: X crashed when I switched to console, but that is not relevant in this case.
Comment 4 Kamil Páral 2012-04-18 03:17:16 EDT
Created attachment 578255 [details]
anaconda.log
Comment 5 Kamil Páral 2012-04-18 03:17:21 EDT
Created attachment 578256 [details]
program.log
Comment 6 Kamil Páral 2012-04-18 03:17:25 EDT
Created attachment 578257 [details]
storage.log
Comment 7 Kamil Páral 2012-04-18 03:17:30 EDT
Created attachment 578258 [details]
syslog
Comment 8 Kamil Páral 2012-04-18 03:17:34 EDT
Created attachment 578259 [details]
X.log
Comment 9 Kamil Páral 2012-04-18 03:17:45 EDT
Created attachment 578260 [details]
storage.state
Comment 10 Kamil Páral 2012-04-18 03:18:28 EDT
I reproduced exactly the same as you see in the video, then hit OK in the VG creation dialog and collected the logs.
Comment 11 Adam Williamson 2012-05-04 13:36:48 EDT
Discussed at 2012-05-04 NTH review meeting. This is accepted as NTH as it's a significant installer bug, but please note we are agreed that it would be bad to poke this code very late: let's say we take it as an NTH for the first week or so of the freeze, but after that, we might not want to take a change. Anaconda team, please check with QA and releng before pushing a fix for this into f17-branch. thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Fedora Update System 2012-05-09 20:02:22 EDT
anaconda-17.26-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.26-1.fc17
Comment 13 Kamil Páral 2012-05-10 04:37:10 EDT
This bug seems to be fixed in 17.26-1
Comment 14 Fedora Update System 2012-05-10 16:40:33 EDT
Package anaconda-17.26-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.26-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7623/anaconda-17.26-1.fc17
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2012-05-12 12:21:52 EDT
anaconda-17.26-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.