Bug 813580

Summary: [abrt] kernel: BUG: scheduling while atomic: irq/9-acpi/28/0x00000002
Product: [Fedora] Fedora Reporter: DanielH1987 <daniel.haenssgen>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:784e2b5ec99d2c407a8e031e1de362fcb77b195d
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-17 19:48:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description DanielH1987 2012-04-17 19:23:06 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.0.17-1.rt33.1.fc16.ccrma.x86_64.rt root=UUID=5727118c-c059-4245-827d-a3815ce1394f ro rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=de_DE.UTF-8 KEYTABLE=de-latin1-nodeadkeys
kernel:         3.0.17-1.rt33.1.fc16.ccrma.x86_64.rt
reason:         BUG: scheduling while atomic: irq/9-acpi/28/0x00000002
time:           Mi 18 Apr 2012 03:16:56 CEST

backtrace:
:BUG: scheduling while atomic: irq/9-acpi/28/0x00000002
:1 lock held by irq/9-acpi/28:
: #0:  (acpi_gbl_gpe_lock){+.+...}, at: [<ffffffff812adec4>] acpi_ev_gpe_detect+0x35/0x149
:Modules linked in: be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi 8021q garp stp llc lockd fcoe libfcoe libfc scsi_transport_fc scsi_tgt ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ip6_tables snd_hda_codec_analog snd_hda_intel snd_hda_codec snd_hwdep snd_seq arc4 snd_seq_device b43 snd_pcm mac80211 cfg80211 snd_timer ssb snd edac_core mmc_core tg3 soundcore hp_wmi k8temp snd_page_alloc i2c_piix4 edac_mce_amd sparse_keymap tpm_infineon rfkill uinput joydev sunrpc serio_raw shpchp firewire_ohci ata_generic firewire_core pata_acpi yenta_socket crc_itu_t pata_atiixp sata_sil wmi video radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 28, comm: irq/9-acpi Not tainted 3.0.17-1.rt33.1.fc16.ccrma.x86_64.rt #1
:Call Trace:
: [<ffffffff814e849b>] __schedule_bug+0x75/0x7a
: [<ffffffff814ef8bc>] __schedule+0x8c/0x68a
: [<ffffffff8108bc80>] ? trace_hardirqs_off+0xd/0xf
: [<ffffffff814f02f1>] schedule+0x74/0x90
: [<ffffffff814f13dc>] rt_spin_lock_slowlock+0x1d6/0x288
: [<ffffffff814f1367>] ? rt_spin_lock_slowlock+0x161/0x288
: [<ffffffff8108bc80>] ? trace_hardirqs_off+0xd/0xf
: [<ffffffff814f1aa0>] rt_spin_lock+0x2c/0x56
: [<ffffffff810749ad>] __queue_work+0x1bd/0x1ec
: [<ffffffff81074a55>] queue_work_on+0x4c/0x5c
: [<ffffffff8129a751>] __acpi_os_execute+0x147/0x177
: [<ffffffff812ada1a>] ? acpi_os_allocate_zeroed+0x32/0x32
: [<ffffffff8129a791>] acpi_os_execute+0x10/0x12
: [<ffffffff812ade38>] acpi_ev_gpe_dispatch+0xe7/0x13e
: [<ffffffff812adf86>] acpi_ev_gpe_detect+0xf7/0x149
: [<ffffffff810c4135>] ? irq_thread_fn+0x3c/0x3c
: [<ffffffff812ac176>] acpi_ev_sci_xrupt_handler+0x22/0x2b
: [<ffffffff8129a80b>] acpi_irq+0x16/0x31
: [<ffffffff810c415a>] irq_forced_thread_fn+0x25/0x45
: [<ffffffff814f253e>] ? _raw_spin_unlock_irq+0x4c/0x59
: [<ffffffff810c4002>] irq_thread+0x101/0x1f8
: [<ffffffff810c3f01>] ? irq_finalize_oneshot+0xb6/0xb6
: [<ffffffff81079b26>] kthread+0x99/0xa1
: [<ffffffff8108bc80>] ? trace_hardirqs_off+0xd/0xf
: [<ffffffff8108f893>] ? trace_hardirqs_on+0xd/0xf
: [<ffffffff814f9624>] kernel_thread_helper+0x4/0x10
: [<ffffffff814f28d8>] ? retint_restore_args+0x13/0x13
: [<ffffffff81079a8d>] ? __init_kthread_worker+0x8c/0x8c
: [<ffffffff814f9620>] ? gs_change+0x13/0x13

smolt_data:
:
:
:Allgemein
:=================================
:UUID: f433188c-81ea-4473-b042-2d76613fd628
:OS: Fedora release 16 (Verne)
:Standard-Runlevel: Unknown
:Sprache: de_DE.UTF-8
:Plattform: x86_64
:BogoMIPS: 3191.35
:CPU-Anbieter: AuthenticAMD
:CPU-Modell: AMD Turion(tm) 64 X2 Mobile Technology TL-52
:CPU-Stepping: 2
:CPU Familie: 15
:CPU-Modellnummer: 72
:Anzahl der CPUs: 2
:CPU-Geschwindigkeit: 1595
:Systemspeicher: 1861
:System-Swap: 3191
:Anbieter: Hewlett-Packard
:System: HP Compaq nx6325 (EY350EA#ABD) F.07
:Form-Faktor: Notebook
:Kernel: 3.0.17-1.rt33.1.fc16.ccrma.x86_64.rt
:SELinux aktiviert: 1
:SELinux-Richtlinie: targeted
:SELinux erzwingen: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Geräte
:=================================
:(4098:23096:4156:12464) pci, pcieport, PCI/PCI, RS480 PCI Bridge
:(4172:32826:4156:12464) pci, firewire_ohci, FIREWIRE, PCIxx12 OHCI Compliant IEEE 1394 Host Controller
:(4172:32825:4156:12464) pci, yenta_cardbus, PCI/CARDBUS, PCIxx12 Cardbus Controller
:(4098:17270:4156:12464) pci, pata_atiixp, STORAGE, IXP SB400 IDE Controller
:(4098:17266:4156:12464) pci, piix4_smbus, SERIAL, IXP SB400 SMBus Controller
:(4098:17271:4156:12464) pci, None, PCI/ISA, IXP SB400 PCI-ISA Bridge
:(4098:17275:12464:4156) pci, HDA Intel, MULTIMEDIA, IXP SB4x0 High Definition Audio Controller
:(4098:17265:0:0) pci, None, PCI/PCI, IXP SB400 PCI-PCI Bridge
:(5348:17170:4156:4961) pci, b43-pci-bridge, NETWORK, Broadcom 802.11a/b/g WLAN
:(4098:23103:4156:12464) pci, None, PCI/PCI, RS480 PCI Bridge
:(4098:22901:4156:12464) pci, radeon, VIDEO, RS482 [Radeon Xpress 200M]
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4130:4354:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4098:17267:4156:12464) pci, ehci_hcd, USB, IXP SB400 USB2 Host Controller
:(5348:5788:4156:12464) pci, tg3, ETHERNET, NetXtreme BCM5788 Gigabit Ethernet
:(4098:22864:4156:12464) pci, None, HOST/PCI, RS480 Host Bridge
:(4098:17269:4156:12464) pci, ohci_hcd, USB, IXP SB400 USB Host Controller
:(4098:17268:4156:12464) pci, ohci_hcd, USB, IXP SB400 USB Host Controller
:(4098:17273:4156:12464) pci, sata_sil, STORAGE, IXP SB400 Serial ATA Controller
:
:
:Dateisysteminformationen
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 23233020 21368570 21132596 5906432 5619992 5619992
:
Comment 1 Josh Boyer 2012-04-17 19:48:41 EDT

*** This bug has been marked as a duplicate of bug 126342 ***