Bug 814585

Summary: icedtea-web rpm does not provide javaws
Product: [Fedora] Fedora Reporter: Marko Myllynen <myllynen>
Component: icedtea-webAssignee: Deepak Bhole <dbhole>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: dbhole, omajid
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 682674 Environment:
Last Closed: 2012-05-03 14:20:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marko Myllynen 2012-04-20 07:21:58 UTC
+++ This bug was initially created as a clone of Bug #682674 +++

Description of problem:
icedtea-web package should provide "javaws" since it provides Java Web Start implementation - now some packages requiring javaws pull in the Sun package needlessly.

Version-Release number of selected component (if applicable):
icedtea-web-1.2-2.fc17.x86_64

Comment 1 Deepak Bhole 2012-04-20 15:41:07 UTC
Fedora does not have the Sun/Oracle or IBM JDK. IMO a virtual provides for javaws is not needed there.

Comment 2 Marko Myllynen 2012-04-23 08:11:43 UTC
> Fedora does not have the Sun/Oracle or IBM JDK.

Correct, the paste was relevant only for RHEL.

> IMO a virtual provides for javaws is not needed there.

The case I had in mind were possible 3rd party RPMs created for RHEL which now fail to install on Fedora. However, those RPMs could/should Require java-plugin instead of javaws.

I'm ok either way, please feel free to close this one if you think javaws is not needed on Fedora.

Thanks.

Comment 3 Deepak Bhole 2012-05-03 14:20:38 UTC
Hi Marko. I have made the change and pushed it into git for f17/rawhide. Though I am not rebuilding now, the next build will automatically have this fix. 

Thanks for reporting it!