Bug 814696

Summary: When installing, after reboot only black screen with "X" cursor shows up instead of firstboot
Product: [Fedora] Fedora Reporter: Michal Trunecka <mtruneck>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: airlied, ajax, awilliam, bcl, bskeggs, deejay1, ebenes, kparal, mkrizek, satellitgo, tflink
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-02 22:15:08 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Logs from installed system none

Description Michal Trunecka 2012-04-20 08:51:13 EDT
Created attachment 578998 [details]
Logs from installed system

Description of problem:

When installing fedora 17 Beta Live KDE from USB to dualboot (Lenovo T420s), first part of installation went ok, but after reboot only black screen with "X" mouse cursor shows up.

If Ctrl-Alt-Backspace is pressed, system goes directly to KDE login screen.

Last line in /var/log/boot.log is:
"Starting firstboot configuration program (graphical mode)..."

/var/log/messages file is attached to this bug, probably most important part is this:

Apr 20 15:43:44 dhcp-26-170 firstboot[682]: kdeinit4: Aborting. $HOME not set!kdeinit4: Aborting. $HOME not set!kwin(880): No ksycoca4 database available!
Apr 20 15:43:44 dhcp-26-170 firstboot[682]: kwin(880)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "KWin/Effect"  not found
Apr 20 15:43:44 dhcp-26-170 firstboot[682]: kdeinit4: Aborting. $HOME not set!kwin(880): Couldn't start kglobalaccel from kglobalaccel.desktop:  "KLauncher could not be reached via D-Bus. Error when calling start_service_by_desktop_path:
Apr 20 15:43:44 dhcp-26-170 firstboot[682]: The name org.kde.klauncher was not provided by any .service files
Apr 20 15:43:44 dhcp-26-170 firstboot[682]: "
Apr 20 15:43:45 dhcp-26-170 firstboot[682]: kdeinit4: Aborting. $HOME not set!kwin(880): Couldn't start knotify from knotify4.desktop:  "KLauncher could not be reached via D-Bus. Error when calling start_service_by_desktop_path:
Apr 20 15:43:45 dhcp-26-170 firstboot[682]: The name org.kde.klauncher was not provided by any .service files
Apr 20 15:43:45 dhcp-26-170 firstboot[682]: "



Version-Release number of selected component (if applicable):
Fedora 17 Beta

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Only black screen with "X" mouse cursor shows up.

Expected results:
Final part of installation should appear after reboot.

Additional info:
Comment 1 Adam Williamson 2012-04-20 15:28:29 EDT
Discussed at 2012-04-20 blocker review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-04-20/fedora-bugzappers.2012-04-20-17.01.log.txt . We agreed that, if as described it caused a blank screen with cursor after any install of KDE live, it'd obviously be a blocker, but we did not recall seeing any such effect in Beta validation testing. We agreed we needed to investigate further and delay the decision on blocker status.

Michael, did you really test simply a straight-through install of Beta live KDE? It wasn't a nightly or anything?
Comment 2 Michal Trunecka 2012-04-23 03:37:50 EDT
I have finally found the reason of this behaviour. The thing is I had second LCD monitor connected to my laptop and in spite of the fact it was unplugged! (of the socket) the system detected it and the rest of installation "displayed" on that monitor. That is the reason why my laptop screen remained black with mouse cursor.

This is probably not a blocker bug, but as long as the system is able to detect monitors that are not switched on, this behaviour is imo not ok.
Comment 3 Tim Flink 2012-04-26 13:30:26 EDT
OK, with the new information in c#2, I think that this is not a blocker.

-1 blocker, -1 NTH
Comment 4 Kamil Páral 2012-04-27 03:08:07 EDT
I already reported some bugs about invalid display detection. I can't say for sure I understood the case here, but I was told that we couldn't detect a display that is connected but switched off. It needs kernel support and driver support and none of it is in place. And it would work just for certain displays (supporting certain protocol extensions) anyway.

I'm afraid we can't do much here. Except asking for clone mode in anaconda/firstboot/gdm (but that still leaves problems for default extended mode after logging in).
Comment 5 Michal Trunecka 2012-04-30 04:42:07 EDT
Ok, I'll try to describe it in short again - After (proper, requested) reboot during installation, I see only black screen with X cursor, because switched off monitor was plugged in. It behaves so both with and without dockstation. If the switched off monitor had not been detected, the problem must have been somwhere else, but everything seems that it didn't.

I'm pretty sure I'm able to reproduce it, so if you are interested in further investigation I can provide the environment for it in RedHat Brno.
Comment 6 Martin Gracik 2012-05-02 09:04:13 EDT
*** Bug 753355 has been marked as a duplicate of this bug. ***
Comment 7 Martin Gracik 2012-05-02 09:08:02 EDT
Can you try setting kernel command line to "rdblacklist=nouveau nomodeset" during the first boot?
Comment 8 Michal Trunecka 2012-05-21 07:52:52 EDT
With the "rdblacklist=nouveau nomodeset" it correctly continues with the installation. During the boot is displayed ascii progress bar instead of the graphical Fedora logo, though.

For the record, in RHEL6.3 I'm currently running on it is posible to detect unplugged monitor and moreover it detects the vendor and the size of the monitor.
Comment 9 Ben Skeggs 2012-08-02 22:15:08 EDT
There is no way for the driver to know the monitor is not actually plugged in. 

The monitor's DDC circuitry is powered by the display connector, and responds (by design), not a bug.