Bug 814821

Summary: Support non-power of 2 chunk sizes when striping
Product: Red Hat Enterprise Linux 6 Reporter: Alasdair Kergon <agk>
Component: lvm2Assignee: Heinz Mauelshagen <heinzm>
lvm2 sub component: Striping (RHEL6) QA Contact: cluster-qe <cluster-qe>
Status: CLOSED WONTFIX Docs Contact:
Severity: medium    
Priority: medium CC: agk, dwysocha, heinzm, jbrassow, msnitzer, prajnoha, prockai, thornber, zkabelac
Version: 6.4Keywords: FutureFeature
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-12-17 18:22:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 814820    
Bug Blocks:    

Description Alasdair Kergon 2012-04-20 19:00:26 UTC
Make dm-striped bug 814820 available through lvm.

Comment 1 RHEL Program Management 2012-07-10 08:25:41 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 2 RHEL Program Management 2012-07-10 23:57:27 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 3 Tom Lavigne 2012-09-07 15:21:57 UTC
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Since we are unable to provide this feature at this time,  
it has been proposed for the next release of 
Red Hat Enterprise Linux.

Comment 4 Jonathan Earl Brassow 2015-10-15 14:36:28 UTC
Heinz, please check if this feature is already in RHEL6.  (We believe it is already in RHEL7.)

Comment 5 Heinz Mauelshagen 2015-10-16 08:21:21 UTC
It is not in upstream.
It is not in RHEL7 either.

Obviously it is not as important to the original requester (xfs?).

FWIW: non-power of 2 stripe sizes are incompatible with md, thus
      once we support takeover from striped -> raid0/raid4/raid5,
      non-power of 2 striped mappings ain't supported to be taken
      over to those dm-raid mappings; conversion by duplication will
      be possible though (i.e. lvm creating a new LV with the requested
      layout and sync the content of e.g. the striped LV across).