This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 815812

Summary: mysql 5.5.22-1 fails to start on Fedora 16 cloud server
Product: [Fedora] Fedora Reporter: Dan Prince <dprince>
Component: mysqlAssignee: Tom Lane <tgl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: apevec, hhorak, tgl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-24 11:20:03 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dan Prince 2012-04-24 10:55:54 EDT
Description of problem:

Clean install of mysql-server-5.5.22-1 fails to start on Fedora 16.

Version-Release number of selected component (if applicable):

[root@nova1 ~]# rpm -qa | grep mysql
mysql-libs-5.5.22-1.fc16.x86_64
ruby-mysql-2.8.2-3.fc16.x86_64
mysql-5.5.22-1.fc16.x86_64
mysql-server-5.5.22-1.fc16.x86_64

How reproducible:

Always.


Steps to Reproduce:
1. Yum install mysql-server
2. Start MySQL Server (service mysqld start)
3. Service fails to start... check logs.
  
Actual results:

(/var/log/mysqld.log)

120424 14:43:12 [Note] Plugin 'FEDERATED' is disabled.
120424 14:43:12 InnoDB: The InnoDB memory heap is disabled
120424 14:43:12 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120424 14:43:12 InnoDB: Compressed tables use zlib 1.2.5
120424 14:43:12 InnoDB: Using Linux native AIO
^G/usr/libexec/mysqld: Can't create/write to file '/tmp/ibR3SR0Q' (Errcode: 13)
120424 14:43:12  InnoDB: Error: unable to create temporary file; errno: 13
120424 14:43:12 [ERROR] Plugin 'InnoDB' init function returned error.
120424 14:43:12 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
120424 14:43:12 [ERROR] Unknown/unsupported storage engine: innodb
120424 14:43:12 [ERROR] Aborting

Expected results:

MySQL should startup cleanly.

Work Around:

If I Yum downgrade mysql-server, mysql, and mysql-libs I'm able to successfully startup MySQL:

yum downgrade mysql-server mysql mysql-libs

[root@login mysql]# rpm -qa | grep mysql
mysql-5.5.14-3.fc16.x86_64
mysql-libs-5.5.14-3.fc16.x86_64
mysql-server-5.5.14-3.fc16.x86_64

service mysqld start (service now starts and works correctly)

Additional info:

uname -a
Linux nova1 3.1.0-7.fc16.x86_64 #1 SMP Tue Nov 1 21:10:48 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

I'm running this version of MySQL on a Rackspace Cloud Server instance.
Comment 1 Dan Prince 2012-04-24 11:06:47 EDT
Looks like this may be somewhat of a duplicate of 782513.

If you 'yum update systemd' the latest version (5.5.22) of MySQL seems to work fine.
Comment 2 Alan Pevec 2012-04-24 11:13:29 EDT
(copying last comment from bug 782513)

> But the thing is, we do not test nor encourage selective updates in Fedora.
> Most packagers just assume you update all packages.
This is a system where there was no update since it was installed, the problem
occurred when I installed mysql. I only selectively updated systemd to see if
it would fix the problem I was having. Keeping my system up to date also have
avoided the problem but I would have thought installing mysql would update
systemd if required.
Comment 3 Honza Horak 2012-04-24 11:20:03 EDT
(In reply to comment #1)
> Looks like this may be somewhat of a duplicate of 782513.
> 
> If you 'yum update systemd' the latest version (5.5.22) of MySQL seems to work
> fine.

Yes, this is most probably the same issue. Closing this for now, but feel free
to reopen it if the problem persists even with the current systemd.

*** This bug has been marked as a duplicate of bug 782513 ***